aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-01-03 20:49:39 +0800
committerjbeich <jbeich@FreeBSD.org>2017-01-03 20:49:39 +0800
commit003a0750f9ef8361a85fda2cbc1f09362c708d66 (patch)
tree1469256abd4e099d9e0091af6618f1011270b470
parentb08c90f98c2e4a9abb0c3a6d1ebf987a19325f16 (diff)
downloadfreebsd-ports-gnome-003a0750f9ef8361a85fda2cbc1f09362c708d66.tar.gz
freebsd-ports-gnome-003a0750f9ef8361a85fda2cbc1f09362c708d66.tar.zst
freebsd-ports-gnome-003a0750f9ef8361a85fda2cbc1f09362c708d66.zip
Drop pre-10.3 support in my ports
Figuring out which GCC hacks are safe to drop is tricky but at least devel/fb-adb is limited to x86 due to ADA bootstrap.
-rw-r--r--devel/android-tools-adb/Makefile6
-rw-r--r--devel/android-tools-simpleperf/Makefile8
-rw-r--r--devel/fb-adb/Makefile4
-rw-r--r--devel/fb-adb/files/patch-util.c12
-rw-r--r--emulators/citra/files/patch-externals_dynarmic_src_common_mp.h34
-rw-r--r--emulators/ppsspp/Makefile3
-rw-r--r--graphics/colmap/Makefile3
-rw-r--r--multimedia/libmtp/Makefile12
-rw-r--r--sysutils/android-file-transfer/Makefile4
-rw-r--r--sysutils/android-file-transfer/files/libusb-1.0.pc11
-rw-r--r--sysutils/fusefs-simple-mtpfs/Makefile4
11 files changed, 1 insertions, 100 deletions
diff --git a/devel/android-tools-adb/Makefile b/devel/android-tools-adb/Makefile
index fb8e20da9040..b546703aec51 100644
--- a/devel/android-tools-adb/Makefile
+++ b/devel/android-tools-adb/Makefile
@@ -69,12 +69,6 @@ TEST_ALL_TARGET= adb_test
pre-install-TEST-on: do-test
post-patch:
-# XXX C++ exception with description "regex_error" thrown in the test body.
- @if [ ${OPSYS} = FreeBSD -a ${OSREL:R} -lt 10 ]; then \
- ${REINPLACE_CMD} -Ee '/^TEST/\
- s/ (LOG|PLOG|UNIMPLEMENTED)/ DISABLED_\1/' \
- ${WRKSRC}/base/logging_test.cpp; \
- fi
# XXX Hidden by poudriere/tinderbox, see lindev(4) for FreeBSD < 11.0
@if [ ! -e /dev/full ]; then \
${REINPLACE_CMD} -e '/TEST/s/[^ ]*ENOSPC/DISABLED_&/' \
diff --git a/devel/android-tools-simpleperf/Makefile b/devel/android-tools-simpleperf/Makefile
index b5a050f6514a..d6286bace711 100644
--- a/devel/android-tools-simpleperf/Makefile
+++ b/devel/android-tools-simpleperf/Makefile
@@ -40,14 +40,6 @@ post-extract:
# Adjust paths relative to extras
@(cd ${WRKSRC_core} && ${COPYTREE_SHARE} . ${WRKSRC})
-post-patch:
-# XXX C++ exception with description "regex_error" thrown in the test body.
- @if [ ${OPSYS} = FreeBSD -a ${OSREL:R} -lt 10 ]; then \
- ${REINPLACE_CMD} -Ee '/^TEST/\
- s/ (LOG|PLOG|UNIMPLEMENTED)/ DISABLED_\1/' \
- ${WRKSRC}/base/logging_test.cpp; \
- fi
-
pre-install-TEST-on: do-test
.include <bsd.port.mk>
diff --git a/devel/fb-adb/Makefile b/devel/fb-adb/Makefile
index f199dd58b7d0..8ddbeee41bf3 100644
--- a/devel/fb-adb/Makefile
+++ b/devel/fb-adb/Makefile
@@ -68,11 +68,7 @@ NDK_CONFIGURE_ENV= ANDROID_NDK="${WRKSRC_ndk}" \
NDK_TMPDIR="${WRKDIR}"
NDK_BUILD_DEPENDS_OFF= ${LOCALBASE}/android/ARMv7/bin/arm-aux-linux-androideabi-gcc:lang/gnatdroid-armv7 \
${LOCALBASE}/android-x86/x86_32/bin/i686-aux-linux-android-gcc:lang/gnatdroid-x86
-.if defined(.PARSEDIR)
NDK_CONFIGURE_ENV_OFF= PATH="${NDK_BUILD_DEPENDS_OFF:C/:.*//:H:ts:}:$$PATH"
-.else
-NDK_CONFIGURE_ENV_OFF= PATH="${LOCALBASE}/android/ARMv7/bin:${LOCALBASE}/android-x86/x86_32/bin:$$PATH"
-.endif
NDK_CONFIGURE_OFF= --with-android-ndk=system
post-extract:
diff --git a/devel/fb-adb/files/patch-util.c b/devel/fb-adb/files/patch-util.c
deleted file mode 100644
index a147a187eaea..000000000000
--- a/devel/fb-adb/files/patch-util.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- util.c.orig 2015-10-09 22:02:18 UTC
-+++ util.c
-@@ -1563,3 +1563,9 @@ xregerror(int errcode, const regex_t* pr
- reslist_xfer(rl->parent, rl);
- return (char*) gb.buf;
- }
-+
-+#ifndef __linux__
-+// XXX For GCC 4.4 or older
-+__weak_reference(my_unreachable, __builtin_unreachable);
-+void my_unreachable() { abort(); }
-+#endif
diff --git a/emulators/citra/files/patch-externals_dynarmic_src_common_mp.h b/emulators/citra/files/patch-externals_dynarmic_src_common_mp.h
deleted file mode 100644
index 6e732890460e..000000000000
--- a/emulators/citra/files/patch-externals_dynarmic_src_common_mp.h
+++ /dev/null
@@ -1,34 +0,0 @@
-std::tuple_element_t appeared in FreeBSD 10.2 (libcxx r202673) but
-USES=compiler cannot pull newer C++14-compatible libc++ version.
-
- In file included from externals/dynarmic/src/frontend/disassembler/disassembler_arm.cpp:15:
- In file included from externals/dynarmic/src/./frontend/decoder/arm.h:18:
- In file included from externals/dynarmic/src/./frontend/decoder/decoder_detail.h:14:
- externals/dynarmic/src/./common/mp.h:34:27: fatal error: no template named 'tuple_element_t' in namespace 'std'; did you mean 'tuple_element'?
- using type = std::tuple_element_t<ParameterIndex, std::tuple<Args...>>;
- ~~~~~^~~~~~~~~~~~~~~
- tuple_element
- /usr/include/c++/v1/__tuple:44:62: note: 'tuple_element' declared here
- template <size_t _Ip, class _Tp> class _LIBCPP_TYPE_VIS_ONLY tuple_element;
- ^
-
---- externals/dynarmic/src/common/mp.h.orig 2016-09-14 22:03:09 UTC
-+++ externals/dynarmic/src/common/mp.h
-@@ -9,6 +9,17 @@
- #include <cstddef>
- #include <tuple>
-
-+#ifdef __FreeBSD__
-+#include <osreldate.h>
-+# if defined(_LIBCPP_VERSION) && __FreeBSD_version < 1001508
-+// Copied from <tuple>
-+namespace std {
-+ template <size_t _Ip, class ..._Tp>
-+ using tuple_element_t = typename tuple_element <_Ip, _Tp...>::type;
-+}
-+# endif
-+#endif
-+
- namespace Dynarmic {
- namespace mp {
-
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index 61766b357dcf..56952c5db083 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -76,9 +76,8 @@ post-patch:
do-install-SDL-on:
# cmake doesn't pack assets into the app unlike qmake
-# XXX Convert to ${PORTDATA:N${PORTNAME}} once fmake is EOL
(cd ${INSTALL_WRKSRC} && ${COPYTREE_SHARE} \
- "${PORTDATA:Nppsspp}" ${STAGEDIR}${DATADIR})
+ "${PORTDATA:N${PORTNAME}}" ${STAGEDIR}${DATADIR})
# Install the app alongside assets to avoid warnings with GetExeDirectory()
${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${PORTNAME:tu}* \
${STAGEDIR}${DATADIR}/${PORTNAME}
diff --git a/graphics/colmap/Makefile b/graphics/colmap/Makefile
index 2b741569b196..69038bad9d1f 100644
--- a/graphics/colmap/Makefile
+++ b/graphics/colmap/Makefile
@@ -41,9 +41,6 @@ TEST_TARGET= test ARGS="-V"
OPTIONS_DEFINE= DOCS OPENMP SIMD
OPTIONS_DEFAULT= OPENMP SIMD
-# XXX ports/215138: exclude still broken
-OPTIONS_EXCLUDE= ${OPTIONS_EXCLUDE_${OPSYS}_${OSREL}} # not OSREL:R
-OPTIONS_EXCLUDE_FreeBSD_10.1= OPENMP
DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
DOCS_USES= gmake
diff --git a/multimedia/libmtp/Makefile b/multimedia/libmtp/Makefile
index cad465a6aa47..5dde7dc96d54 100644
--- a/multimedia/libmtp/Makefile
+++ b/multimedia/libmtp/Makefile
@@ -26,16 +26,4 @@ MTPZ_DESC= Enable functionality to connect to MTPZ devices
MTPZ_CONFIGURE_ENABLE= mtpz
MTPZ_LIB_DEPENDS= libgcrypt.so:security/libgcrypt
-.if !exists(/usr/libdata/pkgconfig/libusb-1.0.pc)
-CONFIGURE_ENV+= LIBUSB_CFLAGS=" " LIBUSB_LIBS="-lusb"
-.endif
-
-post-patch:
-.if !exists(/usr/libdata/pkgconfig/libusb-1.0.pc)
- @${REINPLACE_CMD} -i .pkgconf.bak -e \
- '/LIBUSB_REQUIRES/s|libusb-1.0||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -i .pkgconf.bak -e \
- '/Libs.private/s|:|& @LIBUSB_LIBS@|' ${WRKSRC}/libmtp.pc.in
-.endif
-
.include <bsd.port.mk>
diff --git a/sysutils/android-file-transfer/Makefile b/sysutils/android-file-transfer/Makefile
index a68c3b6b4f3d..b3a1af08b46f 100644
--- a/sysutils/android-file-transfer/Makefile
+++ b/sysutils/android-file-transfer/Makefile
@@ -48,10 +48,6 @@ QT5_PLIST_FILES=bin/android-file-transfer \
share/applications/android-file-transfer.desktop \
share/icons/hicolor/128x128/apps/android-file-transfer.png
-.if !exists(/usr/libdata/pkgconfig/libusb-1.0.pc)
-CONFIGURE_ENV+= PKG_CONFIG_PATH="${FILESDIR}"
-.endif
-
post-patch-CLI-off:
@${REINPLACE_CMD} '/subdirectory(cli)/d' ${WRKSRC}/CMakeLists.txt
diff --git a/sysutils/android-file-transfer/files/libusb-1.0.pc b/sysutils/android-file-transfer/files/libusb-1.0.pc
deleted file mode 100644
index 411fd3983b3b..000000000000
--- a/sysutils/android-file-transfer/files/libusb-1.0.pc
+++ /dev/null
@@ -1,11 +0,0 @@
-# $FreeBSD: head/lib/libusb/libusb-1.0.pc 267110 2014-06-05 14:19:32Z emaste $
-prefix=/usr
-exec_prefix=${prefix}
-libdir=${exec_prefix}/lib
-includedir=${prefix}/include
-
-Name: libusb-1.0
-Description: Library that abstracts ways to access USB devices (v1.0)
-Version: 1.0.13
-Libs: -L${libdir} -lusb
-Cflags: -I${includedir}
diff --git a/sysutils/fusefs-simple-mtpfs/Makefile b/sysutils/fusefs-simple-mtpfs/Makefile
index e2da0e335632..ccdcb4b87d87 100644
--- a/sysutils/fusefs-simple-mtpfs/Makefile
+++ b/sysutils/fusefs-simple-mtpfs/Makefile
@@ -26,10 +26,6 @@ PORTDOCS= AUTHORS NEWS README.md
OPTIONS_DEFINE= DOCS
-.if !exists(/usr/libdata/pkgconfig/libusb-1.0.pc)
-CONFIGURE_ENV+= LIBUSB1_CFLAGS=" " LIBUSB1_LIBS="-lusb"
-.endif
-
# XXX move to PREFIX when bug 193596 lands
.if exists(/etc/autofs)
PLIST_FILES+= /etc/autofs/special_${PORTNAME}