aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-02-20 03:44:02 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-02-20 03:44:02 +0800
commit007c5f0b5b4141f64a0398803b83c19a8243842d (patch)
tree4d7e817c44b5f8c4f7c5c8d3c4d8df0dcd0f1559
parentfdee9678a075d43b407de077d006c94ac937e6f6 (diff)
downloadfreebsd-ports-gnome-007c5f0b5b4141f64a0398803b83c19a8243842d.tar.gz
freebsd-ports-gnome-007c5f0b5b4141f64a0398803b83c19a8243842d.tar.zst
freebsd-ports-gnome-007c5f0b5b4141f64a0398803b83c19a8243842d.zip
- Add rubygem-fog-aws 0.1.0
Fog::Aws is a module for the 'fog' gem to support Amazon Web Services. WWW: https://github.com/fog/fog-aws RG: https://rubygems.org/gems/fog-aws
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-fog-aws/Makefile23
-rw-r--r--net/rubygem-fog-aws/distinfo2
-rw-r--r--net/rubygem-fog-aws/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 616e0789d30f..58e34ff109a3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1023,6 +1023,7 @@
SUBDIR += rubygem-domain_name
SUBDIR += rubygem-dropbox-sdk
SUBDIR += rubygem-fog-atmos
+ SUBDIR += rubygem-fog-aws
SUBDIR += rubygem-fog-ecloud
SUBDIR += rubygem-fog-profitbricks
SUBDIR += rubygem-fog-radosgw
diff --git a/net/rubygem-fog-aws/Makefile b/net/rubygem-fog-aws/Makefile
new file mode 100644
index 000000000000..ebaf84313747
--- /dev/null
+++ b/net/rubygem-fog-aws/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fog-aws
+PORTVERSION= 0.1.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Module for the 'fog' gem to support Amazon Web Services
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-fog-core>=1.27:${PORTSDIR}/devel/rubygem-fog-core \
+ rubygem-fog-json>=1.0:${PORTSDIR}/devel/rubygem-fog-json \
+ rubygem-fog-xml>=0.1:${PORTSDIR}/textproc/rubygem-fog-xml \
+ rubygem-ipaddress>=0.8:${PORTSDIR}/net/rubygem-ipaddress
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-fog-aws/distinfo b/net/rubygem-fog-aws/distinfo
new file mode 100644
index 000000000000..070110044357
--- /dev/null
+++ b/net/rubygem-fog-aws/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/fog-aws-0.1.0.gem) = 63da2e7539185be0ee2126c3860b10431a299d54c0e81d1900cd6c39e1a28596
+SIZE (rubygem/fog-aws-0.1.0.gem) = 414720
diff --git a/net/rubygem-fog-aws/pkg-descr b/net/rubygem-fog-aws/pkg-descr
new file mode 100644
index 000000000000..2bdbf721fcdc
--- /dev/null
+++ b/net/rubygem-fog-aws/pkg-descr
@@ -0,0 +1,4 @@
+Fog::Aws is a module for the 'fog' gem to support Amazon Web Services.
+
+WWW: https://github.com/fog/fog-aws
+RG: https://rubygems.org/gems/fog-aws