aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-25 01:46:24 +0800
committerpawel <pawel@FreeBSD.org>2012-11-25 01:46:24 +0800
commit00e3729af9e00d5d1b9c4e3eaae65c13eb2b396d (patch)
treea50648537c7a4605f03e35cb247d1f26bca8d9e9
parente34e6ac67c8101403b4398a1735ff68d3137939b (diff)
downloadfreebsd-ports-gnome-00e3729af9e00d5d1b9c4e3eaae65c13eb2b396d.tar.gz
freebsd-ports-gnome-00e3729af9e00d5d1b9c4e3eaae65c13eb2b396d.tar.zst
freebsd-ports-gnome-00e3729af9e00d5d1b9c4e3eaae65c13eb2b396d.zip
- Fix build with clang [1]
- Fix plist problems when building with clang PR: ports/172103 [1] Submitted by: Oliver Pinter <oliver.pntr@gmail.com> Feature safe: yes
-rw-r--r--x11/kdebase3/Makefile2
-rw-r--r--x11/kdebase3/files/patch-configure21
-rw-r--r--x11/kdebase3/files/patch-kicker-applet-launcher-easyvector.h29
3 files changed, 49 insertions, 3 deletions
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index ced8e5b76513..aa23960d4383 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -114,6 +114,8 @@ post-configure:
${WRKSRC}/kappfinder/apps/Graphics/ElectricEyes.desktop
${REINPLACE_CMD} -e 's/444/644/g' \
${WRKSRC}/kdesktop/init/Templates/Makefile
+ ${REINPLACE_CMD} -e 's|-fno-exceptions||' \
+ ${WRKSRC}/kioslave/thumbnail/Makefile
post-install:
${INSTALL_DATA} ${FILESDIR}/freebsd.keytab ${PREFIX}/share/apps/konsole/
diff --git a/x11/kdebase3/files/patch-configure b/x11/kdebase3/files/patch-configure
index 1bf1f3b4ce88..e3860fec5651 100644
--- a/x11/kdebase3/files/patch-configure
+++ b/x11/kdebase3/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2008-01-18 16:57:45.000000000 +0100
-+++ configure 2008-01-18 16:58:02.000000000 +0100
-@@ -51622,7 +51622,7 @@
+--- configure.orig 2008-08-20 18:01:56.000000000 +0200
++++ configure 2012-11-24 17:08:09.000000000 +0100
+@@ -51800,7 +51800,7 @@
{ echo "$as_me:$LINENO: checking HAL_LIBS" >&5
echo $ECHO_N "checking HAL_LIBS... $ECHO_C" >&6; }
@@ -9,3 +9,18 @@
{ echo "$as_me:$LINENO: result: $HAL_LIBS" >&5
echo "${ECHO_T}$HAL_LIBS" >&6; }
else
+@@ -53193,11 +53193,11 @@
+
+ ac_ext=cpp
+ ac_cpp='$CXXCPP $CPPFLAGS'
+-ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+-ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
++ac_compile='$CXX -c $CXXFLAGS $USE_EXCEPTIONS $CPPFLAGS conftest.$ac_ext >&5'
++ac_link='$CXX -o conftest$ac_exeext $CXXFLAGS $USE_EXCEPTIONS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS >&5'
+ ac_compiler_gnu=$ac_cv_cxx_compiler_gnu
+
+-ac_link='rm -rf SunWS_cache; ${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
++ac_link='rm -rf SunWS_cache; ${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $USE_EXCEPTIONS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
+
+
+ kde_save_CXXFLAGS="$CXXFLAGS"
diff --git a/x11/kdebase3/files/patch-kicker-applet-launcher-easyvector.h b/x11/kdebase3/files/patch-kicker-applet-launcher-easyvector.h
new file mode 100644
index 000000000000..cef0db344347
--- /dev/null
+++ b/x11/kdebase3/files/patch-kicker-applet-launcher-easyvector.h
@@ -0,0 +1,29 @@
+--- kicker/applets/launcher/easyvector.h.orig 2012-11-24 11:38:20.000000000 +0100
++++ kicker/applets/launcher/easyvector.h 2012-11-24 11:39:40.000000000 +0100
+@@ -87,7 +87,7 @@
+ template < class VALUE, bool CHECKINDEX >
+ void EasyVector< VALUE, CHECKINDEX >::eraseAt(Index index)
+ { _checkIndex(index);
+- erase(this->begin()+index);
++ this->erase(this->begin()+index);
+ }
+
+
+@@ -108,7 +108,7 @@
+ this->push_back(value);
+ return;
+ }
+- insert(this->begin()+index,value);
++ this->insert(this->begin()+index,value);
+ }
+
+
+@@ -116,7 +116,7 @@
+ void EasyVector< VALUE, CHECKINDEX >::insertAt(EasyVector< VALUE, CHECKINDEX >::Index index,const EasyVector< VALUE, CHECKINDEX > &v)
+ { index=_convertInsertIndex(index);
+ _checkInsertIndex(index);
+- insert(this->begin()+index,v.begin(),v.end());
++ this->insert(this->begin()+index,v.begin(),v.end());
+ }
+
+