aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-07-27 03:08:08 +0800
committerswills <swills@FreeBSD.org>2014-07-27 03:08:08 +0800
commit0228b8e7328557e8b0759784f7135f73541428cd (patch)
tree28e8180ba26e5161eb19accf180f0dc1b72c0790
parent861fe0af0b23e5b1dde0f7bbf121b3543c204a28 (diff)
downloadfreebsd-ports-gnome-0228b8e7328557e8b0759784f7135f73541428cd.tar.gz
freebsd-ports-gnome-0228b8e7328557e8b0759784f7135f73541428cd.tar.zst
freebsd-ports-gnome-0228b8e7328557e8b0759784f7135f73541428cd.zip
lang/ruby19: update to Ruby 1.9.3-p547
-rw-r--r--Mk/bsd.ruby.mk4
-rw-r--r--lang/ruby19/Makefile3
-rw-r--r--lang/ruby19/distinfo4
-rw-r--r--lang/ruby19/files/patch-thread_pthread.c19
4 files changed, 6 insertions, 24 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index acc65143d665..d55fb5ce1caf 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -177,9 +177,9 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
# Ruby 1.9
#
RUBY_RELVERSION= 1.9.3
-RUBY_PORTREVISION= 2
+RUBY_PORTREVISION= 0
RUBY_PORTEPOCH= 1
-RUBY_PATCHLEVEL= 484
+RUBY_PATCHLEVEL= 547
#
# PLIST_SUB helpers
diff --git a/lang/ruby19/Makefile b/lang/ruby19/Makefile
index 78a200519d00..b3cdde11141b 100644
--- a/lang/ruby19/Makefile
+++ b/lang/ruby19/Makefile
@@ -330,7 +330,8 @@ validate:
@${MKDIR} ${WRKSRC}/rubyspec
rm -rf ${WRKSRC}/rubyspec/*
(cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/rubyspec.git)
+ (cd ${WRKSRC}/rubyspec/rubyspec && git checkout 1.x)
(cd ${WRKSRC}/rubyspec && git clone git://github.com/rubyspec/mspec.git)
- (cd ${WRKSRC}/rubyspec/rubyspec && env PATH=${WRKSRC}/rubyspec/mspec/bin:${PATH} mspec -t ${STAGEDIR}${PREFIX}/bin/ruby${RUBY_SUFFIX})
+ (cd ${WRKSRC}/rubyspec/rubyspec && env PATH=${WRKSRC}/rubyspec/mspec/bin:${PATH} mspec -t ${PREFIX}/bin/ruby${RUBY_SUFFIX} .)
.include <bsd.port.post.mk>
diff --git a/lang/ruby19/distinfo b/lang/ruby19/distinfo
index d8d9d178b4ea..73cbd08fc908 100644
--- a/lang/ruby19/distinfo
+++ b/lang/ruby19/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/ruby-1.9.3-p484.tar.bz2) = 0fdc6e860d0023ba7b94c7a0cf1f7d32908b65b526246de9dfd5bb39d0d7922b
-SIZE (ruby/ruby-1.9.3-p484.tar.bz2) = 10041514
+SHA256 (ruby/ruby-1.9.3-p547.tar.bz2) = ef588ed3ff53009b4c1833c83187ae252dd6c20db45e21a326cd4a16a102ef4c
+SIZE (ruby/ruby-1.9.3-p547.tar.bz2) = 10036828
diff --git a/lang/ruby19/files/patch-thread_pthread.c b/lang/ruby19/files/patch-thread_pthread.c
deleted file mode 100644
index d3a182729038..000000000000
--- a/lang/ruby19/files/patch-thread_pthread.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- thread_pthread.c.orig 2013-03-28 10:10:00.000000000 +0000
-+++ thread_pthread.c 2014-01-25 02:59:12.085473158 +0000
-@@ -1193,13 +1193,13 @@
-
- pthread_attr_init(&attr);
- #ifdef PTHREAD_STACK_MIN
-- if (PTHREAD_STACK_MIN < 4096 * 3) {
-+ if (PTHREAD_STACK_MIN < 4096 * 4) {
- /* Allocate the machine stack for the timer thread
-- * at least 12KB (3 pages). FreeBSD 8.2 AMD64 causes
-+ * at least 16KB (4 pages). FreeBSD 8.2 AMD64 causes
- * machine stack overflow only with PTHREAD_STACK_MIN.
- */
- pthread_attr_setstacksize(&attr,
-- 4096 * 3 + (THREAD_DEBUG ? BUFSIZ : 0));
-+ 4096 * 4 + (THREAD_DEBUG ? BUFSIZ : 0));
- }
- else {
- pthread_attr_setstacksize(&attr,