aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-05-09 03:35:03 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-05-09 03:35:03 +0800
commit02aa8ef80c949ef1f70088b00b13f99cbc8c960a (patch)
tree8c8b4b60e11805deb2ab3c3f0601088f98429ec9
parent50b8a0081d247cd432f120545a4a418f48298521 (diff)
downloadfreebsd-ports-gnome-02aa8ef80c949ef1f70088b00b13f99cbc8c960a.tar.gz
freebsd-ports-gnome-02aa8ef80c949ef1f70088b00b13f99cbc8c960a.tar.zst
freebsd-ports-gnome-02aa8ef80c949ef1f70088b00b13f99cbc8c960a.zip
Add py-cbor 1.0.0
An implementation of RFC 7049 - Concise Binary Object Representation (CBOR). CBOR is comparable to JSON, has a superset of JSON's ability, but serializes to a binary format which is smaller and faster to generate and parse. The two primary functions are cbor.loads() and cbor.dumps(). This library includes a C implementation which runs 3-5 times faster than the Python standard library's C-accelerated implementanion of JSON. This is also includes a 100% Python implementation. WWW: https://pypi.org/project/cbor/ WWW: https://bitbucket.org/bodhisnarkva/cbor
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-cbor/Makefile21
-rw-r--r--devel/py-cbor/distinfo3
-rw-r--r--devel/py-cbor/pkg-descr13
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a4fccf9c4441..fabb7ce0a81b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4357,6 +4357,7 @@
SUBDIR += py-canonicaljson
SUBDIR += py-capstone
SUBDIR += py-castellan
+ SUBDIR += py-cbor
SUBDIR += py-cclib
SUBDIR += py-cdg
SUBDIR += py-celery
diff --git a/devel/py-cbor/Makefile b/devel/py-cbor/Makefile
new file mode 100644
index 000000000000..a8793683e42b
--- /dev/null
+++ b/devel/py-cbor/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cbor
+PORTVERSION= 1.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= RFC 7049 - Concise Binary Object Representation
+
+LICENSE= APACHE20
+
+USE_PYTHON= autoplist concurrent distutils
+USES= python
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cbor/_cbor.so
+
+.include <bsd.port.mk>
diff --git a/devel/py-cbor/distinfo b/devel/py-cbor/distinfo
new file mode 100644
index 000000000000..0255496d7fa3
--- /dev/null
+++ b/devel/py-cbor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523535472
+SHA256 (cbor-1.0.0.tar.gz) = 13225a262ddf5615cbd9fd55a76a0d53069d18b07d2e9f19c39e6acb8609bbb6
+SIZE (cbor-1.0.0.tar.gz) = 20096
diff --git a/devel/py-cbor/pkg-descr b/devel/py-cbor/pkg-descr
new file mode 100644
index 000000000000..1eba687d9d9c
--- /dev/null
+++ b/devel/py-cbor/pkg-descr
@@ -0,0 +1,13 @@
+An implementation of RFC 7049 - Concise Binary Object Representation (CBOR).
+
+CBOR is comparable to JSON, has a superset of JSON's ability, but serializes to
+a binary format which is smaller and faster to generate and parse.
+
+The two primary functions are cbor.loads() and cbor.dumps().
+
+This library includes a C implementation which runs 3-5 times faster than the
+Python standard library's C-accelerated implementanion of JSON. This is also
+includes a 100% Python implementation.
+
+WWW: https://pypi.org/project/cbor/
+WWW: https://bitbucket.org/bodhisnarkva/cbor