aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-09 21:24:47 +0800
committerbapt <bapt@FreeBSD.org>2014-05-09 21:24:47 +0800
commit033e3652428809ba783f089a9eb81d72b7f9ec2b (patch)
tree0de5dcc3af8de86b23f5a9ae07cc13cb2fad2572
parentd4cba4242bd1aef530498d99352acb05f32ff527 (diff)
downloadfreebsd-ports-gnome-033e3652428809ba783f089a9eb81d72b7f9ec2b.tar.gz
freebsd-ports-gnome-033e3652428809ba783f089a9eb81d72b7f9ec2b.tar.zst
freebsd-ports-gnome-033e3652428809ba783f089a9eb81d72b7f9ec2b.zip
Support stage
-rw-r--r--audio/festival-freebsoft-utils/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/audio/festival-freebsoft-utils/Makefile b/audio/festival-freebsoft-utils/Makefile
index eacd37de27d0..f15d569e1503 100644
--- a/audio/festival-freebsoft-utils/Makefile
+++ b/audio/festival-freebsoft-utils/Makefile
@@ -9,12 +9,13 @@ MASTER_SITES= http://www.freebsoft.org/pub/projects/${PORTNAME}/
MAINTAINER= avilla@FreeBSD.org
COMMENT= Festival utilities focused on interaction with Speech Dispatcher
+OPTIONS_DEFINE= DOCS
+
RUN_DEPENDS= festival:${PORTSDIR}/audio/festival \
sox:${PORTSDIR}/audio/sox
NO_BUILD= yes
USES= iconv
-NO_STAGE= yes
PORTDOCS= ANNOUNCE NEWS README
@@ -22,19 +23,13 @@ INFO= ${PORTNAME}
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
- ${MKDIR} ${LOCALBASE}/share/festival/lib
- cd ${WRKSRC} && ${INSTALL_DATA} *.scm ${LOCALBASE}/share/festival/lib
- cd ${WRKSRC}/doc && ${INSTALL_MAN} ${PORTNAME}.info ${PREFIX}/${INFO_PATH}
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/festival/lib
+ cd ${WRKSRC} && ${INSTALL_DATA} *.scm ${STAGEDIR}${PREFIX}/share/festival/lib
+ cd ${WRKSRC}/doc && ${INSTALL_MAN} ${PORTNAME}.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_MAN} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>