aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-01 21:11:22 +0800
committerbapt <bapt@FreeBSD.org>2014-07-01 21:11:22 +0800
commit03433fa0a5962fbb82e3d9abb4db837ac2efa6e2 (patch)
treeb0e9c3a6b1a8ddff4d221185acec6c9ce1853c0c
parent500baf8f24799cdb61a8ba55cfa51d42fdd13c9c (diff)
downloadfreebsd-ports-gnome-03433fa0a5962fbb82e3d9abb4db837ac2efa6e2.tar.gz
freebsd-ports-gnome-03433fa0a5962fbb82e3d9abb4db837ac2efa6e2.tar.zst
freebsd-ports-gnome-03433fa0a5962fbb82e3d9abb4db837ac2efa6e2.zip
Fix building with readline from ports and do not hardcode the gcc version
-rw-r--r--devel/libbobcat/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/libbobcat/Makefile b/devel/libbobcat/Makefile
index 5cfdbcc0750e..a9ed6fc93d2c 100644
--- a/devel/libbobcat/Makefile
+++ b/devel/libbobcat/Makefile
@@ -15,6 +15,7 @@ LICENSE= GPLv3
BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
yodl>=3.0:${PORTSDIR}/textproc/yodl
+USE_GCC= yes
USE_XORG= x11
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
@@ -22,11 +23,10 @@ PORTDOCS= *
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-USE_GCC= 4.7
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/bobcat-${PORTVERSION}
-USES= shebangfix
+USES= readline shebangfix
SHEBANG_LANG= icmake
icmake_OLD_CMD= /usr/bin/icmake
@@ -50,8 +50,8 @@ post-patch:
s|"/share/man"|"/man"| ; \
s|"-d"|"-Pp"| ; \
s|#define MANHTML|| ; \
- s|g++|g++47| ; \
- s|gcc|gcc47|' \
+ s|g++|${CXX}| ; \
+ s|gcc|${CC}|' \
${WRKSRC}/INSTALL.im
@${REINPLACE_CMD} -e 's|"-isystem tmp -Wall -O3"|"-isystem tmp ${LOCALBASE}/include -Wall ${CXXFLAGS}"|' \
${WRKSRC}/build