aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-15 15:14:12 +0800
committeraz <az@FreeBSD.org>2013-09-15 15:14:12 +0800
commit03730bd7f2eda8b4459e015d76945b1f3b0f9e65 (patch)
treef4e196d880f05adbbeb3d1416d8f4e48ba29d796
parent31fd1841b62065abef24948fbf8d6d28aeb798b9 (diff)
downloadfreebsd-ports-gnome-03730bd7f2eda8b4459e015d76945b1f3b0f9e65.tar.gz
freebsd-ports-gnome-03730bd7f2eda8b4459e015d76945b1f3b0f9e65.tar.zst
freebsd-ports-gnome-03730bd7f2eda8b4459e015d76945b1f3b0f9e65.zip
- convert to the new perl5 framework
- convert USE_GMAKE to Uses Approved by: portmgr (bapt@, blanket)
-rw-r--r--mail/cone/Makefile4
-rw-r--r--mail/courier-imap/Makefile3
-rw-r--r--mail/cyrus-imapd2/Makefile2
-rw-r--r--mail/cyrus-imapd23/Makefile3
-rw-r--r--mail/cyrus-imapd24/Makefile3
-rw-r--r--mail/enma/Makefile5
-rw-r--r--mail/exilog/Makefile2
-rw-r--r--mail/exim/Makefile5
-rw-r--r--mail/majordomo/Makefile3
-rw-r--r--mail/mimedefang/Makefile2
-rw-r--r--mail/mixmaster/Makefile3
-rw-r--r--mail/p5-Email-Sender/Makefile3
-rw-r--r--mail/policyd2/Makefile2
-rw-r--r--mail/postfix29/Makefile3
-rw-r--r--mail/qmail-scanner/Makefile4
-rw-r--r--mail/qmhandle/Makefile3
-rw-r--r--mail/sqwebmail/Makefile4
-rw-r--r--mail/swaks/Makefile3
-rw-r--r--mail/tpop3d/Makefile2
19 files changed, 27 insertions, 32 deletions
diff --git a/mail/cone/Makefile b/mail/cone/Makefile
index 3218273e1966..70f5a28cea8c 100644
--- a/mail/cone/Makefile
+++ b/mail/cone/Makefile
@@ -19,12 +19,10 @@ BUILD_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_FAM= yes
-USES= gettext iconv ncurses
+USES= gettext gmake iconv ncurses perl5
USE_GNOME= libxml2
USE_BZIP2= yes
-USE_PERL5= yes
-USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
CONFIGURE_ARGS= -C --without-db --with-certdb=${PREFIX}/share/cone/rootcerts --prefix=${PREFIX} --exec-prefix=${PREFIX}
diff --git a/mail/courier-imap/Makefile b/mail/courier-imap/Makefile
index 8980628be26b..73ab774a4530 100644
--- a/mail/courier-imap/Makefile
+++ b/mail/courier-imap/Makefile
@@ -13,10 +13,9 @@ COMMENT= IMAP (and POP3) server that provides access to Maildir mailboxes
BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+USES= gmake perl5
USE_BZIP2= yes
-USE_PERL5= yes
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_RC_SUBR= courier-imap-imapd courier-imap-imapd-ssl \
courier-imap-pop3d courier-imap-pop3d-ssl
diff --git a/mail/cyrus-imapd2/Makefile b/mail/cyrus-imapd2/Makefile
index 9deb51eb42e5..50e1de5c65d2 100644
--- a/mail/cyrus-imapd2/Makefile
+++ b/mail/cyrus-imapd2/Makefile
@@ -26,8 +26,8 @@ PERLMAN= ${SITE_PERL_REL:S/site_perl\///}
USE_RC_SUBR= imapd
+USES= perl5
USE_OPENSSL= yes
-USE_PERL5= yes
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --with-cyrus-prefix=${PREFIX}/cyrus \
--with-cyrus-user=${CYRUS_USER} \
diff --git a/mail/cyrus-imapd23/Makefile b/mail/cyrus-imapd23/Makefile
index d8f013f165a5..5c784bd9f136 100644
--- a/mail/cyrus-imapd23/Makefile
+++ b/mail/cyrus-imapd23/Makefile
@@ -23,8 +23,9 @@ LATEST_LINK= ${PORTNAME}23
PERLMAN= ${SITE_PERL_REL:S/site_perl\///}
USE_RC_SUBR= imapd
+
+USES= perl5
USE_OPENSSL= yes
-USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-cyrus-prefix=${PREFIX}/cyrus \
diff --git a/mail/cyrus-imapd24/Makefile b/mail/cyrus-imapd24/Makefile
index 1c1ab2d71018..0e0c253dba19 100644
--- a/mail/cyrus-imapd24/Makefile
+++ b/mail/cyrus-imapd24/Makefile
@@ -23,8 +23,9 @@ LATEST_LINK= ${PORTNAME}24
PERLMAN= ${SITE_PERL_REL:S/site_perl\///}
USE_RC_SUBR= imapd
+
+USES= perl5
USE_OPENSSL= yes
-USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-cyrus-prefix=${PREFIX}/cyrus \
diff --git a/mail/enma/Makefile b/mail/enma/Makefile
index 9d66736b26c5..ea5ce9f8100d 100644
--- a/mail/enma/Makefile
+++ b/mail/enma/Makefile
@@ -19,11 +19,12 @@ LIBBIND_DESC= Link against dns/libbind instead of dns/ldns
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} --mandir=${PREFIX}/man \
--with-ssl-incdir=${OPENSSLINC} --with-ssl-libdir=${OPENSSLLIB}
+
+USES= gmake perl5
USE_RC_SUBR= milter-enma
-USE_GMAKE= yes
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
MANLANG= "" ja_JP.UTF-8
MAN1= enma.1
MANCOMPRESSED= no
diff --git a/mail/exilog/Makefile b/mail/exilog/Makefile
index 84da6a44d2ac..91f5e6bf9545 100644
--- a/mail/exilog/Makefile
+++ b/mail/exilog/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv2
RUN_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
# Default sql backend
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 2155925adc03..47676939b656 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -19,7 +19,6 @@ LICENSE= GPLv2
USE_BZIP2= yes
WANT_GNOME= yes
-WANT_PERL= yes
MAKE_JOBS_UNSAFE= yes
# One can tune the following "hidden" knobs:
@@ -222,7 +221,7 @@ SEDLIST+= -e 's,^\# (TLS_LIBS=.*-lgnutls[[:space:]]),\1,'
.endif
.if ${PORT_OPTIONS:MEMBEDDED_PERL}
-USE_PERL5= yes
+USES+= perl5
SEDLIST+= -e 's,^\# (EXIM_PERL=),\1,'
.endif
@@ -234,7 +233,7 @@ SEDLIST+= -e 's,XX_TCP_WRAPPERS_LIBS_XX,,'
.endif
.if ${PORT_OPTIONS:MICONV}
-USES= iconv
+USE+S= iconv
SEDLIST+= -e 's,XX_ICONV_LIBS_XX,-L${LOCALBASE:S/,/\\,/g}/lib ${ICONV_LIB},' \
-e 's,^\# (HAVE_ICONV=),\1,'
.else
diff --git a/mail/majordomo/Makefile b/mail/majordomo/Makefile
index 356cadd239fd..890c4649fae7 100644
--- a/mail/majordomo/Makefile
+++ b/mail/majordomo/Makefile
@@ -13,8 +13,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= anders@FreeBSD.org
COMMENT= A mailing list manager
-USES= shebangfix
-USE_PERL5= yes
+USES= shebangfix perl5
SHEBANG_FILES= contrib/sequencer
diff --git a/mail/mimedefang/Makefile b/mail/mimedefang/Makefile
index b7519033c69d..ebcbbc71e055 100644
--- a/mail/mimedefang/Makefile
+++ b/mail/mimedefang/Makefile
@@ -23,7 +23,7 @@ OPTIONS_DEFINE= CLAMAV EXAMPLES DOCS
OPTIONS_DEFAULT= CLAMAV
CLAMAV_DESC= Enable Clamav
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
MAILUSER?= mailnull
diff --git a/mail/mixmaster/Makefile b/mail/mixmaster/Makefile
index 44b2c7d265da..d9167dcdf34c 100644
--- a/mail/mixmaster/Makefile
+++ b/mail/mixmaster/Makefile
@@ -16,8 +16,7 @@ COMMENT= A cryptographically secure anonymous remailer
LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
-USES= ncurses
-USE_PERL5= yes
+USES= ncurses perl5
USE_OPENSSL= yes
.if !exists(/usr/include/openssl/idea.h)
WITH_OPENSSL_PORT= yes
diff --git a/mail/p5-Email-Sender/Makefile b/mail/p5-Email-Sender/Makefile
index 6c6c35a0f5e2..bf34f7ae510a 100644
--- a/mail/p5-Email-Sender/Makefile
+++ b/mail/p5-Email-Sender/Makefile
@@ -28,7 +28,8 @@ TEST_DEPENDS= p5-Capture-Tiny>=0.08:${PORTSDIR}/devel/p5-Capture-Tiny \
p5-Sub-Override>=0:${PORTSDIR}/devel/p5-Sub-Override \
p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Email::Sender.3 \
Email::Sender::Failure.3 \
diff --git a/mail/policyd2/Makefile b/mail/policyd2/Makefile
index d165628206cd..50a46fcf4d1e 100644
--- a/mail/policyd2/Makefile
+++ b/mail/policyd2/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= p5-Net-Server>=0:${PORTSDIR}/net/p5-Net-Server \
p5-Config-IniFiles>=0:${PORTSDIR}/devel/p5-Config-IniFiles \
p5-Cache-FastMmap>=0:${PORTSDIR}/devel/p5-Cache-FastMmap
-USE_PERL5= yes
+USES= perl5
USE_PHP= yes
NO_BUILD= yes
USE_RC_SUBR= policyd2
diff --git a/mail/postfix29/Makefile b/mail/postfix29/Makefile
index 8f457a643e56..cee570898701 100644
--- a/mail/postfix29/Makefile
+++ b/mail/postfix29/Makefile
@@ -31,8 +31,9 @@ NO_LATEST_LINK= yes
USERS= postfix
GROUPS= mail maildrop postfix
+USES= perl5
+USE_PERL5= build
USE_SUBMAKE= yes
-USE_PERL5_BUILD=yes
SCRIPTS_ENV+= POSTFIX_DEFAULT_MTA="${POSTFIX_DEFAULT_MTA}"
OPTIONS_DEFINE= PCRE SASL2 TLS BDB MYSQL PGSQL SQLITE OPENLDAP LDAP_SASL \
diff --git a/mail/qmail-scanner/Makefile b/mail/qmail-scanner/Makefile
index 3ce2c2ed58e8..8e2cdd860e67 100644
--- a/mail/qmail-scanner/Makefile
+++ b/mail/qmail-scanner/Makefile
@@ -21,9 +21,7 @@ BUILD_DEPENDS+= reformime:${PORTSDIR}/mail/maildrop \
CONFLICTS= qmail-scanner-1.*
-USES= qmail
-
-USE_PERL5= yes
+USES= qmail perl5
SPOOLDIR?= /var/spool/qscand
PLIST_SUB= SPOOLDIR=${SPOOLDIR}
diff --git a/mail/qmhandle/Makefile b/mail/qmhandle/Makefile
index d6d9f8afdfb9..4a15e4f6dfc3 100644
--- a/mail/qmhandle/Makefile
+++ b/mail/qmhandle/Makefile
@@ -14,10 +14,9 @@ LICENSE= GPLv2
OPTIONS_DEFINE= DOCS
-USES= qmail:run
+USES= qmail:run perl5
NO_BUILD= yes
-USE_PERL5= yes
USE_BZIP2= yes
PORTDOCS= HISTORY README
diff --git a/mail/sqwebmail/Makefile b/mail/sqwebmail/Makefile
index c68ce0ed9524..17076076822a 100644
--- a/mail/sqwebmail/Makefile
+++ b/mail/sqwebmail/Makefile
@@ -51,10 +51,8 @@ CACHEOWNER?= bin
#
# End of user variables
-USE_PERL5= YES
USE_BZIP2= YES
-USES= gettext iconv
-USE_GMAKE= YES
+USES= gettext gmake iconv perl5
USE_RC_SUBR= sqwebmail-sqwebmaild
GNU_CONFIGURE= yes
diff --git a/mail/swaks/Makefile b/mail/swaks/Makefile
index ae9dc2323661..0766d904c4af 100644
--- a/mail/swaks/Makefile
+++ b/mail/swaks/Makefile
@@ -16,7 +16,8 @@ PERL_NET_DNS_DESC= Add MX lookup support
PERL_NET_SSLEAY_DESC= Add TLS support
PERL_AUTHEN_NTLM_DESC= Add support for AUTH NTLM
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
.include <bsd.port.pre.mk>
diff --git a/mail/tpop3d/Makefile b/mail/tpop3d/Makefile
index a2db5864bcf7..bee993cc27cb 100644
--- a/mail/tpop3d/Makefile
+++ b/mail/tpop3d/Makefile
@@ -56,7 +56,7 @@ CONFIGURE_ARGS+= --enable-auth-ldap --with-openldap-root=${LOCALBASE}
# Perl authentication
.if ${PORT_OPTIONS:MPERLAUTH}
-USE_PERL5= yes
+USES+= perl5
CONFIGURE_ARGS+= --enable-auth-perl
.endif