aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-01-23 07:01:09 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-01-23 07:01:09 +0800
commit047eab4f26ba796af5fb42532638305eeff84758 (patch)
tree279cef25c79a7d858abd26254c7fb6f0b4e94d81
parent9e4f8011212b488a059936b0069cd69b9833abe6 (diff)
downloadfreebsd-ports-gnome-047eab4f26ba796af5fb42532638305eeff84758.tar.gz
freebsd-ports-gnome-047eab4f26ba796af5fb42532638305eeff84758.tar.zst
freebsd-ports-gnome-047eab4f26ba796af5fb42532638305eeff84758.zip
- Update to 3.9.0-rc1
The 32BIT option currently is broken.
-rw-r--r--devel/valgrind-devel/Makefile30
-rw-r--r--devel/valgrind-devel/distinfo4
-rw-r--r--devel/valgrind-devel/pkg-plist35
3 files changed, 57 insertions, 12 deletions
diff --git a/devel/valgrind-devel/Makefile b/devel/valgrind-devel/Makefile
index b66f92cacd40..21b0d9025e1f 100644
--- a/devel/valgrind-devel/Makefile
+++ b/devel/valgrind-devel/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= valgrind
-PORTVERSION= 3.8.1
-PORTREVISION= 1
+DISTVERSIONPREFIX= freebsd-
+DISTVERSION= 3.9.0.rc1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://cdn.bitbucket.org/stass/valgrind-freebsd/downloads/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Memory debugging and profiling tool
@@ -22,11 +21,14 @@ ONLY_FOR_ARCHS= i386 amd64
LIB32_PATH?= ${DESTDIR}/usr/lib32/libc.so
+BUILD_DEPENDS+= docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
+ xsltproc:${PORTSDIR}/textproc/libxslt
+
OPTIONS_DEFINE= MPI
OPTIONS_DEFINE_amd64= 32BIT
-.if exists(${LIB32_PATH})
-OPTIONS_DEFAULT_amd64= 32BIT
-.endif
+#.if exists(${LIB32_PATH})
+#OPTIONS_DEFAULT_amd64= 32BIT
+#.endif
32BIT_DESC= Enable debugging of 32-bit programs (requires lib32)
MPI_DESC= Enable build of MPI wrappers
@@ -34,7 +36,7 @@ MPI_LIB_DEPENDS= mpich:${PORTSDIR}/net/mpich2
OPTIONS_SUB= yes
USE_BZIP2= yes
-USES= pathfix pkgconfig gmake perl5
+USES= pathfix pkgconfig gmake perl5 shebangfix
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -43,8 +45,14 @@ PORTDOCS= html
WRKSRC= ${WRKDIR}/${DISTNAME}
+CONFIGURE_ENV+= ac_cv_path_PERL=${PERL}
+
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:M32BIT}
+BROKEN= Currently does not build with 32bit support
+.endif
+
.if ${ARCH} == "amd64"
PLIST_SUB+= AMD64="" ARCH=amd64
. if !${PORT_OPTIONS:M32BIT}
@@ -67,4 +75,12 @@ post-patch:
@${RM} -rf ${WRKSRC}/docs/html
.endif
+do-build: do-man-pages
+
+do-man-pages:
+ cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} ${GMAKE} man-pages
+.if ${PORT_OPTIONS:MDOCS}
+ cd ${WRKSRC}/docs && ${SETENV} ${MAKE_ENV} ${GMAKE} html-docs
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/valgrind-devel/distinfo b/devel/valgrind-devel/distinfo
index a989433d8a57..88bddc2104b1 100644
--- a/devel/valgrind-devel/distinfo
+++ b/devel/valgrind-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (valgrind-freebsd-3.8.1.tar.bz2) = d4d9a0c6a8581cd04f4091ce9e15ce307f364210c4ea4cd38d568a8df7527871
-SIZE (valgrind-freebsd-3.8.1.tar.bz2) = 6289247
+SHA256 (valgrind-freebsd-3.9.0.rc1.tar.bz2) = cd4304c995fc5e4ea03152147bf80a6de912536c671af46b2d800cc704683442
+SIZE (valgrind-freebsd-3.9.0.rc1.tar.bz2) = 9358772
diff --git a/devel/valgrind-devel/pkg-plist b/devel/valgrind-devel/pkg-plist
index 92f4bd42a8f7..c3a4cc6580e6 100644
--- a/devel/valgrind-devel/pkg-plist
+++ b/devel/valgrind-devel/pkg-plist
@@ -5,6 +5,7 @@ bin/cg_diff
bin/cg_merge
bin/ms_print
bin/valgrind
+bin/valgrind-di-server
bin/valgrind-listener
bin/vgdb
include/valgrind/callgrind.h
@@ -13,10 +14,11 @@ include/valgrind/drd.h
include/valgrind/helgrind.h
include/valgrind/libvex.h
include/valgrind/libvex_basictypes.h
-include/valgrind/libvex_emwarn.h
+include/valgrind/libvex_emnote.h
include/valgrind/libvex_guest_amd64.h
include/valgrind/libvex_guest_arm.h
include/valgrind/libvex_guest_mips32.h
+include/valgrind/libvex_guest_mips64.h
include/valgrind/libvex_guest_offsets.h
include/valgrind/libvex_guest_ppc32.h
include/valgrind/libvex_guest_ppc64.h
@@ -32,13 +34,11 @@ include/valgrind/pub_tool_basics.h
include/valgrind/pub_tool_basics_asm.h
include/valgrind/pub_tool_clientstate.h
include/valgrind/pub_tool_clreq.h
-include/valgrind/pub_tool_cpuid.h
include/valgrind/pub_tool_debuginfo.h
include/valgrind/pub_tool_errormgr.h
include/valgrind/pub_tool_execontext.h
include/valgrind/pub_tool_gdbserver.h
include/valgrind/pub_tool_hashtable.h
-include/valgrind/pub_tool_inner.h
include/valgrind/pub_tool_libcassert.h
include/valgrind/pub_tool_libcbase.h
include/valgrind/pub_tool_libcfile.h
@@ -95,6 +95,20 @@ include/valgrind/vki/vki-scnums-s390x-linux.h
include/valgrind/vki/vki-scnums-x86-linux.h
include/valgrind/vki/vki-x86-freebsd.h
include/valgrind/vki/vki-x86-linux.h
+include/valgrind/vki/vki-linux-drm.h
+include/valgrind/vki/vki-mips64-linux.h
+include/valgrind/vki/vki-posixtypes-mips64-linux.h
+include/valgrind/vki/vki-scnums-mips64-linux.h
+include/valgrind/vki/vki-xen-domctl.h
+include/valgrind/vki/vki-xen-evtchn.h
+include/valgrind/vki/vki-xen-gnttab.h
+include/valgrind/vki/vki-xen-hvm.h
+include/valgrind/vki/vki-xen-memory.h
+include/valgrind/vki/vki-xen-mmuext.h
+include/valgrind/vki/vki-xen-sysctl.h
+include/valgrind/vki/vki-xen-version.h
+include/valgrind/vki/vki-xen-x86.h
+include/valgrind/vki/vki-xen.h
lib/valgrind/32bit-core-valgrind-s1.xml
lib/valgrind/32bit-core-valgrind-s2.xml
lib/valgrind/32bit-core.xml
@@ -141,6 +155,17 @@ lib/valgrind/mips-fpu-valgrind-s2.xml
lib/valgrind/mips-fpu.xml
lib/valgrind/mips-linux-valgrind.xml
lib/valgrind/mips-linux.xml
+lib/valgrind/mips64-cp0-valgrind-s1.xml
+lib/valgrind/mips64-cp0-valgrind-s2.xml
+lib/valgrind/mips64-cp0.xml
+lib/valgrind/mips64-cpu-valgrind-s1.xml
+lib/valgrind/mips64-cpu-valgrind-s2.xml
+lib/valgrind/mips64-cpu.xml
+lib/valgrind/mips64-fpu-valgrind-s1.xml
+lib/valgrind/mips64-fpu-valgrind-s2.xml
+lib/valgrind/mips64-fpu.xml
+lib/valgrind/mips64-linux-valgrind.xml
+lib/valgrind/mips64-linux.xml
lib/valgrind/power-core-valgrind-s1.xml
lib/valgrind/power-core-valgrind-s2.xml
lib/valgrind/s390-acr-valgrind-s1.xml
@@ -227,8 +252,12 @@ libdata/pkgconfig/valgrind.pc
man/man1/callgrind_annotate.1.gz
man/man1/callgrind_control.1.gz
man/man1/cg_annotate.1.gz
+man/man1/cg_diff.1.gz
+man/man1/cg_merge.1.gz
man/man1/ms_print.1.gz
+man/man1/valgrind-listener.1.gz
man/man1/valgrind.1.gz
+man/man1/vgdb.1.gz
@dirrm lib/valgrind
@dirrm include/valgrind/vki
@dirrm include/valgrind