aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-09 09:36:21 +0800
committermaho <maho@FreeBSD.org>2007-01-09 09:36:21 +0800
commit04ac770df9d4340d777d73f5f674bc46bcef7d29 (patch)
tree2c5e4155b3b2731a6100aa383c94e58877b58396
parent024f2f3b6150b0cffa33be706b3dbf9b506e76a4 (diff)
downloadfreebsd-ports-gnome-04ac770df9d4340d777d73f5f674bc46bcef7d29.tar.gz
freebsd-ports-gnome-04ac770df9d4340d777d73f5f674bc46bcef7d29.tar.zst
freebsd-ports-gnome-04ac770df9d4340d777d73f5f674bc46bcef7d29.zip
Migrate to gfortran.
-rw-r--r--astro/cfitsio/Makefile6
-rw-r--r--astro/cfitsio/files/patch-configure22
2 files changed, 28 insertions, 0 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index d06911de8aac..1b813ca51cde 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -19,12 +19,18 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+WANT_FORTRAN= yes #dummy
+USE_GCC=4.2+
+LIB_DEPENDS+= f2c.2:${PORTSDIR}/lang/f2c
ALL_TARGET= shared
post-patch:
+ ${ECHO_CMD} ${FC}
@${GREP} -lR "<malloc.\h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g'
@${REINPLACE_CMD} -e 's|="\.so"|=".so.0"|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|%%FC%%|${FC}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|%%FC%%|${FC}|g' ${WRKSRC}/configure.in
do-install:
.for file in drvrsmem.h fitsio.h fitsio2.h longnam.h
diff --git a/astro/cfitsio/files/patch-configure b/astro/cfitsio/files/patch-configure
new file mode 100644
index 000000000000..70f5db7ff2a6
--- /dev/null
+++ b/astro/cfitsio/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure~ Tue Jan 9 10:31:25 2007
++++ configure Tue Jan 9 10:31:46 2007
+@@ -857,7 +857,7 @@
+ fi
+
+
+-for ac_prog in f77 xlf cf77 gf77 g77 af77 ncf f2c
++for ac_prog in %%FC%% f77 xlf cf77 gf77 g77 af77 ncf f2c
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
+--- configure.in~ Fri Jul 29 06:26:00 2005
++++ configure.in Tue Jan 9 10:31:38 2007
+@@ -54,7 +54,7 @@
+ fi
+ AC_PROG_CC
+
+-AC_CHECK_PROGS(FC, f77 xlf cf77 gf77 g77 af77 ncf f2c , nope)
++AC_CHECK_PROGS(FC, %%FC%%, f77 xlf cf77 gf77 g77 af77 ncf f2c , nope)
+ if test $FC = 'nope' ; then
+ AC_MSG_WARN(cfitsio: == No acceptable f77 found in \$PATH)
+ AC_MSG_WARN(cfitsio: == Cfitsio will be built without Fortran wrapper support)