aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-11 16:38:45 +0800
committerknu <knu@FreeBSD.org>2001-09-11 16:38:45 +0800
commit04d62e0607c6f0a52570ac3db91cc81847e355c2 (patch)
treed0f79cdbd49e1801a013cbf00f7b44966ad4d3ee
parent7ded2db55a079d49b5cbfea46fb0f9c1a7e8af9d (diff)
downloadfreebsd-ports-gnome-04d62e0607c6f0a52570ac3db91cc81847e355c2.tar.gz
freebsd-ports-gnome-04d62e0607c6f0a52570ac3db91cc81847e355c2.tar.zst
freebsd-ports-gnome-04d62e0607c6f0a52570ac3db91cc81847e355c2.zip
Add p5-IPC-SharedCache, a Perl module for managing a SysV IPC shared
memory cache. PR: ports/30189 Submitted by: Norikatsu Shigemura <nork@cityfujisawa.ne.jp>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IPC-SharedCache/Makefile26
-rw-r--r--devel/p5-IPC-SharedCache/distinfo1
-rw-r--r--devel/p5-IPC-SharedCache/pkg-comment1
-rw-r--r--devel/p5-IPC-SharedCache/pkg-descr11
-rw-r--r--devel/p5-IPC-SharedCache/pkg-plist5
6 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9460bce033ec..75d6f5313150 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -360,6 +360,7 @@
SUBDIR += p5-IPC-Run
SUBDIR += p5-IPC-ShareLite
SUBDIR += p5-IPC-Shareable
+ SUBDIR += p5-IPC-SharedCache
SUBDIR += p5-Include
SUBDIR += p5-Ioctl
SUBDIR += p5-Locale-Maketext
diff --git a/devel/p5-IPC-SharedCache/Makefile b/devel/p5-IPC-SharedCache/Makefile
new file mode 100644
index 000000000000..1a18ed627fbd
--- /dev/null
+++ b/devel/p5-IPC-SharedCache/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-IPC-SharedCache
+# Date created: 2001/08/29
+# Whom: nork@cityfujisawa.ne.jp
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-SharedCache
+PORTVERSION= 1.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@cityfujisawa.ne.jp
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/IPC/ShareLite.pm:${PORTSDIR}/devel/p5-IPC-ShareLite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IPC::SharedCache.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IPC-SharedCache/distinfo b/devel/p5-IPC-SharedCache/distinfo
new file mode 100644
index 000000000000..1ed2a1088b2a
--- /dev/null
+++ b/devel/p5-IPC-SharedCache/distinfo
@@ -0,0 +1 @@
+MD5 (IPC-SharedCache-1.3.tar.gz) = 4d5d159a6b41d42918b7c1fceafb43ae
diff --git a/devel/p5-IPC-SharedCache/pkg-comment b/devel/p5-IPC-SharedCache/pkg-comment
new file mode 100644
index 000000000000..6bea228a0b96
--- /dev/null
+++ b/devel/p5-IPC-SharedCache/pkg-comment
@@ -0,0 +1 @@
+Perl module for managing a SysV IPC shared memory cache
diff --git a/devel/p5-IPC-SharedCache/pkg-descr b/devel/p5-IPC-SharedCache/pkg-descr
new file mode 100644
index 000000000000..1206e3bfa2d8
--- /dev/null
+++ b/devel/p5-IPC-SharedCache/pkg-descr
@@ -0,0 +1,11 @@
+This module provides a shared memory cache accessed as a
+tied hash.
+Shared memory is an area of memory that is available to
+all processes. It is accessed by choosing a key, the
+ipc_key arguement to tie. Every process that accesses
+shared memory with the same key gets access to the same
+region of memory. In some ways it resembles a file
+system, but it is not hierarchical and it is resident in
+memory. This makes it harder to use than a filesystem but
+much faster. The data in shared memory persists until the
+machine is rebooted or it is explicitely deleted.
diff --git a/devel/p5-IPC-SharedCache/pkg-plist b/devel/p5-IPC-SharedCache/pkg-plist
new file mode 100644
index 000000000000..fc356e2eb3a4
--- /dev/null
+++ b/devel/p5-IPC-SharedCache/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/IPC/SharedCache.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/SharedCache/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC/SharedCache
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IPC 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/IPC 2>/dev/null || true