aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-10-25 16:03:52 +0800
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-10-25 16:03:52 +0800
commit056895ec049d5b6f096adf9b317b715d629cc0af (patch)
treed30e4c7f6a1137904846917795c9465f48491489
parentfb71fd7b4c84e2de167c083bafd9e78eb6eab984 (diff)
downloadfreebsd-ports-gnome-056895ec049d5b6f096adf9b317b715d629cc0af.tar.gz
freebsd-ports-gnome-056895ec049d5b6f096adf9b317b715d629cc0af.tar.zst
freebsd-ports-gnome-056895ec049d5b6f096adf9b317b715d629cc0af.zip
New port: deskutils/fff: Simple file manager written in Bash
A simple file manager written in Bash. - It's ******* Fast - Minimal (only requires bash and coreutils) - Smooth Scrolling (using vim keybindings) - Works on Linux, BSD, macOS, Haiku etc. - Supports LS_COLORS! - File operations (copy, paste, cut, ranger style bulk rename, etc) - Instant as you type search - Tab completion for all commands! - Automatic CD on exit (see setup) - Works as a file picker in vim/neovim! - Display images with w3m-img! - Supports $CDPATH. WWW: https://github.com/dylanaraps/fff
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/fff/Makefile24
-rw-r--r--deskutils/fff/distinfo3
-rw-r--r--deskutils/fff/pkg-descr16
-rw-r--r--deskutils/fff/pkg-message12
5 files changed, 56 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index d5e3163646c4..2eae978bc487 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -50,6 +50,7 @@
SUBDIR += fasd
SUBDIR += fbreader
SUBDIR += fet
+ SUBDIR += fff
SUBDIR += flameshot
SUBDIR += foliate
SUBDIR += freemind
diff --git a/deskutils/fff/Makefile b/deskutils/fff/Makefile
new file mode 100644
index 000000000000..d6994091769f
--- /dev/null
+++ b/deskutils/fff/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= fff
+DISTVERSION= 2.1
+CATEGORIES= deskutils
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Simple file manager written in Bash
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= bash:shells/bash
+
+USES= shebangfix
+SHEBANG_FILES= fff
+USE_GITHUB= yes
+GH_ACCOUNT= dylanaraps
+
+NO_ARCH= yes
+NO_BUILD= yes
+PLIST_FILES= bin/fff share/man/man1/fff.1
+
+.include <bsd.port.mk>
diff --git a/deskutils/fff/distinfo b/deskutils/fff/distinfo
new file mode 100644
index 000000000000..0a3c1f944302
--- /dev/null
+++ b/deskutils/fff/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568021713
+SHA256 (dylanaraps-fff-2.1_GH0.tar.gz) = 776870d11c022fa40468d5d582831c0ab5beced573489097deaaf5dd690e7eab
+SIZE (dylanaraps-fff-2.1_GH0.tar.gz) = 15573
diff --git a/deskutils/fff/pkg-descr b/deskutils/fff/pkg-descr
new file mode 100644
index 000000000000..ede4f0eb2ee3
--- /dev/null
+++ b/deskutils/fff/pkg-descr
@@ -0,0 +1,16 @@
+A simple file manager written in Bash.
+
+- It's ******* Fast
+- Minimal (only requires bash and coreutils)
+- Smooth Scrolling (using vim keybindings)
+- Works on Linux, BSD, macOS, Haiku etc.
+- Supports LS_COLORS!
+- File operations (copy, paste, cut, ranger style bulk rename, etc)
+- Instant as you type search
+- Tab completion for all commands!
+- Automatic CD on exit (see setup)
+- Works as a file picker in vim/neovim!
+- Display images with w3m-img!
+- Supports $CDPATH.
+
+WWW: https://github.com/dylanaraps/fff
diff --git a/deskutils/fff/pkg-message b/deskutils/fff/pkg-message
new file mode 100644
index 000000000000..d98e7a6a3334
--- /dev/null
+++ b/deskutils/fff/pkg-message
@@ -0,0 +1,12 @@
+[
+{
+ message: <<EOM
+Install the devel/xdg-utils port if you wish to use xdg-open with fff.
+
+Install the following ports in order to enable image displaying support:
+- www/w3m-img
+- x11/xdotool
+EOM
+ type: install
+ }
+ ]