aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2019-09-24 21:45:08 +0800
committernaddy <naddy@FreeBSD.org>2019-09-24 21:45:08 +0800
commit063261c1e0abbe7e4908fed1222eac40b67b6292 (patch)
tree33328739248e096a89f8555422897020e2c68133
parentbd613a4492831a00a1eee8d5e5713fc83e16ff0e (diff)
downloadfreebsd-ports-gnome-063261c1e0abbe7e4908fed1222eac40b67b6292.tar.gz
freebsd-ports-gnome-063261c1e0abbe7e4908fed1222eac40b67b6292.tar.zst
freebsd-ports-gnome-063261c1e0abbe7e4908fed1222eac40b67b6292.zip
Run regression tests with bash since some test scripts unfortunately
rely on bash features. PR: 240686 Reviewed by: jbeich
-rw-r--r--security/nss/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 21205f8947dd..37a251a278a4 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libnspr4.so:devel/nspr \
libsqlite3.so:databases/sqlite3
+TEST_DEPENDS= bash:shells/bash
WRKSRC_SUBDIR= nss
@@ -63,12 +64,12 @@ USE_BINUTILS= # intel-gcm.s
CC+= -B${LOCALBASE}/bin
.endif
-check regression-test test:
+do-test:
cd ${WRKSRC}/tests; \
${SETENV} PATH="${BINS}/bin:${PATH}" \
LD_LIBRARY_PATH="${BINS}/lib" \
${MAKE_ENV} \
- ./all.sh
+ bash ./all.sh
@if ${GREP} -Fh '>Failed<' \
${WRKSRC:H}/tests_results/security/*/results.html; then \
echo "Some tests have failed. Let ${MAINTAINER} know."; \
@@ -83,8 +84,6 @@ post-patch:
@cd ${WRKSRC} && \
${FIND} . -name "*.c" -o -name "*.h" | \
${XARGS} ${REINPLACE_CMD} -e 's|"nspr.h"|<nspr.h>|'
- ${FIND} ${WRKSRC}/tests -name '*.sh' | ${XARGS} ${GREP} -l -F '/bin/bash' | \
- ${XARGS} ${REINPLACE_CMD} -e 's|#! */bin/bash|#!${SH}|'
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/nss/nss ${STAGEDIR}${PREFIX}/lib/nss