aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-04-30 04:47:15 +0800
committerkris <kris@FreeBSD.org>2002-04-30 04:47:15 +0800
commit0694c2ac21c214d777dd30949b277965a40e2eb1 (patch)
tree7e90d349752fb2378135bb5067fc6d8b1a467bf0
parent7b9ff815e0ce3f717175833740bcef11f6016b2c (diff)
downloadfreebsd-ports-gnome-0694c2ac21c214d777dd30949b277965a40e2eb1.tar.gz
freebsd-ports-gnome-0694c2ac21c214d777dd30949b277965a40e2eb1.tar.zst
freebsd-ports-gnome-0694c2ac21c214d777dd30949b277965a40e2eb1.zip
Fix build with gcc31; don't add -I/usr/include to gcc flags.
Submitted by: obrien
-rw-r--r--net/ssldump/Makefile1
-rw-r--r--net/ssldump/files/patch-aa13
2 files changed, 14 insertions, 0 deletions
diff --git a/net/ssldump/Makefile b/net/ssldump/Makefile
index e63748c9f64c..26fd9b1d146b 100644
--- a/net/ssldump/Makefile
+++ b/net/ssldump/Makefile
@@ -16,6 +16,7 @@ USE_OPENSSL= YES
.include <bsd.port.pre.mk>
+USE_AUTOCONF= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE}
diff --git a/net/ssldump/files/patch-aa b/net/ssldump/files/patch-aa
new file mode 100644
index 000000000000..9f40c2087275
--- /dev/null
+++ b/net/ssldump/files/patch-aa
@@ -0,0 +1,13 @@
+--- configure.in.orig Thu Sep 27 01:03:56 2001
++++ configure.in Mon Apr 29 13:20:27 2002
+@@ -200,7 +200,9 @@
+ done
+ if test "$ac_found_openssl_lib_dir" != "no"; then
+ echo "found in $ac_found_openssl_lib_dir"
+- INCLUDES="-I$ac_found_openssl_inc_dir $INCLUDES"
++ if test "$ac_found_openssl_inc_dir" != "/usr/include"; then
++ INCLUDES="-I$ac_found_openssl_inc_dir $INCLUDES"
++ fi
+ DEFINES="-DOPENSSL $DEFINES"
+ else
+ echo "not found."