aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-29 12:29:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-29 12:29:54 +0800
commit06d98cb29a084b6748ca021108d51659eee73c06 (patch)
tree9864dac37c4c9920891eb89ae3d0ccdde1b3aefb
parentddde18a641ce5822a4ba254f912003bd3b21c40b (diff)
downloadfreebsd-ports-gnome-06d98cb29a084b6748ca021108d51659eee73c06.tar.gz
freebsd-ports-gnome-06d98cb29a084b6748ca021108d51659eee73c06.tar.zst
freebsd-ports-gnome-06d98cb29a084b6748ca021108d51659eee73c06.zip
- Add p5-Monitor-Simple 0.2.3
Monitor::Simple allows simple monitoring of applications and services of your IT infrastructure. There are many such tools, some of them very complex and sophisticated. For example, one widely used is Nagios (http://www.nagios.org/). The Monitor::Simple does not aim, as its name indicates, for all features provided by those tools. It allows, however, to check whether your applications and services are running correctly. Its simple command-line interface can be used in cron jobs and reports can be viewed as a single HTML or text page. WWW: http://search.cpan.org/dist/Monitor-Simple/
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-Monitor-Simple/Makefile48
-rw-r--r--sysutils/p5-Monitor-Simple/distinfo2
-rw-r--r--sysutils/p5-Monitor-Simple/pkg-descr9
-rw-r--r--sysutils/p5-Monitor-Simple/pkg-plist33
5 files changed, 93 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index e7f205c3f4af..9cbc88c6ae25 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -571,6 +571,7 @@
SUBDIR += p5-MogileFS-Client
SUBDIR += p5-MogileFS-Server
SUBDIR += p5-MogileFS-Utils
+ SUBDIR += p5-Monitor-Simple
SUBDIR += p5-Plugtools
SUBDIR += p5-Plugtools-Plugins-HomeOU
SUBDIR += p5-Probe-Perl
diff --git a/sysutils/p5-Monitor-Simple/Makefile b/sysutils/p5-Monitor-Simple/Makefile
new file mode 100644
index 000000000000..fa12d0606d0e
--- /dev/null
+++ b/sysutils/p5-Monitor-Simple/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: p5-Monitor-Simple
+# Date created: 2011-10-25
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Monitor-Simple
+PORTVERSION= 0.2.3
+CATEGORIES= sysutils perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple monitoring of applications and services
+
+BUILD_DEPENDS= p5-IO-CaptureOutput>=0:${PORTSDIR}/devel/p5-IO-CaptureOutput \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Parallel-ForkManager>=0:${PORTSDIR}/devel/p5-Parallel-ForkManager \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-IO-CaptureOutput>=0:${PORTSDIR}/devel/p5-IO-CaptureOutput \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Parallel-ForkManager>=0:${PORTSDIR}/devel/p5-Parallel-ForkManager \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+TEST_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
+
+PERL_CONFIGURE= yes
+
+MAN1= smonitor.1
+MAN3= Monitor::Simple.3 \
+ Monitor::Simple::Config.3 \
+ Monitor::Simple::Log.3 \
+ Monitor::Simple::Notifier.3 \
+ Monitor::Simple::Output.3 \
+ Monitor::Simple::UserAgent.3 \
+ Monitor::Simple::Utils.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
+RUN_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-Monitor-Simple/distinfo b/sysutils/p5-Monitor-Simple/distinfo
new file mode 100644
index 000000000000..8b8c48dddba3
--- /dev/null
+++ b/sysutils/p5-Monitor-Simple/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Monitor-Simple-0.2.3.tar.gz) = bf0213de83ca9fc68a87eb5a72da3f83239bb6dc0aeb5f120f95205be22f4d20
+SIZE (Monitor-Simple-0.2.3.tar.gz) = 59687
diff --git a/sysutils/p5-Monitor-Simple/pkg-descr b/sysutils/p5-Monitor-Simple/pkg-descr
new file mode 100644
index 000000000000..2b2f86253dae
--- /dev/null
+++ b/sysutils/p5-Monitor-Simple/pkg-descr
@@ -0,0 +1,9 @@
+Monitor::Simple allows simple monitoring of applications and services of your IT
+infrastructure. There are many such tools, some of them very complex and
+sophisticated. For example, one widely used is Nagios (http://www.nagios.org/).
+The Monitor::Simple does not aim, as its name indicates, for all features
+provided by those tools. It allows, however, to check whether your applications
+and services are running correctly. Its simple command-line interface can be
+used in cron jobs and reports can be viewed as a single HTML or text page.
+
+WWW: http://search.cpan.org/dist/Monitor-Simple/
diff --git a/sysutils/p5-Monitor-Simple/pkg-plist b/sysutils/p5-Monitor-Simple/pkg-plist
new file mode 100644
index 000000000000..b7f18f047883
--- /dev/null
+++ b/sysutils/p5-Monitor-Simple/pkg-plist
@@ -0,0 +1,33 @@
+bin/smonitor
+%%SITE_PERL%%/Monitor/Simple.pm
+%%SITE_PERL%%/Monitor/Simple/Config.pm
+%%SITE_PERL%%/Monitor/Simple/Log.pm
+%%SITE_PERL%%/Monitor/Simple/Notifier.pm
+%%SITE_PERL%%/Monitor/Simple/Output.pm
+%%SITE_PERL%%/Monitor/Simple/UserAgent.pm
+%%SITE_PERL%%/Monitor/Simple/Utils.pm
+%%SITE_PERL%%/Monitor/Simple/configs/bad-config.cfg
+%%SITE_PERL%%/Monitor/Simple/configs/erroneous-monitor-cfg.xml
+%%SITE_PERL%%/Monitor/Simple/configs/monitor-default.css
+%%SITE_PERL%%/Monitor/Simple/configs/monitor-simple-cfg.xml.template
+%%SITE_PERL%%/Monitor/Simple/configs/simple-example-cfg.xml
+%%SITE_PERL%%/Monitor/Simple/configs/simple-example-with-notificationcfg.xml
+%%SITE_PERL%%/Monitor/Simple/notifiers/copy-to-file
+%%SITE_PERL%%/Monitor/Simple/notifiers/send-email
+%%SITE_PERL%%/Monitor/Simple/notifiers/send-email-via-ssh
+%%SITE_PERL%%/Monitor/Simple/plugins/born-to-be-killed.pl
+%%SITE_PERL%%/Monitor/Simple/plugins/check-get.pl
+%%SITE_PERL%%/Monitor/Simple/plugins/check-post.pl
+%%SITE_PERL%%/Monitor/Simple/plugins/check-prg.pl
+%%SITE_PERL%%/Monitor/Simple/plugins/check-url.pl
+%%SITE_PERL%%/Monitor/Simple/plugins/check_mem.pl
+%%SITE_PERL%%/Monitor/Simple/plugins/copy-message.pl
+%%SITE_PERL%%/Monitor/Simple/plugins/get-date.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Monitor/Simple/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Monitor/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Monitor
+@dirrmtry %%SITE_PERL%%/Monitor/Simple/plugins
+@dirrmtry %%SITE_PERL%%/Monitor/Simple/notifiers
+@dirrmtry %%SITE_PERL%%/Monitor/Simple/configs
+@dirrmtry %%SITE_PERL%%/Monitor/Simple
+@dirrmtry %%SITE_PERL%%/Monitor