aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-09-10 06:28:03 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-09-10 06:28:03 +0800
commit0707d1576838c6a912c61c813a48051619fc1363 (patch)
tree19d7e2240874c7249527a246a802311cd39e10f7
parent60e8bb43b9b9336bec5415b13803395e2ff1efd5 (diff)
downloadfreebsd-ports-gnome-0707d1576838c6a912c61c813a48051619fc1363.tar.gz
freebsd-ports-gnome-0707d1576838c6a912c61c813a48051619fc1363.tar.zst
freebsd-ports-gnome-0707d1576838c6a912c61c813a48051619fc1363.zip
XHProf is a function-level hierarchical profiler for PHP and has a simple HTML
based navigational interface. The raw data collection component is implemented in C (as a PHP extension). The reporting/UI layer is all in PHP. It is capable of reporting function-level inclusive and exclusive wall times, memory usage, CPU times and number of calls for each function. Additionally, it supports ability to compare two runs (hierarchical DIFF reports), or aggregate results from multiple runs. WWW: http://pecl.php.net/package/xhprof/ PR: ports/148322 Submitted by: Conor McDermottroe <ports at mcdermottroe.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-xhprof/Makefile24
-rw-r--r--devel/pecl-xhprof/distinfo3
-rw-r--r--devel/pecl-xhprof/pkg-descr9
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 94865c99e383..54f8a93e4cc1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2528,6 +2528,7 @@
SUBDIR += pecl-uploadprogress
SUBDIR += pecl-uuid
SUBDIR += pecl-vld
+ SUBDIR += pecl-xhprof
SUBDIR += pedisassem
SUBDIR += performance
SUBDIR += perlconsole
diff --git a/devel/pecl-xhprof/Makefile b/devel/pecl-xhprof/Makefile
new file mode 100644
index 000000000000..c2494abc2cb6
--- /dev/null
+++ b/devel/pecl-xhprof/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pecl-xhprof
+# Date created: 2 Jul 2010
+# Whom: Conor McDermottroe <ports@mcdermottroe.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xhprof
+PORTVERSION= 0.9.2
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@mcdermottroe.com
+COMMENT= A Hierarchical Profiler for PHP
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/extension
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-xhprof/distinfo b/devel/pecl-xhprof/distinfo
new file mode 100644
index 000000000000..c21c3bdf90b2
--- /dev/null
+++ b/devel/pecl-xhprof/distinfo
@@ -0,0 +1,3 @@
+MD5 (xhprof-0.9.2.tgz) = ae40b153d157e6369a32e2c1a59a61ec
+SHA256 (xhprof-0.9.2.tgz) = 5359ea0a1e16ec6c100dd7adb7285bdcc0f931e0b61631ea364f8b06925ea729
+SIZE (xhprof-0.9.2.tgz) = 931660
diff --git a/devel/pecl-xhprof/pkg-descr b/devel/pecl-xhprof/pkg-descr
new file mode 100644
index 000000000000..56b9cb329a07
--- /dev/null
+++ b/devel/pecl-xhprof/pkg-descr
@@ -0,0 +1,9 @@
+XHProf is a function-level hierarchical profiler for PHP and has a simple HTML
+based navigational interface. The raw data collection component is implemented
+in C (as a PHP extension). The reporting/UI layer is all in PHP. It is capable
+of reporting function-level inclusive and exclusive wall times, memory usage,
+CPU times and number of calls for each function. Additionally, it supports
+ability to compare two runs (hierarchical DIFF reports), or aggregate results
+from multiple runs.
+
+WWW: http://pecl.php.net/package/xhprof/