aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-03-04 03:15:55 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-03-04 03:15:55 +0800
commit0720f2f48224dd8fe1dc735bd49318c8f99ca6d8 (patch)
tree878a766f03233edab1c08ff23bdc6b5c0ba9be82
parent2721dde2fcd76ba754c108fdb88b0312e1a43791 (diff)
downloadfreebsd-ports-gnome-0720f2f48224dd8fe1dc735bd49318c8f99ca6d8.tar.gz
freebsd-ports-gnome-0720f2f48224dd8fe1dc735bd49318c8f99ca6d8.tar.zst
freebsd-ports-gnome-0720f2f48224dd8fe1dc735bd49318c8f99ca6d8.zip
Update to 1.9.4
- Add TEST_DEPENDS - Add NO_ARCH - Allow concurrent installation (USE_PYTHON=concurrent) - Update pkg-descr - Add GitHub repository to WWW - Take maintainership Changes: https://github.com/kislyuk/argcomplete/releases
-rw-r--r--devel/py-argcomplete/Makefile12
-rw-r--r--devel/py-argcomplete/distinfo5
-rw-r--r--devel/py-argcomplete/pkg-descr14
3 files changed, 22 insertions, 9 deletions
diff --git a/devel/py-argcomplete/Makefile b/devel/py-argcomplete/Makefile
index b1aeb549276d..4ccd597ba874 100644
--- a/devel/py-argcomplete/Makefile
+++ b/devel/py-argcomplete/Makefile
@@ -2,18 +2,24 @@
# $FreeBSD$
PORTNAME= argcomplete
-PORTVERSION= 0.8.4
+PORTVERSION= 1.9.4
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Bash tab completion for argparse
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}flake8>=0:devel/py-flake8@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pexpect>=0:misc/py-pexpect@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${FLAVOR}
+
+NO_ARCH= yes
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/devel/py-argcomplete/distinfo b/devel/py-argcomplete/distinfo
index eca3f1ad5114..85eed43c9ddf 100644
--- a/devel/py-argcomplete/distinfo
+++ b/devel/py-argcomplete/distinfo
@@ -1,2 +1,3 @@
-SHA256 (argcomplete-0.8.4.tar.gz) = 925587268e509a8a1cb80c5d3f7190547de2990b7feb46993530a691a14e9255
-SIZE (argcomplete-0.8.4.tar.gz) = 31590
+TIMESTAMP = 1520095580
+SHA256 (argcomplete-1.9.4.tar.gz) = 06c8a54ffaa6bfc9006314498742ec8843601206a3b94212f82657673662ecf1
+SIZE (argcomplete-1.9.4.tar.gz) = 47471
diff --git a/devel/py-argcomplete/pkg-descr b/devel/py-argcomplete/pkg-descr
index 43f054e0f747..49f2fd4dc2a6 100644
--- a/devel/py-argcomplete/pkg-descr
+++ b/devel/py-argcomplete/pkg-descr
@@ -1,9 +1,15 @@
-Argcomplete provides easy, extensible command line tab completion
-of arguments for your Python script.
+Argcomplete provides easy, extensible command line tab completion of arguments
+for your Python script.
It makes two assumptions:
-
-- You're using bash or zsh as your shell
+- You're using bash as your shell (limited support for zsh and tcsh is
+ available)
- You're using argparse to manage your command line arguments/options
+Argcomplete is particularly useful if your program has lots of options or
+subparsers, and if your program can dynamically suggest completions for your
+argument/option values (for example, if the user is browsing resources over the
+network).
+
WWW: https://pypi.python.org/pypi/argcomplete
+WWW: https://github.com/kislyuk/argcomplete