aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2018-06-19 14:56:12 +0800
committercy <cy@FreeBSD.org>2018-06-19 14:56:12 +0800
commit07534a2109dc5d51bc7aa2efd9a08ac3a95fc308 (patch)
tree6f6bd83772509bdc4b4bfd7a69881d797560bbf9
parentfe2b6980ebaaa8ae6c4bb1f03c4b9f9ddf5d91e0 (diff)
downloadfreebsd-ports-gnome-07534a2109dc5d51bc7aa2efd9a08ac3a95fc308.tar.gz
freebsd-ports-gnome-07534a2109dc5d51bc7aa2efd9a08ac3a95fc308.tar.zst
freebsd-ports-gnome-07534a2109dc5d51bc7aa2efd9a08ac3a95fc308.zip
As described in r472760, the "register" keyword is meaningless and
causes at least one port some gas. Remove the keyword from krb5.h.
-rw-r--r--security/krb5-devel/Makefile2
-rw-r--r--security/krb5-devel/files/patch-include_krb5_krb5.hin74
2 files changed, 75 insertions, 1 deletions
diff --git a/security/krb5-devel/Makefile b/security/krb5-devel/Makefile
index 94ca42dce1df..7831f7c43bdd 100644
--- a/security/krb5-devel/Makefile
+++ b/security/krb5-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= krb5
PORTVERSION= 1.17.${MIT_COMMIT_DATE}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
.if !defined(MASTERDIR)
PKGNAMESUFFIX= -devel
diff --git a/security/krb5-devel/files/patch-include_krb5_krb5.hin b/security/krb5-devel/files/patch-include_krb5_krb5.hin
new file mode 100644
index 000000000000..462dcc14a19e
--- /dev/null
+++ b/security/krb5-devel/files/patch-include_krb5_krb5.hin
@@ -0,0 +1,74 @@
+--- include/krb5/krb5.hin.orig 2018-05-12 22:15:24.000000000 -0700
++++ include/krb5/krb5.hin 2018-06-18 23:46:02.119491000 -0700
+@@ -3566,7 +3566,7 @@
+ */
+ krb5_error_code KRB5_CALLCONV
+ krb5_unparse_name(krb5_context context, krb5_const_principal principal,
+- register char **name);
++ char **name);
+
+ /**
+ * Convert krb5_principal structure to string and length.
+@@ -4389,7 +4389,7 @@
+ */
+ krb5_error_code KRB5_CALLCONV_WRONG
+ krb5_principal2salt(krb5_context context,
+- register krb5_const_principal pr, krb5_data *ret);
++ krb5_const_principal pr, krb5_data *ret);
+ /* librc.spec--see rcache.h */
+
+ /* libcc.spec */
+@@ -4730,7 +4730,7 @@
+ * This function frees the contents of @a val and the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_error(krb5_context context, register krb5_error *val);
++krb5_free_error(krb5_context context, krb5_error *val);
+
+ /**
+ * Free a krb5_creds structure.
+@@ -4763,7 +4763,7 @@
+ * This function frees the contents of @a val and the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_checksum(krb5_context context, register krb5_checksum *val);
++krb5_free_checksum(krb5_context context, krb5_checksum *val);
+
+ /**
+ * Free the contents of a krb5_checksum structure.
+@@ -4774,7 +4774,7 @@
+ * This function frees the contents of @a val, but not the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_checksum_contents(krb5_context context, register krb5_checksum *val);
++krb5_free_checksum_contents(krb5_context context, krb5_checksum *val);
+
+ /**
+ * Free a krb5_keyblock structure.
+@@ -4785,7 +4785,7 @@
+ * This function frees the contents of @a val and the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_keyblock(krb5_context context, register krb5_keyblock *val);
++krb5_free_keyblock(krb5_context context, krb5_keyblock *val);
+
+ /**
+ * Free the contents of a krb5_keyblock structure.
+@@ -4796,7 +4796,7 @@
+ * This function frees the contents of @a key, but not the structure itself.
+ */
+ void KRB5_CALLCONV
+-krb5_free_keyblock_contents(krb5_context context, register krb5_keyblock *key);
++krb5_free_keyblock_contents(krb5_context context, krb5_keyblock *key);
+
+ /**
+ * Free a krb5_ap_rep_enc_part structure.
+@@ -4912,7 +4912,7 @@
+ * Kerberos error codes
+ */
+ krb5_error_code KRB5_CALLCONV
+-krb5_timeofday(krb5_context context, register krb5_timestamp *timeret);
++krb5_timeofday(krb5_context context, krb5_timestamp *timeret);
+
+ /**
+ * Check if a timestamp is within the allowed clock skew of the current time.