aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-18 05:24:03 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-18 05:24:03 +0800
commit075dd77083d9682f67957efc0d20a17412e76805 (patch)
tree086f2652276141b35b1a606b5b777429c05e34b4
parent1df8579a32ae665f78078a0c423ed5bfb1418bde (diff)
downloadfreebsd-ports-gnome-075dd77083d9682f67957efc0d20a17412e76805.tar.gz
freebsd-ports-gnome-075dd77083d9682f67957efc0d20a17412e76805.tar.zst
freebsd-ports-gnome-075dd77083d9682f67957efc0d20a17412e76805.zip
New port: science/py-PyQuante: Quantum chemistry in Python
-rw-r--r--science/Makefile1
-rw-r--r--science/py-PyQuante/Makefile20
-rw-r--r--science/py-PyQuante/distinfo3
-rw-r--r--science/py-PyQuante/pkg-descr12
4 files changed, 36 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 21e7a9dc5c29..679f3fa86430 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -163,6 +163,7 @@
SUBDIR += psychopy
SUBDIR += pulseview
SUBDIR += py-DendroPy
+ SUBDIR += py-PyQuante
SUBDIR += py-MDAnalysis
SUBDIR += py-MDAnalysisTests
SUBDIR += py-OpenFermion
diff --git a/science/py-PyQuante/Makefile b/science/py-PyQuante/Makefile
new file mode 100644
index 000000000000..a49fa7eea14e
--- /dev/null
+++ b/science/py-PyQuante/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= PyQuante
+DISTVERSION= 1.6.5
+CATEGORIES= science python
+MASTER_SITES= SF/${PORTNAME:tl}/${PORTNAME}-${DISTVERSION:R}/${PORTNAME}-${DISTVERSION}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Quantum chemistry in Python
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python:2.7-
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/science/py-PyQuante/distinfo b/science/py-PyQuante/distinfo
new file mode 100644
index 000000000000..576998c357ce
--- /dev/null
+++ b/science/py-PyQuante/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529269768
+SHA256 (PyQuante-1.6.5.tar.gz) = 145ac192503c7c0cf9e1b262a39a7de3a43a50e53d6884b45124ade0cfcdb7cc
+SIZE (PyQuante-1.6.5.tar.gz) = 681165
diff --git a/science/py-PyQuante/pkg-descr b/science/py-PyQuante/pkg-descr
new file mode 100644
index 000000000000..a56fd306a6e2
--- /dev/null
+++ b/science/py-PyQuante/pkg-descr
@@ -0,0 +1,12 @@
+PyQuante (Sourceforge Project Page) is an open-source suite of programs for
+developing quantum chemistry methods. The program is written in the Python
+programming language, but has many "rate-determining" modules also written
+in C for speed. The resulting code, though not as fast as Jaguar, NWChem,
+Gaussian, or MPQC, is much easier to understand and modify. The goal of this
+software is not necessarily to provide a working quantum chemistry program
+(although it will hopefully do that), but rather to provide a well-engineered
+set of tools so that scientists can construct their own quantum chemistry
+programs without going through the tedium of having to write every low-level
+routine.
+
+WWW: http://pyquante.sourceforge.net/