aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-01-22 04:53:55 +0800
committerrakuco <rakuco@FreeBSD.org>2014-01-22 04:53:55 +0800
commit075e3ed61920bb0215f6227c8548fa436d344773 (patch)
tree9ade94420ddaddddb716f4707dfe40d515264dbd
parenta032c2e68ec648d5550c770b0391e009103f6437 (diff)
downloadfreebsd-ports-gnome-075e3ed61920bb0215f6227c8548fa436d344773.tar.gz
freebsd-ports-gnome-075e3ed61920bb0215f6227c8548fa436d344773.tar.zst
freebsd-ports-gnome-075e3ed61920bb0215f6227c8548fa436d344773.zip
Partially fix the build.
Sphinx underwent an incompatible change in version 1.2 that removed the sphinx.ext.refcounting module. The module is referenced by shiboken's Sphinx configuration file, and the build fails. Fix it by removing the reference to sphinx.ext.refcounting, as it does not seem to be required and was probably added by default when the configuration file was generated. As mentioned, this is a partial fix: platforms that use libc++ by default are still broken due to other issues, but at least FreeBSD 8 and 9 should have a working package again. While here, also use the new syntax for LIB_DEPENDS. PR: ports/185179 Submitted by: rakuco@ Approved by: maintainer timeout (27 days) MFH: 2014Q1
-rw-r--r--devel/shiboken/Makefile4
-rw-r--r--devel/shiboken/files/patch-doc__conf.py.in11
2 files changed, 13 insertions, 2 deletions
diff --git a/devel/shiboken/Makefile b/devel/shiboken/Makefile
index b033a92883ba..f30a1f0185e8 100644
--- a/devel/shiboken/Makefile
+++ b/devel/shiboken/Makefile
@@ -13,8 +13,8 @@ COMMENT= C++ code generator for CPython extensions
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
- xslt:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libxslt.so:${PORTSDIR}/textproc/libxslt
PLIST_SUB= PORTVERSION=${PORTVERSION} \
PYTHON_VERSION=${PYTHON_VERSION}
diff --git a/devel/shiboken/files/patch-doc__conf.py.in b/devel/shiboken/files/patch-doc__conf.py.in
new file mode 100644
index 000000000000..5d4d8f5e466e
--- /dev/null
+++ b/devel/shiboken/files/patch-doc__conf.py.in
@@ -0,0 +1,11 @@
+--- doc/conf.py.in.orig 2013-12-25 19:56:52.000000000 +0200
++++ doc/conf.py.in 2013-12-25 19:57:00.000000000 +0200
+@@ -22,7 +22,7 @@
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.doctest', 'sphinx.ext.ifconfig', 'sphinx.ext.refcounting', 'sphinx.ext.coverage']
++extensions = ['sphinx.ext.autodoc', 'sphinx.ext.doctest', 'sphinx.ext.ifconfig', 'sphinx.ext.coverage']
+
+ rst_epilog = """
+ .. |project| replace:: Shiboken