aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-17 05:16:45 +0800
committeredwin <edwin@FreeBSD.org>2004-12-17 05:16:45 +0800
commit078be5a5a520cbb7eaf1d1bccba109d9fd67adac (patch)
tree32d57caaca3b465d390e87b39927a8eb6b9a2acd
parent6222ea71691a9e1e9354ad5413556b884179cd59 (diff)
downloadfreebsd-ports-gnome-078be5a5a520cbb7eaf1d1bccba109d9fd67adac.tar.gz
freebsd-ports-gnome-078be5a5a520cbb7eaf1d1bccba109d9fd67adac.tar.zst
freebsd-ports-gnome-078be5a5a520cbb7eaf1d1bccba109d9fd67adac.zip
explicitely require perl 5.6.1 or higher
Submitted by: Venkata Pingali <pingali@ISI.EDU>
-rw-r--r--net/xbone-gui/Makefile4
-rw-r--r--net/xbone/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/net/xbone-gui/Makefile b/net/xbone-gui/Makefile
index 5b28ce3dfd17..32e4f2a93aa2 100644
--- a/net/xbone-gui/Makefile
+++ b/net/xbone-gui/Makefile
@@ -40,4 +40,8 @@ INSTALL_TARGET= gui
FORBIDDEN= "X-Bone ${PORTVERSION} does not support FreeBSD prior to 4.7"
.endif
+.if ${PERL_LEVEL} < 500601
+IGNORE= "X-Bone requires Perl version 5.6.1 or higher. Install lang/perl5.8 and try again."
+.endif
+
.include <bsd.port.post.mk>
diff --git a/net/xbone/Makefile b/net/xbone/Makefile
index dba87e6bf8eb..44c920efb09a 100644
--- a/net/xbone/Makefile
+++ b/net/xbone/Makefile
@@ -45,6 +45,10 @@ INSTALL_TARGET= node
FORBIDDEN= "X-Bone ${PORTVERSION} does not support FreeBSD prior to 4.7"
.endif
+.if ${PERL_LEVEL} < 500601
+IGNORE= "X-Bone requires Perl version 5.6.1 or higher. Install lang/perl5.8 and try again."
+.endif
+
MAN5= XB_Params.pm.5 xbone.conf.5 xbone-gui.conf.5
MAN8= X-Bone.8 xb-node-daemon.8 xb-config.8 xb-gui-config.8 xbonectl.8