aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2004-12-23 14:19:23 +0800
committergreen <green@FreeBSD.org>2004-12-23 14:19:23 +0800
commit07f2461578c502203f7f0c775c050b96697b32d3 (patch)
treec7aef025e42427b29dc4015505e1ee576502fab4
parent8599ddb6bc5660e2217960bf55c2fbad33284ff7 (diff)
downloadfreebsd-ports-gnome-07f2461578c502203f7f0c775c050b96697b32d3.tar.gz
freebsd-ports-gnome-07f2461578c502203f7f0c775c050b96697b32d3.tar.zst
freebsd-ports-gnome-07f2461578c502203f7f0c775c050b96697b32d3.zip
Attempt to make pam_alreadyloggedin work on 4.x again.
Submitted by: vs
-rw-r--r--security/pam_alreadyloggedin/Makefile5
-rw-r--r--security/pam_alreadyloggedin/files/patch-pam_alreadyloggedin.c14
2 files changed, 15 insertions, 4 deletions
diff --git a/security/pam_alreadyloggedin/Makefile b/security/pam_alreadyloggedin/Makefile
index c4089d1e7db8..7936aff7f154 100644
--- a/security/pam_alreadyloggedin/Makefile
+++ b/security/pam_alreadyloggedin/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pam_alreadyloggedin
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://green.homeunix.org/~green/
@@ -19,10 +20,6 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD 4.x"
-.endif
-
.if defined(NOPROFILE)
PLIST_SUB+= PROFILE="@comment "
.else
diff --git a/security/pam_alreadyloggedin/files/patch-pam_alreadyloggedin.c b/security/pam_alreadyloggedin/files/patch-pam_alreadyloggedin.c
new file mode 100644
index 000000000000..f676d9a38c5d
--- /dev/null
+++ b/security/pam_alreadyloggedin/files/patch-pam_alreadyloggedin.c
@@ -0,0 +1,14 @@
+--- pam_alreadyloggedin.c.orig Tue Sep 21 17:41:20 2004
++++ pam_alreadyloggedin.c Thu Dec 23 00:58:02 2004
+@@ -70,6 +70,11 @@
+ int inutmp(struct utmp *utmp, const char *lineglob, const char *username,
+ uid_t uid);
+
++#ifdef PAM_MAX_OPTIONS
++/* The old PAM requires this structure. */
++static struct options options;
++#endif
++
+ PAM_EXTERN int
+ pam_sm_authenticate(pam_handle_t *pamh, int flags __unused, int argc,
+ const char **argv)