aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-07-10 18:49:24 +0800
committerwjv <wjv@FreeBSD.org>2002-07-10 18:49:24 +0800
commit0848fb0c76b4c654494aeaeefe59b36d6911cb5b (patch)
treee725864d1996605604862901b9b016158f024567
parentd4a6a228711384f3d6d9537511a22b0052b9968a (diff)
downloadfreebsd-ports-gnome-0848fb0c76b4c654494aeaeefe59b36d6911cb5b.tar.gz
freebsd-ports-gnome-0848fb0c76b4c654494aeaeefe59b36d6911cb5b.tar.zst
freebsd-ports-gnome-0848fb0c76b4c654494aeaeefe59b36d6911cb5b.zip
Add py-soapy 0.1, A SOAP/XML schema library for Python.
-rw-r--r--net/Makefile1
-rw-r--r--net/py-soapy/Makefile31
-rw-r--r--net/py-soapy/distinfo1
-rw-r--r--net/py-soapy/pkg-comment1
-rw-r--r--net/py-soapy/pkg-descr12
-rw-r--r--net/py-soapy/pkg-plist14
6 files changed, 60 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5923fdeda147..953c6c5a0ddf 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -438,6 +438,7 @@
SUBDIR += py-smb
SUBDIR += py-snmp
SUBDIR += py-soap
+ SUBDIR += py-soapy
SUBDIR += py-spreadmodule
SUBDIR += py-xmlrpc
SUBDIR += py-xmlrpclib
diff --git a/net/py-soapy/Makefile b/net/py-soapy/Makefile
new file mode 100644
index 000000000000..c132616555e9
--- /dev/null
+++ b/net/py-soapy/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-soapy
+# Date created: 10 July 2002
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= soapy
+PORTVERSION= 0.1
+CATEGORIES= net python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wjv@FreeBSD.org
+
+RUN_DEPENDS= ${PYXML}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${DOCSDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @ ${MKDIR} ${EXAMPLESDIR}/test
+ @ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/test/* ${EXAMPLESDIR}/test
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/py-soapy/distinfo b/net/py-soapy/distinfo
new file mode 100644
index 000000000000..e7e3f13e7edc
--- /dev/null
+++ b/net/py-soapy/distinfo
@@ -0,0 +1 @@
+MD5 (soapy-0.1.tar.gz) = 7d6ccb43228ec7da343344f5661d4ce3
diff --git a/net/py-soapy/pkg-comment b/net/py-soapy/pkg-comment
new file mode 100644
index 000000000000..5be081ad2d92
--- /dev/null
+++ b/net/py-soapy/pkg-comment
@@ -0,0 +1 @@
+SOAP/XML schema library for Python
diff --git a/net/py-soapy/pkg-descr b/net/py-soapy/pkg-descr
new file mode 100644
index 000000000000..5cda6c748b50
--- /dev/null
+++ b/net/py-soapy/pkg-descr
@@ -0,0 +1,12 @@
+From the website:
+
+ SOAPy is a SOAP/XML Schema Library for Python. Given either a WSDL or SDL
+ document, SOAPy discovers the published API for a web service and exposes
+ it to Python applications as transparently as possible. SOAPy is designed
+ to support WSDL 1.0 and SOAP 1.1, and whatever version of SDL is being used
+ to power Microsoft's TerraService web service. :)
+
+Author: Adam Elman <aelman@users.sourceforge.net>
+WWW: http://soapy.sourceforge.net/
+
+-- Johann Visagie <wjv@FreeBSD.org>
diff --git a/net/py-soapy/pkg-plist b/net/py-soapy/pkg-plist
new file mode 100644
index 000000000000..15aa57b1a479
--- /dev/null
+++ b/net/py-soapy/pkg-plist
@@ -0,0 +1,14 @@
+%%PORTDOCS%%share/doc/soapy/README
+%%PORTDOCS%%share/examples/soapy/README.txt
+%%PORTDOCS%%share/examples/soapy/get_temperature.py
+%%PORTDOCS%%share/examples/soapy/terraserver_image.py
+%%PORTDOCS%%share/examples/soapy/test/testsoap.py
+lib/%%PYTHON_VERSION%%/site-packages/schema.py
+lib/%%PYTHON_VERSION%%/site-packages/schema.pyc
+lib/%%PYTHON_VERSION%%/site-packages/schema.pyo
+lib/%%PYTHON_VERSION%%/site-packages/soap.py
+lib/%%PYTHON_VERSION%%/site-packages/soap.pyc
+lib/%%PYTHON_VERSION%%/site-packages/soap.pyo
+%%PORTDOCS%%@dirrm share/examples/soapy/test
+%%PORTDOCS%%@dirrm share/examples/soapy
+%%PORTDOCS%%@dirrm share/doc/soapy