aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-09-02 01:36:34 +0800
committeradamw <adamw@FreeBSD.org>2014-09-02 01:36:34 +0800
commit0898da0eaf72140458d0feaf5c0db7e12b52db8c (patch)
treef46ab46af568115f6ff848f90d1c610b9ba0f77b
parent944baefe5cf23a7695b36f84eef0b6b89d34f72d (diff)
downloadfreebsd-ports-gnome-0898da0eaf72140458d0feaf5c0db7e12b52db8c.tar.gz
freebsd-ports-gnome-0898da0eaf72140458d0feaf5c0db7e12b52db8c.tar.zst
freebsd-ports-gnome-0898da0eaf72140458d0feaf5c0db7e12b52db8c.zip
Add devel/p5-Term-ProgressBar-Simple, a simpler interface to
Term::ProgressBar. Progress bars are handy - they tell you how much work has been done, how much is left to do and estimate how long it will take. But they can be fiddly! This module does the right thing in almost all cases in a really convenient way. It wraps Term::ProgressBar::Quiet so there is no output unless the code is running interactively - lets you put them in cron scripts. It deals with minor updates - only refreshes the screen when it will change what the user sees so it is efficient. It completes the progress bar when the progress object is destroyed (explicitly or by going out of scope) - no more '99%' done. WWW: http://search.cpan.org/dist/Term-ProgressBar-Simple/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Term-ProgressBar-Simple/Makefile22
-rw-r--r--devel/p5-Term-ProgressBar-Simple/distinfo2
-rw-r--r--devel/p5-Term-ProgressBar-Simple/pkg-descr14
-rw-r--r--devel/p5-Term-ProgressBar-Simple/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 63306058f79f..fb90f62188bd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2821,6 +2821,7 @@
SUBDIR += p5-Term-Menus
SUBDIR += p5-Term-ProgressBar
SUBDIR += p5-Term-ProgressBar-Quiet
+ SUBDIR += p5-Term-ProgressBar-Simple
SUBDIR += p5-Term-Prompt
SUBDIR += p5-Term-Query
SUBDIR += p5-Term-RawInput
diff --git a/devel/p5-Term-ProgressBar-Simple/Makefile b/devel/p5-Term-ProgressBar-Simple/Makefile
new file mode 100644
index 000000000000..b8be40a3f6f4
--- /dev/null
+++ b/devel/p5-Term-ProgressBar-Simple/Makefile
@@ -0,0 +1,22 @@
+# Created by: adamw
+# $FreeBSD$
+
+PORTNAME= Term-ProgressBar-Simple
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Simpler Term::ProgressBar interface
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Term-ProgressBar-Quiet>=0:${PORTSDIR}/devel/p5-Term-ProgressBar-Quiet
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Term-ProgressBar-Simple/distinfo b/devel/p5-Term-ProgressBar-Simple/distinfo
new file mode 100644
index 000000000000..45cc17d20a70
--- /dev/null
+++ b/devel/p5-Term-ProgressBar-Simple/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Term-ProgressBar-Simple-0.03.tar.gz) = a20db3c67d5bdfd0c1fab392c6d1c26880a7ee843af602af4f9b53a7043579a6
+SIZE (Term-ProgressBar-Simple-0.03.tar.gz) = 3557
diff --git a/devel/p5-Term-ProgressBar-Simple/pkg-descr b/devel/p5-Term-ProgressBar-Simple/pkg-descr
new file mode 100644
index 000000000000..d3587bf4aa1f
--- /dev/null
+++ b/devel/p5-Term-ProgressBar-Simple/pkg-descr
@@ -0,0 +1,14 @@
+Progress bars are handy - they tell you how much work has been done, how much
+is left to do and estimate how long it will take. But they can be fiddly! This
+module does the right thing in almost all cases in a really convenient way.
+
+It wraps Term::ProgressBar::Quiet so there is no output unless the code is
+running interactively - lets you put them in cron scripts.
+
+It deals with minor updates - only refreshes the screen when it will change
+what the user sees so it is efficient.
+
+It completes the progress bar when the progress object is destroyed (explicitly
+or by going out of scope) - no more '99%' done.
+
+WWW: http://search.cpan.org/dist/Term-ProgressBar-Simple/
diff --git a/devel/p5-Term-ProgressBar-Simple/pkg-plist b/devel/p5-Term-ProgressBar-Simple/pkg-plist
new file mode 100644
index 000000000000..0b8282153f96
--- /dev/null
+++ b/devel/p5-Term-ProgressBar-Simple/pkg-plist
@@ -0,0 +1,4 @@
+%%PERL5_MAN3%%/Term::ProgressBar::Simple.3.gz
+%%SITE_PERL%%/Term/ProgressBar/Simple.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ProgressBar/Simple/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/ProgressBar/Simple