aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-29 04:24:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-04-29 04:24:54 +0800
commit08a10eae093aee62a0c4953c07d12a4fd1b87254 (patch)
tree79c47f2e570172c7bc1574546b51bf8c9866e97e
parent561150cfe79845af460c0cb86630c6bc9d2ec32e (diff)
downloadfreebsd-ports-gnome-08a10eae093aee62a0c4953c07d12a4fd1b87254.tar.gz
freebsd-ports-gnome-08a10eae093aee62a0c4953c07d12a4fd1b87254.tar.zst
freebsd-ports-gnome-08a10eae093aee62a0c4953c07d12a4fd1b87254.zip
Add rubygem-oauth212 1.2.0 (copied from rubygem-oauth2)
- Add PORTSCOUT
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-oauth212/Makefile29
-rw-r--r--net/rubygem-oauth212/distinfo3
-rw-r--r--net/rubygem-oauth212/files/patch-gemspec11
-rw-r--r--net/rubygem-oauth212/pkg-descr6
5 files changed, 50 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 454fb9c84265..38b427d1ca9e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1189,6 +1189,7 @@
SUBDIR += rubygem-network_interface
SUBDIR += rubygem-oauth
SUBDIR += rubygem-oauth2
+ SUBDIR += rubygem-oauth212
SUBDIR += rubygem-octokit
SUBDIR += rubygem-octopress-deploy
SUBDIR += rubygem-omniauth-auth0
diff --git a/net/rubygem-oauth212/Makefile b/net/rubygem-oauth212/Makefile
new file mode 100644
index 000000000000..8fee65675daa
--- /dev/null
+++ b/net/rubygem-oauth212/Makefile
@@ -0,0 +1,29 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= oauth2
+PORTVERSION= 1.2.0
+PORTREVISION= 2
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 12
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby wrapper for the OAuth 2.0 protocol
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-faraday>=0.8:www/rubygem-faraday \
+ rubygem-jwt>=1.0:www/rubygem-jwt \
+ rubygem-multi_json>=1.3:devel/rubygem-multi_json \
+ rubygem-multi_xml>=0.5:textproc/rubygem-multi_xml \
+ rubygem-rack>=1.2:www/rubygem-rack
+
+PORTSCOUT= limit:^1\.2\.
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-oauth212/distinfo b/net/rubygem-oauth212/distinfo
new file mode 100644
index 000000000000..571a94b7f9dc
--- /dev/null
+++ b/net/rubygem-oauth212/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1471421475
+SHA256 (rubygem/oauth2-1.2.0.gem) = 23a959386dae98f64ccac7a68c517666c611ff782477b3e1ff8c0b1451d7457c
+SIZE (rubygem/oauth2-1.2.0.gem) = 15360
diff --git a/net/rubygem-oauth212/files/patch-gemspec b/net/rubygem-oauth212/files/patch-gemspec
new file mode 100644
index 000000000000..d1a55bf9223c
--- /dev/null
+++ b/net/rubygem-oauth212/files/patch-gemspec
@@ -0,0 +1,11 @@
+--- oauth2.gemspec.orig 2017-01-15 03:55:34 UTC
++++ oauth2.gemspec
+@@ -21,7 +21,7 @@ Gem::Specification.new do |s|
+ s.specification_version = 4
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+- s.add_runtime_dependency(%q<faraday>.freeze, ["< 0.10", ">= 0.8"])
++ s.add_runtime_dependency(%q<faraday>.freeze, [">= 0.8"])
+ s.add_runtime_dependency(%q<jwt>.freeze, ["~> 1.0"])
+ s.add_runtime_dependency(%q<multi_json>.freeze, ["~> 1.3"])
+ s.add_runtime_dependency(%q<multi_xml>.freeze, ["~> 0.5"])
diff --git a/net/rubygem-oauth212/pkg-descr b/net/rubygem-oauth212/pkg-descr
new file mode 100644
index 000000000000..75a6d3579bd6
--- /dev/null
+++ b/net/rubygem-oauth212/pkg-descr
@@ -0,0 +1,6 @@
+OAuth2 is a Ruby wrapper for the OAuth 2.0 specification. This is a work in
+progress, being built first to solve the pragmatic process of connecting to
+existing OAuth 2.0 endpoints (a.k.a. Facebook) with the goal of building it up
+to meet the entire specification over time.
+
+WWW: https://github.com/intridea/oauth2