aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-06-09 20:18:26 +0800
committerolgeni <olgeni@FreeBSD.org>2015-06-09 20:18:26 +0800
commit08b02e44feba771bdef43cf4e17d04fe94737e59 (patch)
tree1df60e838c33e669e154e4f451acd9d780f0d051
parent86c06c3ef4c0e2fab6b54045038e89e23b333dd0 (diff)
downloadfreebsd-ports-gnome-08b02e44feba771bdef43cf4e17d04fe94737e59.tar.gz
freebsd-ports-gnome-08b02e44feba771bdef43cf4e17d04fe94737e59.tar.zst
freebsd-ports-gnome-08b02e44feba771bdef43cf4e17d04fe94737e59.zip
Add hotfix for unhandled cipher algorithms.
Obtained from: Ingela Andin (ingela.andin@gmail.com) on erlang-questions
-rw-r--r--lang/erlang-runtime17/Makefile1
-rw-r--r--lang/erlang-runtime17/files/patch-lib_ssl_src_ssl__cipher.erl22
2 files changed, 23 insertions, 0 deletions
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index e0c843d5a254..4a73383710a6 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -3,6 +3,7 @@
PORTNAME= erlang
PORTVERSION= 17.5.6
+PORTREVISION= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
diff --git a/lang/erlang-runtime17/files/patch-lib_ssl_src_ssl__cipher.erl b/lang/erlang-runtime17/files/patch-lib_ssl_src_ssl__cipher.erl
new file mode 100644
index 000000000000..efa6734a3e19
--- /dev/null
+++ b/lang/erlang-runtime17/files/patch-lib_ssl_src_ssl__cipher.erl
@@ -0,0 +1,22 @@
+--- lib/ssl/src/ssl_cipher.erl.orig 2015-03-31 12:32:52 UTC
++++ lib/ssl/src/ssl_cipher.erl
+@@ -1209,7 +1209,8 @@ hash_algorithm(?SHA) -> sha;
+ hash_algorithm(?SHA224) -> sha224;
+ hash_algorithm(?SHA256) -> sha256;
+ hash_algorithm(?SHA384) -> sha384;
+-hash_algorithm(?SHA512) -> sha512.
++hash_algorithm(?SHA512) -> sha512;
++hash_algorithm(Other) when is_integer(Other) andalso ((Other >= 224) and (Other =< 255)) -> Other.
+
+ sign_algorithm(anon) -> ?ANON;
+ sign_algorithm(rsa) -> ?RSA;
+@@ -1218,7 +1219,8 @@ sign_algorithm(ecdsa) -> ?ECDSA;
+ sign_algorithm(?ANON) -> anon;
+ sign_algorithm(?RSA) -> rsa;
+ sign_algorithm(?DSA) -> dsa;
+-sign_algorithm(?ECDSA) -> ecdsa.
++sign_algorithm(?ECDSA) -> ecdsa;
++sign_algorithm(Other) when is_integer(Other) andalso ((Other >= 224) and (Other =< 255)) -> Other.
+
+ hash_size(null) ->
+ 0;