aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-07-10 00:24:55 +0800
committermakc <makc@FreeBSD.org>2010-07-10 00:24:55 +0800
commit090d9be1f5b47a1e9562eab31e871ef029965b7b (patch)
tree4c5e3643ea0161db6e8c4c2b530559ee5f72b26c
parent666b809dac57275e09581e8b766100777fa1ba5e (diff)
downloadfreebsd-ports-gnome-090d9be1f5b47a1e9562eab31e871ef029965b7b.tar.gz
freebsd-ports-gnome-090d9be1f5b47a1e9562eab31e871ef029965b7b.tar.zst
freebsd-ports-gnome-090d9be1f5b47a1e9562eab31e871ef029965b7b.zip
Fix build for on powerpc64
PR: ports/148199 Submitted by: nwhitehorn@
-rw-r--r--x11-toolkits/qt4-gui/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index 057936b982ad..25ce7d69204b 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -84,6 +84,12 @@ RUN_DEPENDS+= ${FONTSCALE}:${X_FONTS_TTF_PORT} \
${FONTENCOD}:${X_FONTS_ENCODINGS_PORT}
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == powerpc64
+CFLAGS+= -mminimal-toc
+.endif
+
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
@@ -99,4 +105,4 @@ post-configure:
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/lib/pkgconfig/QtGui.pc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>