aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2019-09-22 18:16:13 +0800
committerpi <pi@FreeBSD.org>2019-09-22 18:16:13 +0800
commit09c18b5078162354b976cfd1df524f412d3414da (patch)
treef360d89420d2f498aa23d74f4a8cf1b9c256dd46
parent4be864ac594a30a2b823c424baf4147d74ef11ba (diff)
downloadfreebsd-ports-gnome-09c18b5078162354b976cfd1df524f412d3414da.tar.gz
freebsd-ports-gnome-09c18b5078162354b976cfd1df524f412d3414da.tar.zst
freebsd-ports-gnome-09c18b5078162354b976cfd1df524f412d3414da.zip
New port: devel/ros-wstool
Command-line tools for maintaining a workspace from multiple version-control systems. This is primarily used as a tool for build a workspace for the Robot Operating System (ROS). WWW: https://github.com/vcstools/wstool PR: 240639 Submitted by: Trenton Schulz <trueos@norwegianrockcat.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ros-wstool/Makefile23
-rw-r--r--devel/ros-wstool/distinfo3
-rw-r--r--devel/ros-wstool/pkg-descr7
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6a03e8ca21f7..6c312b20ea0d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5395,6 +5395,7 @@
SUBDIR += root-doc
SUBDIR += ros-rosinstall_generator
SUBDIR += ros-vcstools
+ SUBDIR += ros-wstool
SUBDIR += rote
SUBDIR += rpc2
SUBDIR += rpclib
diff --git a/devel/ros-wstool/Makefile b/devel/ros-wstool/Makefile
new file mode 100644
index 000000000000..6e4fbb244f63
--- /dev/null
+++ b/devel/ros-wstool/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= ros-wstool
+DISTVERSION= 0.1.17
+CATEGORIES= devel
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= trueos@norwegianrockcat.com
+COMMENT= Tool for managing a workspace of heterogenous SCM repositories
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ros-vcstools>=0:devel/ros-vcstools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3:devel/py-yaml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+USE_GITHUB= yes
+GH_ACCOUNT= vcstools
+GH_PROJECT= wstool
+
+.include <bsd.port.mk>
diff --git a/devel/ros-wstool/distinfo b/devel/ros-wstool/distinfo
new file mode 100644
index 000000000000..7a6cc1a53749
--- /dev/null
+++ b/devel/ros-wstool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516531178
+SHA256 (vcstools-wstool-0.1.17_GH0.tar.gz) = 5f352e0063393231ae18ddd7c8488511a4ebbd045905e5edcd309a056e47e911
+SIZE (vcstools-wstool-0.1.17_GH0.tar.gz) = 76168
diff --git a/devel/ros-wstool/pkg-descr b/devel/ros-wstool/pkg-descr
new file mode 100644
index 000000000000..e0c28efcaa5f
--- /dev/null
+++ b/devel/ros-wstool/pkg-descr
@@ -0,0 +1,7 @@
+Command-line tools for maintaining a workspace from multiple
+version-control systems.
+
+This is primarily used as a tool for build a workspace for the Robot
+Operating System (ROS).
+
+WWW: https://github.com/vcstools/wstool