aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-24 04:46:26 +0800
committeryuri <yuri@FreeBSD.org>2018-03-24 04:46:26 +0800
commit0a051dc793064b0c99680f516b6ec4d95e09778a (patch)
tree8d974d83db22a92afcecfe41bfc54d9cdf1b4292
parent743276fcd0da1aaa513db68a77b37876b710296c (diff)
downloadfreebsd-ports-gnome-0a051dc793064b0c99680f516b6ec4d95e09778a.tar.gz
freebsd-ports-gnome-0a051dc793064b0c99680f516b6ec4d95e09778a.tar.zst
freebsd-ports-gnome-0a051dc793064b0c99680f516b6ec4d95e09778a.zip
comms/aldo: Update 0.7.5 -> 0.7.7
Port changes: * Change to DISTVERSION * Add LICENSE/LICENSE_FILE * Remove USE_GCC * Add USES=localbase instead of CPPFLAGS/LIBS PR: 226349 Submitted by: Dmitri Goutnik <dg@syrec.org> Approved by: lambert@lambertfam.org (maintainer timeout; 19 days)
-rw-r--r--comms/aldo/Makefile11
-rw-r--r--comms/aldo/distinfo5
-rw-r--r--comms/aldo/files/patch-configure4
-rw-r--r--comms/aldo/files/patch-include_Makefile.in4
-rw-r--r--comms/aldo/files/patch-src_audioworkspace.cc20
-rw-r--r--comms/aldo/files/patch-src_menu.cc25
6 files changed, 37 insertions, 32 deletions
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index ce1a614ee430..e788b4be5b3c 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -2,21 +2,20 @@
# $FreeBSD$
PORTNAME= aldo
-PORTVERSION= 0.7.5
-PORTREVISION= 6
+DISTVERSION= 0.7.7
CATEGORIES= comms hamradio
MASTER_SITES= SAVANNAH
MAINTAINER= lambert@lambertfam.org
COMMENT= Morse code training program
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libao.so:audio/libao
+USES= compiler:c++0x gmake localbase tar:bzip2
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-USES= gmake libtool tar:bzip2
-USE_GCC= any
PLIST_FILES= bin/aldo \
man/man1/aldo.1.gz
diff --git a/comms/aldo/distinfo b/comms/aldo/distinfo
index e474475e8103..c3513c6750b3 100644
--- a/comms/aldo/distinfo
+++ b/comms/aldo/distinfo
@@ -1,2 +1,3 @@
-SHA256 (aldo-0.7.5.tar.bz2) = 15f9dbcab48c6ba3fba6a4d3e9a030bad3255d4a4b47677388a1e46782aa84ea
-SIZE (aldo-0.7.5.tar.bz2) = 98612
+TIMESTAMP = 1521837318
+SHA256 (aldo-0.7.7.tar.bz2) = f1b8849d09267fff3c1f5122097d90fec261291f51b1e075f37fad8f1b7d9f92
+SIZE (aldo-0.7.7.tar.bz2) = 112000
diff --git a/comms/aldo/files/patch-configure b/comms/aldo/files/patch-configure
index f67b730eae30..ecac41752b54 100644
--- a/comms/aldo/files/patch-configure
+++ b/comms/aldo/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2007-11-05 09:22:11 UTC
+--- configure.orig 2012-03-31 11:55:36 UTC
+++ configure
-@@ -2220,9 +2220,6 @@ am__tar='${AMTAR} chof - "$$tardir"'; am
+@@ -2725,9 +2725,6 @@ am__tar='$${TAR-tar} chof - "$$tardir"'
diff --git a/comms/aldo/files/patch-include_Makefile.in b/comms/aldo/files/patch-include_Makefile.in
index 2a57933fe40e..370528edcfa7 100644
--- a/comms/aldo/files/patch-include_Makefile.in
+++ b/comms/aldo/files/patch-include_Makefile.in
@@ -1,6 +1,6 @@
---- include/Makefile.in.orig 2017-03-24 13:33:28 UTC
+--- include/Makefile.in.orig 2012-03-31 11:55:36 UTC
+++ include/Makefile.in
-@@ -101,7 +101,7 @@ PATH_SEPARATOR = @PATH_SEPARATOR@
+@@ -105,7 +105,7 @@ PATH_SEPARATOR = @PATH_SEPARATOR@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
diff --git a/comms/aldo/files/patch-src_audioworkspace.cc b/comms/aldo/files/patch-src_audioworkspace.cc
deleted file mode 100644
index 6f0b4288e755..000000000000
--- a/comms/aldo/files/patch-src_audioworkspace.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/audioworkspace.cc.orig 2007-11-05 08:58:46 UTC
-+++ src/audioworkspace.cc
-@@ -31,7 +31,8 @@
- #include <cmath>
- #include <iostream>
- #include <limits>
--
-+#include <string.h>
-+
- using namespace std;
- using namespace libaudiostream;
-
-@@ -104,6 +105,7 @@ oastream AudioWorkSpace::create_output_s
- {
- ao_sample_format format;
-
-+ memset(&format, 0, sizeof(format));
- format.bits = m_bits;
- format.channels = m_channels;
- format.rate = m_sample_rate;
diff --git a/comms/aldo/files/patch-src_menu.cc b/comms/aldo/files/patch-src_menu.cc
new file mode 100644
index 000000000000..0431124a33d4
--- /dev/null
+++ b/comms/aldo/files/patch-src_menu.cc
@@ -0,0 +1,25 @@
+--- src/menu.cc.orig 2012-03-31 11:32:34 UTC
++++ src/menu.cc
+@@ -112,19 +112,19 @@ void Menu::add_item(id_type id, std::str
+
+ void Menu::add_item_at(unsigned int pos, id_type id, std::string c, Function1 f)
+ {
+- IT it(&m_its[pos]);
++ IT it(m_its.begin() + pos);
+ m_its.insert(it, Item(id,c,f) );
+ }
+
+ void Menu::add_item_at(unsigned int pos, id_type id, std::string c, Function2 f)
+ {
+- IT it(&m_its[pos]);
++ IT it(m_its.begin() + pos);
+ m_its.insert(it, Item(id,c,f) );
+ }
+
+ void Menu::delete_item_at(unsigned int pos)
+ {
+- IT it(&m_its[pos]);
++ IT it(m_its.begin() + pos);
+ m_its.erase(it);
+ }
+
'insertions'>+2 * - upgrade to 3.5.2bapt2012-04-234-0/+22 * Update to version 4.5.2.bsam2012-04-031-2/+2 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-161-0/+1 * The KDE/FreeBSD team is pleased to announce KDE SC 4.7.4, whichavilla2012-01-251-2/+2 * - Update to 9.4.7 (English version only)hrs2012-01-221-0/+2 * Update to version 4.4.20.bsam2012-01-161-2/+2 * - change required APACHE version from 13+ to 20+ohauer2012-01-021-1/+1 * Fix a mistake in the MANUAL_PACKAGE_BUILD line.linimon2011-12-121-1/+1 * Update to version 4.4.19.bsam2011-12-061-2/+2 * - Pass maintainership to office@FreeBSD.orgsunpoet2011-11-292-2/+2 * adjust linking and comments in dependent ports after the math/atlas update;bf2011-11-221-2/+2 * The KDE on FreeBSD team is pleased to update the KDE4 ports to 4.7.3.rakuco2011-11-142-3/+2 * - Get rid FreeBSD 6 supportmiwi2011-11-071-4/+0 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-1/+1 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-172-15/+47 * Update to version 4.4.18.bsam2011-10-031-2/+2 * - Update to 4.3sunpoet2011-10-032-4/+3 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-242-5/+6 * . update to version 4.4.17;bsam2011-09-071-2/+2 * - Disallow from pointyhat: runaway python processpav2011-08-271-0/+2 * - bump PORTREVISION from ports if USE_APACHE=13+ or 20+ is definedohauer2011-08-211-2/+2 * - Set DIST_SUBDIR: move dist files to DISTDIR/mythessunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hyphensunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hunspellsunpoet2011-08-182-2/+3 * - Set WRKSRCsunpoet2011-08-131-1/+2 * - Unify COMMENT and pkg-descrsunpoet2011-08-132-4/+5 * - Move language prefix to PKGNAMEPREFIXsunpoet2011-07-293-41/+38 * Update to 0.1.33, which fixes the verb "chauvir".naddy2011-07-253-4/+6 * - Fix typosunpoet2011-07-251-9/+9 * Pass matainership to the new office teambapt2011-07-223-3/+3 * Add some locales thesaurusbapt2011-07-214-0/+50 * Add french hyphenation rulesbapt2011-07-204-0/+45 * Update to 5.12jlaffaye2011-07-201-5/+3 * Add french modern dictionnary for hunspellbapt2011-07-204-0/+45 * - Bump PORTREVISION for science/hdf5-18 shlib changesunpoet2011-07-152-4/+4 * It seems that Code_Aster does not support Python 2.7 on amd64.thierry2011-07-141-0/+5 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-082-2/+2 * Update KDE Software Compilation ports to 4.6.5makc2011-07-083-3/+85 * Update to version 4.4.16.bsam2011-07-041-2/+2 * - Drop MD5 supportmiwi2011-07-031-1/+0 * Rework the port, for apache22 exp-run.thierry2011-06-308-446/+421 * Chase py-mechanize's upgrade.thierry2011-06-221-1/+2 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.4. Read fullavilla2011-06-141-2/+2 * Update to version 4.4.15.bsam2011-06-021-2/+2 * Update to Adobe Reader 9.4.2 and add a hack to mitigate "RSException" crashhrs2011-05-301-2/+2 * Update KDE Software Compilation ports to 4.6.3makc2011-05-172-2/+51 * One more bunch of unmaintained expired ports removalbapt2011-05-0211-327/+0 * Bump PORTREVISION after open-mofit updatemakc2011-05-023-2/+3 * - Update KOffice to 2.3.3.avilla2011-04-134-4/+100 * The FreeBSD KDE Team is pleased to announce April updates for KDEavilla2011-04-072-2/+11 * Update to version 4.4.13.bsam2011-04-031-2/+2 * - Update KOffice to 2.3.1.avilla2011-03-254-114/+32 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-253-26/+51 * - Revertpav2011-03-221-2/+2 * - Get Rid MD5 supportmiwi2011-03-1910-11/+2 * Deprecate unmaintained ports from french where upstream disapear and/orbapt2011-03-161-0/+3 * Chase the upgrade of science/cgnslib to 2.5-5; this implies tothierry2011-02-26