aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2017-03-20 17:57:41 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 20:02:34 +0800
commit0acc7a52d4299e0f64b33fd71550ad583539457e (patch)
tree969bb065364ce3bf0031a1139a4beed8758973e5
parent2a279dabb9d967b9b4a6e50047361ab309aed3b5 (diff)
downloadfreebsd-ports-gnome-0acc7a52d4299e0f64b33fd71550ad583539457e.tar.gz
freebsd-ports-gnome-0acc7a52d4299e0f64b33fd71550ad583539457e.tar.zst
freebsd-ports-gnome-0acc7a52d4299e0f64b33fd71550ad583539457e.zip
New port: net/rubygem-omniauth-authentiq
Official OmniAuth strategy for authenticating with an Authentiq ID mobile app (iOS, Android). WWW: https://github.com/AuthentiqID/omniauth-authentiq
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-omniauth-authentiq/Makefile20
-rw-r--r--net/rubygem-omniauth-authentiq/distinfo3
-rw-r--r--net/rubygem-omniauth-authentiq/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 639df007140a..592b444abe1e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1189,6 +1189,7 @@
SUBDIR += rubygem-octokit
SUBDIR += rubygem-octopress-deploy
SUBDIR += rubygem-omniauth-auth0
+ SUBDIR += rubygem-omniauth-authentiq
SUBDIR += rubygem-omniauth-azure-oauth2
SUBDIR += rubygem-omniauth-facebook
SUBDIR += rubygem-omniauth-github
diff --git a/net/rubygem-omniauth-authentiq/Makefile b/net/rubygem-omniauth-authentiq/Makefile
new file mode 100644
index 000000000000..e56ae5459158
--- /dev/null
+++ b/net/rubygem-omniauth-authentiq/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= omniauth-authentiq
+PORTVERSION= 0.3.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Authentiq OAuth2 Strategy for OmniAuth
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.3.1:net/rubygem-omniauth-oauth2
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-authentiq/distinfo b/net/rubygem-omniauth-authentiq/distinfo
new file mode 100644
index 000000000000..e36d0e61df5f
--- /dev/null
+++ b/net/rubygem-omniauth-authentiq/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490003344
+SHA256 (rubygem/omniauth-authentiq-0.3.0.gem) = 0a5c81998e588fd5317326cba66588b204b4ce515d576b3cc19572307bce2b37
+SIZE (rubygem/omniauth-authentiq-0.3.0.gem) = 9728
diff --git a/net/rubygem-omniauth-authentiq/pkg-descr b/net/rubygem-omniauth-authentiq/pkg-descr
new file mode 100644
index 000000000000..7130e6f3dfe6
--- /dev/null
+++ b/net/rubygem-omniauth-authentiq/pkg-descr
@@ -0,0 +1,4 @@
+Official OmniAuth strategy for authenticating
+with an Authentiq ID mobile app (iOS, Android).
+
+WWW: https://github.com/AuthentiqID/omniauth-authentiq