aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2012-05-05 04:02:25 +0800
committerjkim <jkim@FreeBSD.org>2012-05-05 04:02:25 +0800
commit0b037d1bc9cb39d572134ea181be554b62a7139d (patch)
tree886b213aacdde936fb2e81d40834045ab4f59d5c
parent276778e94ddf8da2d46d5b8480aab9650cdb2df9 (diff)
downloadfreebsd-ports-gnome-0b037d1bc9cb39d572134ea181be554b62a7139d.tar.gz
freebsd-ports-gnome-0b037d1bc9cb39d572134ea181be554b62a7139d.tar.zst
freebsd-ports-gnome-0b037d1bc9cb39d572134ea181be554b62a7139d.zip
- Work around build issues with Clang by lowering C++ standard level. Note
this is temporary because both Clang and LibreOffice fixed all the issues. - Shut up annoying "argument unused during compilation" warnings for Clang. With hat: office@
-rw-r--r--editors/libreoffice/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index e2b5e40d7086..b561a6782735 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -229,6 +229,8 @@ USE_BINUTILS= yes
CXXCPP= clang++ -E
CPP= clang -E
.endif
+# XXX Work around C++11 problems with Clang.
+CXXFLAGS= -std=gnu++98 -Qunused-arguments
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcppunit.so:${PORTSDIR}/devel/cppunit
.endif