aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-10-08 20:17:55 +0800
committermadpilot <madpilot@FreeBSD.org>2013-10-08 20:17:55 +0800
commit0b13ebee2509bd6ad63b49c246cacdc3df2e3bf9 (patch)
tree482ed3606383c50ee59be6ff6cf8058f0fe27783
parent2da70ae6a404203a677f886840d33ca42b5bd601 (diff)
downloadfreebsd-ports-gnome-0b13ebee2509bd6ad63b49c246cacdc3df2e3bf9.tar.gz
freebsd-ports-gnome-0b13ebee2509bd6ad63b49c246cacdc3df2e3bf9.tar.zst
freebsd-ports-gnome-0b13ebee2509bd6ad63b49c246cacdc3df2e3bf9.zip
- Fix build with iconv from base on head
While here: - Use new LIB_DEPENDS format - Convert to USES gmake - Support staging - Fix build with libc++ on head Approved by: portmgr (bapt)
-rw-r--r--multimedia/xbmc/Makefile64
-rw-r--r--multimedia/xbmc/files/patch-xbmc__linux__PlatformDefs.h10
-rw-r--r--multimedia/xbmc/pkg-plist2
3 files changed, 44 insertions, 32 deletions
diff --git a/multimedia/xbmc/Makefile b/multimedia/xbmc/Makefile
index e5bfd5eae004..33627246898e 100644
--- a/multimedia/xbmc/Makefile
+++ b/multimedia/xbmc/Makefile
@@ -21,31 +21,31 @@ BUILD_DEPENDS= enca:${PORTSDIR}/converters/enca \
dvdread-config:${PORTSDIR}/multimedia/libdvdread \
gtk-update-icon-cache:${PORTSDIR}/x11-toolkits/gtk20 \
swig2.0:${PORTSDIR}/devel/swig20
-LIB_DEPENDS= ass:${PORTSDIR}/multimedia/libass \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- cdio:${PORTSDIR}/sysutils/libcdio \
- curl:${PORTSDIR}/ftp/curl \
- dbus-1:${PORTSDIR}/devel/dbus \
- enca:${PORTSDIR}/converters/enca \
- GLEW:${PORTSDIR}/graphics/glew \
- FLAC:${PORTSDIR}/audio/flac \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2 \
- fribidi:${PORTSDIR}/converters/fribidi \
- lzo2:${PORTSDIR}/archivers/lzo2 \
- jasper:${PORTSDIR}/graphics/jasper \
- jpeg:${PORTSDIR}/graphics/jpeg \
- mad:${PORTSDIR}/audio/libmad \
- modplug:${PORTSDIR}/audio/libmodplug \
- mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
- pcre:${PORTSDIR}/devel/pcre \
- png15:${PORTSDIR}/graphics/png \
- samplerate:${PORTSDIR}/audio/libsamplerate \
- sqlite3:${PORTSDIR}/databases/sqlite3 \
- tag:${PORTSDIR}/audio/taglib \
- tinyxml:${PORTSDIR}/textproc/tinyxml \
- vorbis:${PORTSDIR}/audio/libvorbis \
- yajl:${PORTSDIR}/devel/yajl
+LIB_DEPENDS= libass.so:${PORTSDIR}/multimedia/libass \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libcdio.so:${PORTSDIR}/sysutils/libcdio \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libenca.so:${PORTSDIR}/converters/enca \
+ libGLEW.so:${PORTSDIR}/graphics/glew \
+ libFLAC.so:${PORTSDIR}/audio/flac \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfribidi.so:${PORTSDIR}/converters/fribidi \
+ liblzo2.so:${PORTSDIR}/archivers/lzo2 \
+ libjasper.so:${PORTSDIR}/graphics/jasper \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libmad.so:${PORTSDIR}/audio/libmad \
+ libmodplug.so:${PORTSDIR}/audio/libmodplug \
+ libmpeg2.so:${PORTSDIR}/multimedia/libmpeg2 \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
+ libtag.so:${PORTSDIR}/audio/taglib \
+ libtinyxml.so:${PORTSDIR}/textproc/tinyxml \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis \
+ libyajl.so:${PORTSDIR}/devel/yajl
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
glxinfo:${PORTSDIR}/graphics/mesa-demos \
nmblookup:${PORTSDIR}/net/samba-nmblookup \
@@ -53,8 +53,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
xdpyinfo:${PORTSDIR}/x11/xdpyinfo
FETCH_ARGS= -Fpr
-USES= pkgconfig
-USE_GMAKE= yes
+USES= gmake iconv pkgconfig
USE_AUTOTOOLS= autoconf libtool automake libltdl
GNU_CONFIGURE= yes
USE_XORG= xt xmu xrandr xtst
@@ -89,7 +88,6 @@ VORBIS_DESC= Ogg Vorbis audio encoder
OPTIONS_DEFAULT= AIRPLAY AVAHI CEC LAME LIBBLURAY HAL MYSQL \
RTMP SFTP SMB VORBIS WEBSERVER
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 900000
@@ -98,9 +96,6 @@ OPTIONS_DEFAULT+= EXTERNAL_FFMPEG
CONFIGURE_ARGS+= --disable-nfs
-MAN1= xbmc.bin.1
-MLINKS= xbmc.bin.1 xbmc.1
-
.include <bsd.port.options.mk>
.if ${ARCH} == i386
@@ -269,11 +264,16 @@ post-patch:
${WRKSRC}/lib/libsidplay2/libsidplay/src/mos656x/mos656x.h
${REINPLACE_CMD} 's;make;gmake;' ${WRKSRC}/bootstrap
${REINPLACE_CMD} 's;which swig;&2.0;' ${WRKSRC}/codegenerator.mk
+.if empty(ICONV_LIB)
+ ${REINPLACE_CMD} -e 's;^checking for main in -liconv\.\.\.;checking for iconv...;' \
+ -e 's;-liconv;${ICONV_LIB};' ${WRKSRC}/configure
+.endif
run-autotools:
@cd ${WRKSRC} && ${SH} ./bootstrap
post-install:
- @${INSTALL_MAN} ${WRKSRC}/docs/manpages/xbmc.bin.1 ${MAN1PREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/docs/manpages/xbmc.bin.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @(cd ${STAGEDIR}${MAN1PREFIX}/man/man1 && ${LN} -sf xbmc.bin.1.gz xbmc.1.gz)
.include <bsd.port.post.mk>
diff --git a/multimedia/xbmc/files/patch-xbmc__linux__PlatformDefs.h b/multimedia/xbmc/files/patch-xbmc__linux__PlatformDefs.h
new file mode 100644
index 000000000000..799b7d0a8ee5
--- /dev/null
+++ b/multimedia/xbmc/files/patch-xbmc__linux__PlatformDefs.h
@@ -0,0 +1,10 @@
+--- xbmc/linux/PlatformDefs.h.orig 2013-05-03 07:57:41.000000000 +0200
++++ xbmc/linux/PlatformDefs.h 2013-10-07 23:03:51.032581268 +0200
+@@ -55,6 +55,7 @@
+ #include <stdio.h>
+ #include <sys/sysctl.h>
+ #include <sys/types.h>
++#include <stdlib.h>
+ #else
+ #include <sys/sysinfo.h>
+ #endif
diff --git a/multimedia/xbmc/pkg-plist b/multimedia/xbmc/pkg-plist
index 278676e97091..3f449a564e0a 100644
--- a/multimedia/xbmc/pkg-plist
+++ b/multimedia/xbmc/pkg-plist
@@ -31,6 +31,8 @@ lib/xbmc/system/players/paplayer/timidity-%%ARCH%%-freebsd.so
lib/xbmc/system/players/paplayer/vgmstream-%%ARCH%%-freebsd.so
lib/xbmc/xbmc-xrandr
lib/xbmc/xbmc.bin
+man/man1/xbmc.bin.1.gz
+man/man1/xbmc.1.gz
%%DOCSDIR%%/LICENSE.GPL
%%DOCSDIR%%/README.linux
%%DOCSDIR%%/copying.txt