aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2021-01-22 18:10:10 +0800
committerMark Linimon <linimon@FreeBSD.org>2021-01-22 18:10:10 +0800
commit0c675e7260d19e57a694c6de8a7876e35fb86313 (patch)
treed26f357cccf3e8c5d4452e6549033186588fbe7b
parent14ebb0ebd655150adc9e3d6a89b4f95cae0233d0 (diff)
downloadfreebsd-ports-gnome-0c675e7260d19e57a694c6de8a7876e35fb86313.tar.gz
freebsd-ports-gnome-0c675e7260d19e57a694c6de8a7876e35fb86313.tar.zst
freebsd-ports-gnome-0c675e7260d19e57a694c6de8a7876e35fb86313.zip
Add compiler:c++11-lang to USES to fix build on GCC-based systems:
frei0r-plugins-1.7.0/src/filter/elastic_scale/elastic_scale.cpp:152: error: ISO C++ forbids initialization of member 'm_transformationCalculations' Approved by: portmgr (tier-2 blanket)
-rw-r--r--graphics/frei0r/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/frei0r/Makefile b/graphics/frei0r/Makefile
index 5a2bde6b2999..f773a620e99c 100644
--- a/graphics/frei0r/Makefile
+++ b/graphics/frei0r/Makefile
@@ -16,7 +16,7 @@ COMMENT?= Minimalistic plugin API for video effects
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING.txt
-USES= cmake pkgconfig
+USES= cmake compiler:c++11-lang pkgconfig
.if defined(BUILDING_FREI0R_OPENCV) && defined(BUILDING_FREI0R_GAVL)
IGNORE= cannot build OpenCV and gavl plugins simultaneously