aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-01-11 01:00:34 +0800
committerale <ale@FreeBSD.org>2005-01-11 01:00:34 +0800
commit0c8861b65f6e76212df2cf2e415b6c7427bc5bc1 (patch)
tree537d01bff83ba02865621fd9abf68c892f1e4841
parent1e6246ba6e20505d3a258d008490906b1e74f069 (diff)
downloadfreebsd-ports-gnome-0c8861b65f6e76212df2cf2e415b6c7427bc5bc1.tar.gz
freebsd-ports-gnome-0c8861b65f6e76212df2cf2e415b6c7427bc5bc1.tar.zst
freebsd-ports-gnome-0c8861b65f6e76212df2cf2e415b6c7427bc5bc1.zip
- Fix overloading objects [1] (bump php4 PORTREVISION)
- Fix crash with threaded apache2 [2] - Fix build when SSL is in not in base system [3] [4] PR: ports/75737 [1], ports/74780 [2], ports/73896 [3], ports/74886 [4] Submitted by: Toni Viemero <toni.viemero@iki.fi> [1], Peter Jeffery <peterj@qubesoft.com> [2], oliver [3], William Fletcher <ultraviolet@omina.co.za> [4] Patch by: Simon Barner <barner@gmx.de> [4]
-rw-r--r--lang/php4/Makefile2
-rw-r--r--lang/php4/Makefile.ext6
-rw-r--r--lang/php4/files/patch-Zend::zend.h12
-rw-r--r--lang/php4/files/patch-Zend::zend_execute.c13
-rw-r--r--lang/php5/Makefile.ext6
-rw-r--r--lang/php5/files/patch-Zend::zend.h12
-rw-r--r--lang/php53/Makefile.ext6
-rw-r--r--lang/php53/files/patch-Zend::zend.h12
8 files changed, 59 insertions, 10 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index a692644b2525..a885f917f830 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php4
PORTVERSION= 4.3.10
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 00c64f6dd641..6de92282d459 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -181,7 +181,7 @@ LIB_DEPENDS+= mcve.3:${PORTSDIR}/devel/libmcve
CONFIGURE_ARGS+=--with-mcve=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -230,7 +230,7 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -295,7 +295,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
diff --git a/lang/php4/files/patch-Zend::zend.h b/lang/php4/files/patch-Zend::zend.h
new file mode 100644
index 000000000000..50625c403417
--- /dev/null
+++ b/lang/php4/files/patch-Zend::zend.h
@@ -0,0 +1,12 @@
+--- Zend/zend.h.orig Mon Dec 6 15:42:56 2004
++++ Zend/zend.h Mon Dec 6 15:46:40 2004
+@@ -176,7 +176,7 @@
+ #endif
+
+
+-#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__)
++#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__) && !(defined(ZTS) && defined(__FreeBSD__))
+ # define do_alloca(p) alloca(p)
+ # define free_alloca(p)
+ #else
+
diff --git a/lang/php4/files/patch-Zend::zend_execute.c b/lang/php4/files/patch-Zend::zend_execute.c
new file mode 100644
index 000000000000..bc6f098c8ad0
--- /dev/null
+++ b/lang/php4/files/patch-Zend::zend_execute.c
@@ -0,0 +1,13 @@
+--- Zend/zend_execute.c.orig Tue Dec 28 15:03:55 2004
++++ Zend/zend_execute.c Tue Dec 28 15:03:57 2004
+@@ -1577,6 +1577,10 @@
+ EX(Ts)[EX(opline)->op1.u.var].EA.data.overloaded_element.elements_list = (zend_llist *) emalloc(sizeof(zend_llist));
+ zend_llist_init(EX(Ts)[EX(opline)->op1.u.var].EA.data.overloaded_element.elements_list, sizeof(zend_overloaded_element), NULL, 0);
+ EX(object).ptr->refcount++;
++ /* is-ref needed so that assign to this in call won't separate it */
++ if(EX(object).ptr->refcount > 1) {
++ EX(object).ptr->is_ref = 1;
++ }
+ }
+ zend_llist_add_element(EX(Ts)[EX(opline)->op1.u.var].EA.data.overloaded_element.elements_list, &overloaded_element);
+ EX(fbc) = (zend_function *) emalloc(sizeof(zend_function));
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 248df410681e..27b1ee61528a 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -169,7 +169,7 @@ LIB_DEPENDS+= mcve.3:${PORTSDIR}/devel/libmcve
CONFIGURE_ARGS+=--with-mcve=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -226,7 +226,7 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -294,7 +294,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
diff --git a/lang/php5/files/patch-Zend::zend.h b/lang/php5/files/patch-Zend::zend.h
new file mode 100644
index 000000000000..50625c403417
--- /dev/null
+++ b/lang/php5/files/patch-Zend::zend.h
@@ -0,0 +1,12 @@
+--- Zend/zend.h.orig Mon Dec 6 15:42:56 2004
++++ Zend/zend.h Mon Dec 6 15:46:40 2004
+@@ -176,7 +176,7 @@
+ #endif
+
+
+-#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__)
++#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__) && !(defined(ZTS) && defined(__FreeBSD__))
+ # define do_alloca(p) alloca(p)
+ # define free_alloca(p)
+ #else
+
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 248df410681e..27b1ee61528a 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -169,7 +169,7 @@ LIB_DEPENDS+= mcve.3:${PORTSDIR}/devel/libmcve
CONFIGURE_ARGS+=--with-mcve=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -226,7 +226,7 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -294,7 +294,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
diff --git a/lang/php53/files/patch-Zend::zend.h b/lang/php53/files/patch-Zend::zend.h
new file mode 100644
index 000000000000..50625c403417
--- /dev/null
+++ b/lang/php53/files/patch-Zend::zend.h
@@ -0,0 +1,12 @@
+--- Zend/zend.h.orig Mon Dec 6 15:42:56 2004
++++ Zend/zend.h Mon Dec 6 15:46:40 2004
+@@ -176,7 +176,7 @@
+ #endif
+
+
+-#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__)
++#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__) && !(defined(ZTS) && defined(__FreeBSD__))
+ # define do_alloca(p) alloca(p)
+ # define free_alloca(p)
+ #else
+