aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-08-28 20:34:43 +0800
committersat <sat@FreeBSD.org>2006-08-28 20:34:43 +0800
commit0c8e5b101c06d60dcb27f85b4550aedeaf92788b (patch)
treecce9d62459efafc788bd9c5653e296b2573e465e
parent91dbfd42b00379d91f342fd369130f4f213d1322 (diff)
downloadfreebsd-ports-gnome-0c8e5b101c06d60dcb27f85b4550aedeaf92788b.tar.gz
freebsd-ports-gnome-0c8e5b101c06d60dcb27f85b4550aedeaf92788b.tar.zst
freebsd-ports-gnome-0c8e5b101c06d60dcb27f85b4550aedeaf92788b.zip
Add port audio/libnoise:
libnoise is a portable C++ library that is used to generate coherent noise, a type of smoothly-changing noise. libnoise can generate Perlin noise, ridged multifractal noise, and other types of coherent-noise. Coherent noise is often used by graphics programmers to generate natural-looking textures, planetary terrain, and other things. The mountain scene shown above was rendered in Terragen with a terrain file generated by libnoise. You can also view some other examples of what libnoise can do. In libnoise, coherent-noise generators are encapsulated in classes called noise modules. There are many different types of noise modules. Some noise modules can combine or modify the outputs of other noise modules in various ways; you can join these modules together to generate very complex coherent noise. WWW: http://libnoise.sourceforge.net/
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libnoise/Makefile31
-rw-r--r--audio/libnoise/distinfo3
-rw-r--r--audio/libnoise/pkg-descr18
-rw-r--r--audio/libnoise/pkg-plist51
5 files changed, 104 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 593c8150a534..9f46ffa84e6e 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -304,6 +304,7 @@
SUBDIR += libmpcdec
SUBDIR += libmpd
SUBDIR += libmusicbrainz
+ SUBDIR += libnoise
SUBDIR += libofa
SUBDIR += libogg
SUBDIR += libsamplerate
diff --git a/audio/libnoise/Makefile b/audio/libnoise/Makefile
new file mode 100644
index 000000000000..ed03ae45ae6b
--- /dev/null
+++ b/audio/libnoise/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libnoise
+# Date created: 28 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnoise
+DISTVERSION= 1.0.0-RC1
+CATEGORIES= audio
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}src-${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Generates three-dimensional coherent noise
+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+CXXFLAGS+= -O3 -fomit-frame-pointer
+WRKSRC= ${WRKDIR}/noise
+NO_FILTER_SHLIBS= yes
+
+do-install:
+ @${CP} -R ${WRKSRC}/lib/${PORTNAME}.* ${PREFIX}/lib/
+ @${INSTALL} -d ${PREFIX}/include/noise
+ @${CP} -R ${WRKSRC}/include/ ${PREFIX}/include/noise/
+ @${RM} -f ${PREFIX}/include/noise/Makefile
+ @${LN} -sf ${PREFIX}/lib/libnoise.so.0.3 ${PREFIX}/lib/libnoise.so.0
+
+.include <bsd.port.mk>
diff --git a/audio/libnoise/distinfo b/audio/libnoise/distinfo
new file mode 100644
index 000000000000..3263fb504690
--- /dev/null
+++ b/audio/libnoise/distinfo
@@ -0,0 +1,3 @@
+MD5 (libnoisesrc-1.0.0-RC1.zip) = ab4a7b12970d5d1126027e33c6da031f
+SHA256 (libnoisesrc-1.0.0-RC1.zip) = 01b791a1bee0ca6fe73e28977a5ecc13e85c96d586162b412232b238a147cf2c
+SIZE (libnoisesrc-1.0.0-RC1.zip) = 1668214
diff --git a/audio/libnoise/pkg-descr b/audio/libnoise/pkg-descr
new file mode 100644
index 000000000000..3db82d0dd9ce
--- /dev/null
+++ b/audio/libnoise/pkg-descr
@@ -0,0 +1,18 @@
+libnoise is a portable C++ library that is used to generate coherent
+noise, a type of smoothly-changing noise. libnoise can generate
+Perlin noise, ridged multifractal noise, and other types of
+coherent-noise.
+
+Coherent noise is often used by graphics programmers to generate
+natural-looking textures, planetary terrain, and other things. The
+mountain scene shown above was rendered in Terragen with a terrain
+file generated by libnoise. You can also view some other examples of
+what libnoise can do.
+
+In libnoise, coherent-noise generators are encapsulated in classes
+called noise modules. There are many different types of noise
+modules. Some noise modules can combine or modify the outputs of
+other noise modules in various ways; you can join these modules
+together to generate very complex coherent noise.
+
+WWW: http://libnoise.sourceforge.net/
diff --git a/audio/libnoise/pkg-plist b/audio/libnoise/pkg-plist
new file mode 100644
index 000000000000..1514a4c5bbb9
--- /dev/null
+++ b/audio/libnoise/pkg-plist
@@ -0,0 +1,51 @@
+include/noise/basictypes.h
+include/noise/exception.h
+include/noise/interp.h
+include/noise/latlon.h
+include/noise/mathconsts.h
+include/noise/misc.h
+include/noise/model/cylinder.h
+include/noise/model/line.h
+include/noise/model/model.h
+include/noise/model/plane.h
+include/noise/model/sphere.h
+include/noise/module/abs.h
+include/noise/module/add.h
+include/noise/module/billow.h
+include/noise/module/blend.h
+include/noise/module/cache.h
+include/noise/module/checkerboard.h
+include/noise/module/clamp.h
+include/noise/module/const.h
+include/noise/module/curve.h
+include/noise/module/cylinders.h
+include/noise/module/displace.h
+include/noise/module/exponent.h
+include/noise/module/invert.h
+include/noise/module/max.h
+include/noise/module/min.h
+include/noise/module/module.h
+include/noise/module/modulebase.h
+include/noise/module/multiply.h
+include/noise/module/perlin.h
+include/noise/module/power.h
+include/noise/module/ridgedmulti.h
+include/noise/module/rotatepoint.h
+include/noise/module/scalebias.h
+include/noise/module/scalepoint.h
+include/noise/module/select.h
+include/noise/module/spheres.h
+include/noise/module/terrace.h
+include/noise/module/translatepoint.h
+include/noise/module/turbulence.h
+include/noise/module/voronoi.h
+include/noise/noise.h
+include/noise/noisegen.h
+include/noise/vectortable.h
+lib/libnoise.a
+lib/libnoise.la
+lib/libnoise.so.0
+lib/libnoise.so.0.3
+@dirrm include/noise/model
+@dirrm include/noise/module
+@dirrm include/noise