aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-06 06:01:20 +0800
committermiwi <miwi@FreeBSD.org>2008-06-06 06:01:20 +0800
commit0d146f930f497a451841591aa968561dcf77ab24 (patch)
tree214753491a2c7703891f1edc9570a462983ecc50
parent7c95a7f52e9775c3a1809e2b3957d79b92655510 (diff)
downloadfreebsd-ports-gnome-0d146f930f497a451841591aa968561dcf77ab24.tar.gz
freebsd-ports-gnome-0d146f930f497a451841591aa968561dcf77ab24.tar.zst
freebsd-ports-gnome-0d146f930f497a451841591aa968561dcf77ab24.zip
This module allows easy access to Feeds, Presences and Users at jaiku.com.
It requires an API key retreivable from http://api.jaiku.com/ for each username you wish to authenticate. WWW: http://search.cpan.org/dist/Net-Jaiku/ PR: ports/124242 Submitted by: Ying-Chieh Liao <ijliao at csie.nctu.edu.tw>
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Jaiku/Makefile30
-rw-r--r--net/p5-Net-Jaiku/distinfo3
-rw-r--r--net/p5-Net-Jaiku/pkg-descr5
-rw-r--r--net/p5-Net-Jaiku/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7cfaaf28c4ed..820c859f6369 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -507,6 +507,7 @@
SUBDIR += p5-Net-IPTrie
SUBDIR += p5-Net-Ident
SUBDIR += p5-Net-Interface
+ SUBDIR += p5-Net-Jaiku
SUBDIR += p5-Net-Jifty
SUBDIR += p5-Net-LDAP-Express
SUBDIR += p5-Net-LDAP-LDAPhash
diff --git a/net/p5-Net-Jaiku/Makefile b/net/p5-Net-Jaiku/Makefile
new file mode 100644
index 000000000000..18fc32a0ebb4
--- /dev/null
+++ b/net/p5-Net-Jaiku/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: Net::Jaiku
+# Date created: Jun 3, 2008
+# Whom: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Jaiku
+PORTVERSION= 0.0501
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A perl interface to jaiku.com's API
+
+RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
+ p5-JSON-Any>0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
+BUILD_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
+ p5-JSON-Any>0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Jaiku.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Jaiku/distinfo b/net/p5-Net-Jaiku/distinfo
new file mode 100644
index 000000000000..01b5a489197f
--- /dev/null
+++ b/net/p5-Net-Jaiku/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Jaiku-0.0501.tgz) = 23363fbe9e9d6d64140f88e51a8f9d5d
+SHA256 (Net-Jaiku-0.0501.tgz) = dd5fb327d2e7f48bcaa8cb44b46217c12b2358f3f4895a26efc0242d904027a5
+SIZE (Net-Jaiku-0.0501.tgz) = 14231
diff --git a/net/p5-Net-Jaiku/pkg-descr b/net/p5-Net-Jaiku/pkg-descr
new file mode 100644
index 000000000000..6b158a740831
--- /dev/null
+++ b/net/p5-Net-Jaiku/pkg-descr
@@ -0,0 +1,5 @@
+This module allows easy access to Feeds, Presences and Users at jaiku.com.
+It requires an API key retreivable from http://api.jaiku.com/ for each
+username you wish to authenticate.
+
+WWW: http://search.cpan.org/dist/Net-Jaiku/
diff --git a/net/p5-Net-Jaiku/pkg-plist b/net/p5-Net-Jaiku/pkg-plist
new file mode 100644
index 000000000000..386179c8d9ce
--- /dev/null
+++ b/net/p5-Net-Jaiku/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Jaiku/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Jaiku
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+%%SITE_PERL%%/Net/Jaiku.pm
+@dirrmtry %%SITE_PERL%%/Net