aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-08-04 07:51:48 +0800
committerpawel <pawel@FreeBSD.org>2014-08-04 07:51:48 +0800
commit0eff41e7b9a36ea4031df2f12affda98bd0b9e61 (patch)
tree9fa5be1cdeffc9491909e1e0b760974ff0e1e9f0
parentf0614e861616ac2320b099c2baad159948e31288 (diff)
downloadfreebsd-ports-gnome-0eff41e7b9a36ea4031df2f12affda98bd0b9e61.tar.gz
freebsd-ports-gnome-0eff41e7b9a36ea4031df2f12affda98bd0b9e61.tar.zst
freebsd-ports-gnome-0eff41e7b9a36ea4031df2f12affda98bd0b9e61.zip
- Add staging support
- Convert to new options framework - Delete RUN_DEPENDS on javavmwrapper, it's pulled in by USE_JAVA
-rw-r--r--textproc/ppower4/Makefile35
1 files changed, 12 insertions, 23 deletions
diff --git a/textproc/ppower4/Makefile b/textproc/ppower4/Makefile
index 146af4f68c66..3df248bc3be0 100644
--- a/textproc/ppower4/Makefile
+++ b/textproc/ppower4/Makefile
@@ -14,8 +14,6 @@ EXTRACT_ONLY= pp4sty.zip leveldemo.zip
MAINTAINER= ports@FreeBSD.org
COMMENT= Post processor for PDF presentations made with (La)TeX
-RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
-
USES= zip
USE_TEX= latex
USE_JAVA= yes
@@ -37,27 +35,18 @@ PLIST_SUB= STY_DIR="${STY_DIR:S,^${PREFIX}/,,}" \
SUB_FILES= ppower4.sh
SUB_LIST= JARFILE=${JAR_DIR}/pp4p.jar
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
-# install docs?
-.if !defined(NOPORTDOCS)
-# install docs...
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/manual.pdf ${DOCSDIR}
-# ...and the examples, too!
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${EXAMPLE_FILES} ${EXAMPLESDIR}
-.endif
-# install data files
- @${MKDIR} ${STY_DIR}
- @${INSTALL_DATA} ${STY_FILES} ${STY_DIR}
- @${MKDIR} ${JAR_DIR}
- @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/pp4p.jar ${JAR_DIR}
-# install wrapper script
- @${INSTALL_SCRIPT} ${WRKDIR}/ppower4.sh ${PREFIX}/bin/ppower4
-
-post-install:
- ${SETENV} LOCALBASE=${LOCALBASE} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGDIR}/pkg-install ${PKGNAME} POST-INSTALL
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/manual.pdf \
+ ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLE_FILES} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${STY_DIR}
+ ${INSTALL_DATA} ${STY_FILES} ${STAGEDIR}${STY_DIR}
+ @${MKDIR} ${STAGEDIR}${JAR_DIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/pp4p.jar ${STAGEDIR}${JAR_DIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/ppower4.sh ${STAGEDIR}${PREFIX}/bin/ppower4
.include <bsd.port.mk>