aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-03-22 05:03:48 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2017-04-09 20:03:04 +0800
commit0fae29fa03c1bc7be9d48879ddff71d4e2b89e8a (patch)
treecf410a88decb8ecb5fb94bffb113d083bf8728df
parent1698c8b146eec77e30c6bb0b91ec185e517bfa36 (diff)
downloadfreebsd-ports-gnome-0fae29fa03c1bc7be9d48879ddff71d4e2b89e8a.tar.gz
freebsd-ports-gnome-0fae29fa03c1bc7be9d48879ddff71d4e2b89e8a.tar.zst
freebsd-ports-gnome-0fae29fa03c1bc7be9d48879ddff71d4e2b89e8a.zip
New port: graphics/guetzli
Guetzli is a JPEG encoder that aims for excellent compression density at high visual quality. Guetzli-generated images are typically 20-30% smaller than images of equivalent quality generated by libjpeg. Guetzli generates only sequential (nonprogressive) JPEGs due to faster decompression speeds they offer. WWW: https://github.com/google/guetzli PR: 217872 Approved by: lme (mentor) Submitted by: Yuri Victorovich <yuri@rawbw.com> Differential Revision: https://reviews.freebsd.org/D10074
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/guetzli/Makefile27
-rw-r--r--graphics/guetzli/distinfo3
-rw-r--r--graphics/guetzli/files/patch-guetzli.make20
-rw-r--r--graphics/guetzli/pkg-descr7
5 files changed, 58 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e956dd869978..cd2a216d6729 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -329,6 +329,7 @@
SUBDIR += gtk-update-icon-cache
SUBDIR += gtkam
SUBDIR += gts
+ SUBDIR += guetzli
SUBDIR += guilib
SUBDIR += gwenview-kde4
SUBDIR += gx
diff --git a/graphics/guetzli/Makefile b/graphics/guetzli/Makefile
new file mode 100644
index 000000000000..34217d609936
--- /dev/null
+++ b/graphics/guetzli/Makefile
@@ -0,0 +1,27 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= guetzli
+PORTVERSION= 1.0.1
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Perceptual JPEG encoder
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libpng.so:graphics/png
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
+
+USES= compiler:c++11-lib gmake pkgconfig
+PLIST_FILES= bin/guetzli
+MAKE_FLAGS= verbose=1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/Release/guetzli ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/guetzli/distinfo b/graphics/guetzli/distinfo
new file mode 100644
index 000000000000..99b32d152157
--- /dev/null
+++ b/graphics/guetzli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1490123236
+SHA256 (google-guetzli-v1.0.1_GH0.tar.gz) = e52eb417a5c0fb5a3b08a858c8d10fa797627ada5373e203c196162d6a313697
+SIZE (google-guetzli-v1.0.1_GH0.tar.gz) = 97251
diff --git a/graphics/guetzli/files/patch-guetzli.make b/graphics/guetzli/files/patch-guetzli.make
new file mode 100644
index 000000000000..714e6a3c2e42
--- /dev/null
+++ b/graphics/guetzli/files/patch-guetzli.make
@@ -0,0 +1,20 @@
+--- guetzli.make.orig 2017-03-21 19:09:12 UTC
++++ guetzli.make
+@@ -19,8 +19,8 @@ ifeq ($(config),release)
+ INCLUDES += -I. -Ithird_party/butteraugli
+ FORCE_INCLUDE +=
+ ALL_CPPFLAGS += $(CPPFLAGS) -MMD -MP $(DEFINES) $(INCLUDES)
+- ALL_CFLAGS += $(CFLAGS) $(ALL_CPPFLAGS) -O3 -g `pkg-config --cflags libpng`
+- ALL_CXXFLAGS += $(CXXFLAGS) $(ALL_CPPFLAGS) -O3 -g -std=c++11 `pkg-config --cflags libpng`
++ ALL_CFLAGS += $(CFLAGS) $(ALL_CPPFLAGS) `pkg-config --cflags libpng`
++ ALL_CXXFLAGS += $(CXXFLAGS) $(ALL_CPPFLAGS) -std=c++11 `pkg-config --cflags libpng`
+ ALL_RESFLAGS += $(RESFLAGS) $(DEFINES) $(INCLUDES)
+ LIBS +=
+ LDDEPS +=
+@@ -210,4 +210,4 @@ $(OBJDIR)/butteraugli.o: third_party/butteraugli/butte
+ -include $(OBJECTS:%.o=%.d)
+ ifneq (,$(PCH))
+ -include $(OBJDIR)/$(notdir $(PCH)).d
+-endif
+\ No newline at end of file
++endif
diff --git a/graphics/guetzli/pkg-descr b/graphics/guetzli/pkg-descr
new file mode 100644
index 000000000000..d4ea63179569
--- /dev/null
+++ b/graphics/guetzli/pkg-descr
@@ -0,0 +1,7 @@
+Guetzli is a JPEG encoder that aims for excellent compression density
+at high visual quality. Guetzli-generated images are typically 20-30%
+smaller than images of equivalent quality generated by libjpeg.
+Guetzli generates only sequential (nonprogressive) JPEGs due to faster
+decompression speeds they offer.
+
+WWW: https://github.com/google/guetzli