aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-07-27 08:51:11 +0800
committerswills <swills@FreeBSD.org>2014-07-27 08:51:11 +0800
commit0ffd9673f5ed624e6905228016877d64d6e62bbd (patch)
tree84870147558c030d5de31b3faca5908872d4766f
parent226c39374a1b9d0246485367a147cfb09f8fe9a5 (diff)
downloadfreebsd-ports-gnome-0ffd9673f5ed624e6905228016877d64d6e62bbd.tar.gz
freebsd-ports-gnome-0ffd9673f5ed624e6905228016877d64d6e62bbd.tar.zst
freebsd-ports-gnome-0ffd9673f5ed624e6905228016877d64d6e62bbd.zip
lang/ruby21: Update to Ruby 2.1.2
-rw-r--r--Mk/bsd.ruby.mk4
-rw-r--r--lang/ruby21/Makefile1
-rw-r--r--lang/ruby21/distinfo4
-rw-r--r--lang/ruby21/files/extra-patch-ext__readline__readline.c11
4 files changed, 4 insertions, 16 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 0449f1a41899..6db314a46c1d 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -208,8 +208,8 @@ RUBY21= "@comment "
#
# Ruby 2.1
#
-RUBY_RELVERSION= 2.1.1
-RUBY_PORTREVISION= 2
+RUBY_RELVERSION= 2.1.2
+RUBY_PORTREVISION= 0
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 0
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index e90ecf4d345e..7a5d9359035f 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -103,7 +103,6 @@ CONFIGURE_ARGS+= --enable-libedit --with-libedit-prefix=${LOCALBASE}
BUILD_DEPENDS+= readline>=0:${PORTSDIR}/devel/readline
RUN_DEPENDS+= readline>=0:${PORTSDIR}/devel/readline
CONFIGURE_ARGS+= --disable-libedit --with-readline-prefix=${LOCALBASE}
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ext__readline__readline.c
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
diff --git a/lang/ruby21/distinfo b/lang/ruby21/distinfo
index cee693fa267f..9c3288b69a09 100644
--- a/lang/ruby21/distinfo
+++ b/lang/ruby21/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ruby/ruby-2.1.1.tar.bz2) = 96aabab4dd4a2e57dd0d28052650e6fcdc8f133fa8980d9b936814b1e93f6cfc
-SIZE (ruby/ruby-2.1.1.tar.bz2) = 11990697
+SHA256 (ruby/ruby-2.1.2.tar.bz2) = 6948b02570cdfb89a8313675d4aa665405900e27423db408401473f30fc6e901
+SIZE (ruby/ruby-2.1.2.tar.bz2) = 11976939
diff --git a/lang/ruby21/files/extra-patch-ext__readline__readline.c b/lang/ruby21/files/extra-patch-ext__readline__readline.c
deleted file mode 100644
index dd5a2eb1282b..000000000000
--- a/lang/ruby21/files/extra-patch-ext__readline__readline.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext/readline/readline.c.orig 2013/10/29 03:09:00 43458
-+++ ext/readline/readline.c 2014/03/01 07:19:08 45225
-@@ -1974,7 +1974,7 @@
-
- rl_attempted_completion_function = readline_attempted_completion_function;
- #if defined(HAVE_RL_PRE_INPUT_HOOK)
-- rl_pre_input_hook = (Function *)readline_pre_input_hook;
-+ rl_pre_input_hook = (rl_hook_func_t *)readline_pre_input_hook;
- #endif
- #ifdef HAVE_RL_CATCH_SIGNALS
- rl_catch_signals = 0;