aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2013-10-29 02:08:56 +0800
committerflo <flo@FreeBSD.org>2013-10-29 02:08:56 +0800
commit1034af0f102489e67c2d790e0e1080185305b6a5 (patch)
treec86245b7646a07ad30bfab9eec0a94239eaa03ee
parentfab9eabcf44b346d8684c79f11361c5278597878 (diff)
downloadfreebsd-ports-gnome-1034af0f102489e67c2d790e0e1080185305b6a5.tar.gz
freebsd-ports-gnome-1034af0f102489e67c2d790e0e1080185305b6a5.tar.zst
freebsd-ports-gnome-1034af0f102489e67c2d790e0e1080185305b6a5.zip
- fix typo on pkg-install [1]
- provide pkg-deinstall to clean up after deinstall Submitted by: maintainer [1] Pointyhat to: flo [1]
-rw-r--r--sysutils/minimunin/Makefile1
-rw-r--r--sysutils/minimunin/pkg-deinstall9
-rw-r--r--sysutils/minimunin/pkg-install2
3 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/minimunin/Makefile b/sysutils/minimunin/Makefile
index 02615aa2eb23..8afe4591ba27 100644
--- a/sysutils/minimunin/Makefile
+++ b/sysutils/minimunin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= minimunin
PORTVERSION= 0.1
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://erdgeist.org/arts/software/minimunin/
diff --git a/sysutils/minimunin/pkg-deinstall b/sysutils/minimunin/pkg-deinstall
new file mode 100644
index 000000000000..034003c164f1
--- /dev/null
+++ b/sysutils/minimunin/pkg-deinstall
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "updating /etc/services"
+ cp /etc/services /tmp/services
+ grep -v '^munin 4949/tcp #munin node$' \
+ /tmp/services > /etc/services
+ rm /tmp/services
+fi
diff --git a/sysutils/minimunin/pkg-install b/sysutils/minimunin/pkg-install
index 1733abbac0b7..092878ad52e9 100644
--- a/sysutils/minimunin/pkg-install
+++ b/sysutils/minimunin/pkg-install
@@ -1,6 +1,6 @@
#!/bin/sh
-if [ "$2" = POSTINSTALL ]; then
+if [ "$2" = "POST-INSTALL" ]; then
echo "updating /etc/services"
(grep -q '^munin ' /etc/services || \
echo "munin 4949/tcp #munin node"; ) \