aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-08-15 10:22:01 +0800
committerswills <swills@FreeBSD.org>2014-08-15 10:22:01 +0800
commit1090ca7994a427cf49a865b7a845c9c94884121b (patch)
tree4a752476398e31def8e931e414c65b1c61e7b4d8
parent4139fcad58e346ee3837ae014f6b72dd00abb0f4 (diff)
downloadfreebsd-ports-gnome-1090ca7994a427cf49a865b7a845c9c94884121b.tar.gz
freebsd-ports-gnome-1090ca7994a427cf49a865b7a845c9c94884121b.tar.zst
freebsd-ports-gnome-1090ca7994a427cf49a865b7a845c9c94884121b.zip
net/syncthing-cli: add command line interface to syncthing
-rw-r--r--net/Makefile1
-rw-r--r--net/syncthing-cli/Makefile60
-rw-r--r--net/syncthing-cli/distinfo14
-rw-r--r--net/syncthing-cli/files/patch-cmd_options.go28
-rw-r--r--net/syncthing-cli/pkg-descr3
5 files changed, 106 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b2f2fe920905..3f9aaad9b264 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1151,6 +1151,7 @@
SUBDIR += sup
SUBDIR += svnup
SUBDIR += syncthing
+ SUBDIR += syncthing-cli
SUBDIR += tableutil
SUBDIR += tac_plus-libradius
SUBDIR += tac_plus4
diff --git a/net/syncthing-cli/Makefile b/net/syncthing-cli/Makefile
new file mode 100644
index 000000000000..19576ab0ec4b
--- /dev/null
+++ b/net/syncthing-cli/Makefile
@@ -0,0 +1,60 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= syncthing-cli
+PORTVERSION= 0.0.0.2014081401
+CATEGORIES= net
+MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/archive/${GH_TAGNAME}.tar.gz?dummy=/:group1 \
+ https://codeload.github.com/AudriusButkevicius/cli/legacy.tar.gz/7f561c7?dummy=/:group2 \
+ https://github.com/syncthing/syncthing/archive/v0.9.4.tar.gz?dummy=/:group3 \
+ LOCAL/swills:group4 \
+ LOCAL/swills:group5 \
+ https://codeload.github.com/bkaradzic/go-lz4/legacy.tar.gz/77e2ba8?dummy=/:group6 \
+ https://codeload.github.com/calmh/xdr/legacy.tar.gz/e1714bb?dummy=/:group7
+DISTFILES= syncthing-cli-0.0.0.2014081401.tar.gz:group1 \
+ AudriusButkevicius-cli-7f561c7${EXTACT_SUFX}:group2 \
+ syncthing-0.9.4${EXTRACT_SUFX}:group3 \
+ crypto.go-f3cebac2bd11${EXTRACT_SUFX}:group4 \
+ text.go-d65bffbc88a1${EXTRACT_SUFX}:group5 \
+ bkaradzic-go-lz4-77e2ba8${EXTRACT_SUFX}:group6 \
+ calmh-xdr-e1714bb${EXTRACT_SUFX}:group7
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Syncthing CLI
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
+
+GH_ACCOUNT= syncthing
+GH_PROJECT= syncthing-cli
+GH_COMMIT= 7dab84f
+GH_TAGNAME= ${GH_COMMIT}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-7dab84f6edfbd873c5addac1c564fa1f64d0ff29
+
+PLIST_FILES= bin/syncthing-cli
+
+post-patch:
+ cd ${WRKSRC} ; \
+ ${MKDIR} src/github.com/AudriusButkevicius ; \
+ ${MKDIR} src/github.com/syncthing/syncthing ; \
+ ${MKDIR} src/github.com/bkaradzic ; \
+ ${MKDIR} src/github.com/calmh ; \
+ ${MKDIR} src/code.google.com/p ; \
+ ${MV} ${WRKDIR}/AudriusButkevicius-cli-7f561c7 src/github.com/AudriusButkevicius/cli ; \
+ ${MV} ${WRKDIR}/syncthing-0.9.4/config src/github.com/syncthing/syncthing/config ; \
+ ${MV} ${WRKDIR}/syncthing-0.9.4/protocol src/github.com/syncthing/syncthing/protocol ; \
+ ${MV} ${WRKDIR}/crypto.go-f3cebac2bd11 src/code.google.com/p/go.crypto ; \
+ ${MV} ${WRKDIR}/text.go-d65bffbc88a1/ src/code.google.com/p/go.text ; \
+ ${MV} ${WRKDIR}/bkaradzic-go-lz4-77e2ba8 src/github.com/bkaradzic/go-lz4 ; \
+ ${MV} ${WRKDIR}/syncthing-0.9.4/logger src/github.com/syncthing/syncthing ; \
+ ${MV} ${WRKDIR}/syncthing-0.9.4/luhn src/github.com/syncthing/syncthing ; \
+ ${MV} ${WRKDIR}/calmh-xdr-e1714bb src/github.com/calmh/xdr
+
+do-build:
+ cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC} go build
+ ${MV} ${WRKSRC}/syncthing-cli-7dab84f6edfbd873c5addac1c564fa1f64d0ff29 ${WRKSRC}/syncthing-cli
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/syncthing-cli ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/net/syncthing-cli/distinfo b/net/syncthing-cli/distinfo
new file mode 100644
index 000000000000..1aa1854348a0
--- /dev/null
+++ b/net/syncthing-cli/distinfo
@@ -0,0 +1,14 @@
+SHA256 (syncthing-cli-0.0.0.2014081401.tar.gz) = 556ae864df96dc1a1987a43ddd0d1552a7b269f6a763a7f8dd11cede4030e742
+SIZE (syncthing-cli-0.0.0.2014081401.tar.gz) = 8308
+SHA256 (AudriusButkevicius-cli-7f561c7) = ad64f151c314333f714ef600f65a4fb512ce7242bc2100074775581a56ad439a
+SIZE (AudriusButkevicius-cli-7f561c7) = 14736
+SHA256 (syncthing-0.9.4.tar.gz) = e1cfbc3055ca26662d9f3664bd236357f84f6523360cc2aa4c3e83fcd74fcfad
+SIZE (syncthing-0.9.4.tar.gz) = 1814400
+SHA256 (crypto.go-f3cebac2bd11.tar.gz) = 9de8c02f5f4b29db4ec31e772acc5b2b75323d5a20f58bfadfe1d10300256f37
+SIZE (crypto.go-f3cebac2bd11.tar.gz) = 326871
+SHA256 (text.go-d65bffbc88a1.tar.gz) = 5b87e4dddc48c363bf190982a0d229ed5c9b57793ae4ec68004dc1c2f2a31309
+SIZE (text.go-d65bffbc88a1.tar.gz) = 3231005
+SHA256 (bkaradzic-go-lz4-77e2ba8.tar.gz) = 8d6a3f73bb2e21a64292d14af1a8466707c14f71b70d48fde317746cd2ac8d0e
+SIZE (bkaradzic-go-lz4-77e2ba8.tar.gz) = 232876
+SHA256 (calmh-xdr-e1714bb.tar.gz) = 354133594fc70dac499a44ffd6d857f1f730345f8db3d07def4e38daec5ec791
+SIZE (calmh-xdr-e1714bb.tar.gz) = 9250
diff --git a/net/syncthing-cli/files/patch-cmd_options.go b/net/syncthing-cli/files/patch-cmd_options.go
new file mode 100644
index 000000000000..508f6cbda491
--- /dev/null
+++ b/net/syncthing-cli/files/patch-cmd_options.go
@@ -0,0 +1,28 @@
+--- cmd_options.go.orig 2014-08-14 20:00:24.000000000 +0000
++++ cmd_options.go 2014-08-14 20:00:35.000000000 +0000
+@@ -46,7 +46,6 @@
+ fmt.Fprintln(writer, "Local discovery port:\t", cfg.LocalAnnPort, "\t(localannport)")
+
+ fmt.Fprintln(writer, "Maximum outstanding requests:\t", cfg.ParallelRequests, "\t(requests)")
+- fmt.Fprintln(writer, "Maximum file change rate in KiB/s:\t", cfg.MaxChangeKbps, "\t(maxchange)")
+ fmt.Fprintln(writer, "Outgoing rate limit in KiB/s:\t", cfg.MaxSendKbps, "\t(maxsend)")
+ fmt.Fprintln(writer, "Rescan interval in seconds:\t", cfg.RescanIntervalS, "\t(rescan)")
+ fmt.Fprintln(writer, "Reconnect interval in seconds:\t", cfg.ReconnectIntervalS, "\t(reconnect)")
+@@ -85,8 +84,6 @@
+ fmt.Println(cfg.ParallelRequests)
+ case "maxsend":
+ fmt.Println(cfg.MaxSendKbps)
+- case "maxchange":
+- fmt.Println(cfg.MaxChangeKbps)
+ case "rescan":
+ fmt.Println(cfg.RescanIntervalS)
+ case "reconnect":
+@@ -134,8 +131,6 @@
+ config.Options.ParallelRequests = parseUint(val)
+ case "maxsend":
+ config.Options.MaxSendKbps = parseUint(val)
+- case "maxchange":
+- config.Options.MaxChangeKbps = parseUint(val)
+ case "rescan":
+ config.Options.RescanIntervalS = parseUint(val)
+ case "reconnect":
diff --git a/net/syncthing-cli/pkg-descr b/net/syncthing-cli/pkg-descr
new file mode 100644
index 000000000000..3f1c372f3eea
--- /dev/null
+++ b/net/syncthing-cli/pkg-descr
@@ -0,0 +1,3 @@
+Command line interface to syncthing
+
+WWW: http://syncthing.net/