aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2009-01-27 01:57:30 +0800
committerthierry <thierry@FreeBSD.org>2009-01-27 01:57:30 +0800
commit10d3b3fe69c203c448db79bf9de639c1f2f481de (patch)
tree69d2fe91fecf8f74f019c4ec04ea95e51ad6e6c2
parent531e2db0433e9f58768232108c4806e0429c3123 (diff)
downloadfreebsd-ports-gnome-10d3b3fe69c203c448db79bf9de639c1f2f481de.tar.gz
freebsd-ports-gnome-10d3b3fe69c203c448db79bf9de639c1f2f481de.tar.zst
freebsd-ports-gnome-10d3b3fe69c203c448db79bf9de639c1f2f481de.zip
Fix a bug triggered on amd64 by Cristiano Rolim.
Submitted by: Cristiano Rolim <cristianorolim (at) hotmail<dot>com>
-rw-r--r--cad/opencascade/Makefile2
-rw-r--r--cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx11
2 files changed, 12 insertions, 1 deletions
diff --git a/cad/opencascade/Makefile b/cad/opencascade/Makefile
index fed93b66df46..556b88a193e9 100644
--- a/cad/opencascade/Makefile
+++ b/cad/opencascade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opencascade
PORTVERSION= 6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= cad science
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= thierry
diff --git a/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx b/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx
new file mode 100644
index 000000000000..245322f6345c
--- /dev/null
+++ b/cad/opencascade/files/patch-ros_src_STEPConstruct_STEPConstruct_AP203Context.cxx
@@ -0,0 +1,11 @@
+--- ./ros/src/STEPConstruct/STEPConstruct_AP203Context.cxx.orig 2001-09-21 10:00:28.000000000 +0200
++++ ./ros/src/STEPConstruct/STEPConstruct_AP203Context.cxx 2009-01-24 11:45:15.000000000 +0100
+@@ -103,7 +103,7 @@
+
+ Handle(StepBasic_CoordinatedUniversalTimeOffset) zone =
+ new StepBasic_CoordinatedUniversalTimeOffset;
+- Standard_Integer shift = Standard_Integer(timezone);
++ Standard_Integer shift = Standard_Integer((long long) timezone);
+ Standard_Integer shifth = abs ( shift ) / 3600;
+ Standard_Integer shiftm = ( abs ( shift ) - shifth * 3600 ) / 60;
+ StepBasic_AheadOrBehind sense = ( shift >0 ? StepBasic_aobBehind :