aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2010-10-02 12:39:51 +0800
committerstas <stas@FreeBSD.org>2010-10-02 12:39:51 +0800
commit113e33d0899dbd1cb99d055bd86d17b49fcf264e (patch)
treeb11b6387f0748c345abfd5223e82cc8b7e16fdc3
parent9e504a4bab65cee7e2f7aa7904539f69b0bdb5b4 (diff)
downloadfreebsd-ports-gnome-113e33d0899dbd1cb99d055bd86d17b49fcf264e.tar.gz
freebsd-ports-gnome-113e33d0899dbd1cb99d055bd86d17b49fcf264e.tar.zst
freebsd-ports-gnome-113e33d0899dbd1cb99d055bd86d17b49fcf264e.zip
- Use native cpuid mode for now, because our kernel support seems
to be somewhat incomplete. [1] - Bump portrevision. Reported by: Andriy Gapon <avg@icyb.net.ua> [1]
-rw-r--r--sysutils/x86info/Makefile1
-rw-r--r--sysutils/x86info/files/patch-cpuid.c9
2 files changed, 8 insertions, 2 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 50b6b963ce05..6acaa5a8a9f4 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -7,6 +7,7 @@
PORTNAME= x86info
PORTVERSION= 1.27
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://codemonkey.org.uk/projects/x86info/ \
http://codemonkey.org.uk/projects/x86info/old/
diff --git a/sysutils/x86info/files/patch-cpuid.c b/sysutils/x86info/files/patch-cpuid.c
index b4b6acca00c4..42ce9b51f453 100644
--- a/sysutils/x86info/files/patch-cpuid.c
+++ b/sysutils/x86info/files/patch-cpuid.c
@@ -1,5 +1,5 @@
--- cpuid.c.orig 2010-09-08 12:19:56.000000000 -0700
-+++ cpuid.c 2010-10-01 04:06:00.000000000 -0700
++++ cpuid.c 2010-10-01 21:37:48.000000000 -0700
@@ -23,8 +23,16 @@
#include <sched.h>
@@ -70,7 +70,12 @@
if (ret)
return ret;
return 0;
-@@ -106,7 +133,11 @@
+@@ -102,11 +129,15 @@
+ unsigned int *ecx,
+ unsigned int *edx)
+ {
+- static int nodriver=0;
++ static int nodriver=1;
char cpuname[20];
unsigned char buffer[16];
int fh;