aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2008-03-07 06:59:52 +0800
committermi <mi@FreeBSD.org>2008-03-07 06:59:52 +0800
commit116c58f9569f9dda157886c8aa4c13aa995d79ef (patch)
tree55df74102bc2241753bbb9917f416b8d29b54d09
parent338d5fee85de11d07d1521c71eeea00cf6525bbb (diff)
downloadfreebsd-ports-gnome-116c58f9569f9dda157886c8aa4c13aa995d79ef.tar.gz
freebsd-ports-gnome-116c58f9569f9dda157886c8aa4c13aa995d79ef.tar.zst
freebsd-ports-gnome-116c58f9569f9dda157886c8aa4c13aa995d79ef.zip
Attempt to fix the PRs below caused by PWLib getting upgraded under our
feet. While here, add a small patch found in Ubuntu and Debian ports. PR: ports/121346 PR: ports/120824 PR: ports/121401
-rw-r--r--net/ekiga/Makefile2
-rw-r--r--net/ekiga/files/patch-src-devices-fakevideoinput39
-rw-r--r--net/ekiga/files/patch-ubuntu15
3 files changed, 55 insertions, 1 deletions
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index ed1afc1a9b2a..2ad0d187104f 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ekiga
PORTVERSION= 2.0.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.0
diff --git a/net/ekiga/files/patch-src-devices-fakevideoinput b/net/ekiga/files/patch-src-devices-fakevideoinput
new file mode 100644
index 000000000000..066fd69cfba9
--- /dev/null
+++ b/net/ekiga/files/patch-src-devices-fakevideoinput
@@ -0,0 +1,39 @@
+Remove the guts from a function, that no longer compiles with
+PWLib-1.12. Since the whole file is dealing with the situation,
+when there is, in fact, no video -- the user is shown a logo
+instead -- it is unclear, what good was this function providing
+even when it worked.
+
+Better patches are actively solicited...
+
+ -mi
+
+--- src/devices/fakevideoinput.cpp 2007-09-18 05:00:19.000000000 -0400
++++ src/devices/fakevideoinput.cpp 2008-03-06 17:13:47.000000000 -0500
+@@ -334,26 +334,4 @@
+ PVideoInputDevice_Picture::WaitFinishPreviousFrame ()
+ {
+- if (frameTimeError == 0) {
+-
+- frameTimeError += msBetweenFrames;
+- return;
+- }
+-
+- PTime now;
+- PTimeInterval delay = now - previousFrameTime;
+- frameTimeError += msBetweenFrames;
+- frameTimeError -= (int) delay.GetMilliSeconds();
+- frameTimeError += 1000 / frameRate;
+-
+- previousFrameTime = now;
+-
+- if (frameTimeError > 0) {
+- PTRACE(6, "FakeVideo\t Sleep for " << frameTimeError << " milli seconds");
+-#ifdef P_LINUX
+- usleep(frameTimeError * 1000);
+-#else
+- PThread::Current()->Sleep(frameTimeError);
+-#endif
+- }
+ }
+
diff --git a/net/ekiga/files/patch-ubuntu b/net/ekiga/files/patch-ubuntu
new file mode 100644
index 000000000000..d52544e497ae
--- /dev/null
+++ b/net/ekiga/files/patch-ubuntu
@@ -0,0 +1,15 @@
+A small patch found among Ubuntu and Debian ports of Ekiga.
+
+ -mi
+
+--- lib/gmconf/gmconf-glib.c 2007-09-18 09:00:21.000000000 +0000
++++ lib/gmconf/gmconf-glib.c 2007-10-06 18:34:01.000000000 +0000
+@@ -1473,7 +1473,7 @@
+ }
+
+ gboolean
+-gm_conf_is_key_writable (gchar *key)
++gm_conf_is_key_writable (const gchar *key)
+ {
+ g_return_val_if_fail (key != NULL, FALSE);
+