aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-10 05:43:02 +0800
committerbapt <bapt@FreeBSD.org>2013-03-10 05:43:02 +0800
commit11cdd557db2e22c7f1ad5e873d0a4397068caf5e (patch)
treebd32ed7f7e7b64a00aa12cc9947ea970c460d843
parent6607e5826c610a31e5dfd291ea1f5b1a83ff6131 (diff)
downloadfreebsd-ports-gnome-11cdd557db2e22c7f1ad5e873d0a4397068caf5e.tar.gz
freebsd-ports-gnome-11cdd557db2e22c7f1ad5e873d0a4397068caf5e.tar.zst
freebsd-ports-gnome-11cdd557db2e22c7f1ad5e873d0a4397068caf5e.zip
Get rid of XAWVER option in bsd.port.mk it does not need to be specified there also remove a useless global XAWVER PLIST_SUB
-rw-r--r--Mk/bsd.port.mk3
-rw-r--r--comms/acfax/Makefile8
-rw-r--r--devel/pdcurses-the/Makefile10
-rw-r--r--devel/pdcurses/Makefile10
-rw-r--r--editors/emacs21/Makefile8
-rw-r--r--editors/emacs22/Makefile8
-rw-r--r--editors/emacs23/Makefile2
-rw-r--r--editors/xemacs-devel-mule/Makefile8
-rw-r--r--editors/xemacs/Makefile8
-rw-r--r--editors/xemacs21-mule/Makefile8
-rw-r--r--emulators/vice/Makefile2
-rw-r--r--games/3dc/Makefile8
-rw-r--r--games/xfrisk/Makefile8
-rw-r--r--games/xmine/Makefile6
-rw-r--r--x11-toolkits/Xaw3d/Makefile1
-rw-r--r--x11-toolkits/Xaw3d/pkg-plist2
-rw-r--r--x11-toolkits/neXtaw/Makefile8
-rw-r--r--x11-toolkits/neXtaw/pkg-plist2
18 files changed, 31 insertions, 79 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 3aa068d3f0cb..57a58ad68c39 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1976,11 +1976,8 @@ MAKE_ENV+= DISPLAY="localhost:1001"
.endif
.endif
-XAWVER= 8
PKG_IGNORE_DEPENDS?= 'this_port_does_not_exist'
-PLIST_SUB+= XAWVER=${XAWVER}
-
_GL_gl_LIB_DEPENDS= GL.1:${PORTSDIR}/graphics/libGL
_GL_glew_LIB_DEPENDS= GLEW.1:${PORTSDIR}/graphics/glew
_GL_glu_LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU
diff --git a/comms/acfax/Makefile b/comms/acfax/Makefile
index a90c68f09d7f..16e564ae75b2 100644
--- a/comms/acfax/Makefile
+++ b/comms/acfax/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: acfax
-# Date created: 20 February 2002
-# Whom: Darren <igla@batterybackups.net>
-#
+# Created by: Darren <igla@batterybackups.net>
# $FreeBSD$
-#
PORTNAME= acfax
PORTVERSION= 0.981011
@@ -15,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0.//}
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Receive faxes using sound card and radio
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
PLIST_FILES= bin/acfax
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/pdcurses-the/Makefile b/devel/pdcurses-the/Makefile
index 17618ad20dae..b01f79727dc2 100644
--- a/devel/pdcurses-the/Makefile
+++ b/devel/pdcurses-the/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pdcurses
-# Date created: 1 Jul 2006
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= pdcurses
PORTVERSION= 3.2
@@ -36,12 +32,12 @@ CONFIGURE_ARGS+=--enable-${opt:L}
.endfor
.if ${PORT_OPTIONS:MNEXTAW}
-LIB_DEPENDS+= neXtaw.${XAWVER}:${PORTSDIR}/x11-toolkits/neXtaw
+LIB_DEPENDS+= neXtaw:${PORTSDIR}/x11-toolkits/neXtaw
CONFIGURE_ARGS+=--with-nextaw
.endif
.if ${PORT_OPTIONS:MXAW3D}
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-xaw3d
.endif
diff --git a/devel/pdcurses/Makefile b/devel/pdcurses/Makefile
index ff2e55f77538..d5f273714598 100644
--- a/devel/pdcurses/Makefile
+++ b/devel/pdcurses/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pdcurses
-# Date created: 1 Jul 2006
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= pdcurses
PORTVERSION= 3.4
@@ -35,12 +31,12 @@ CONFIGURE_ARGS+=--enable-${opt:L}
.endfor
.if ${PORT_OPTIONS:MNEXTAW}
-LIB_DEPENDS+= neXtaw.${XAWVER}:${PORTSDIR}/x11-toolkits/neXtaw
+LIB_DEPENDS+= neXtaw:${PORTSDIR}/x11-toolkits/neXtaw
CONFIGURE_ARGS+=--with-nextaw
.endif
.if ${PORT_OPTIONS:MXAW3D}
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-xaw3d
.endif
diff --git a/editors/emacs21/Makefile b/editors/emacs21/Makefile
index d199163f5a69..d7ee891b3e85 100644
--- a/editors/emacs21/Makefile
+++ b/editors/emacs21/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: GNU emacs
-# Date created: 11 October 2001
-# Whom: MANTANI Nobutaka <nobutaka@nobutaka.com>
-#
+# Created by: MANTANI Nobutaka <nobutaka@nobutaka.com>
# $FreeBSD$
-#
PORTNAME= emacs
PORTVERSION= 21.3
@@ -26,7 +22,7 @@ CONFLICTS= emacs-19.* emacs-22.* emacs-23.* emacs-24.* \
xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]*
.if !defined(WITHOUT_X11)
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d \
+LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d \
jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
gif.5:${PORTSDIR}/graphics/giflib \
diff --git a/editors/emacs22/Makefile b/editors/emacs22/Makefile
index ed71825ea16f..5db92c31dead 100644
--- a/editors/emacs22/Makefile
+++ b/editors/emacs22/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: GNU emacs
-# Date created: 11 October 2001
-# Whom: MANTANI Nobutaka <nobutaka@nobutaka.com>
-#
+# Created by: MANTANI Nobutaka <nobutaka@nobutaka.com>
# $FreeBSD$
-#
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
@@ -18,7 +14,7 @@ COMMENT= GNU editing macros
.if !defined(WITHOUT_X11)
.if defined(WITHOUT_GTK)
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
.endif
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 8737a9dd769f..3910bcccc02b 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -95,7 +95,7 @@ CONFIGURE_ARGS+= --without-rsvg
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --with-x-toolkit=gtk
.elif ${PORT_OPTIONS:MXAW3D}
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+= --with-x-toolkit=athena
.elif ${PORT_OPTIONS:MXAW}
USE_XORG= xaw
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index b74841065459..244c49669f1d 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: X-Emacs with mule
-# Date created: 3 Jan 2002
-# Whom: KIRIYAMA Kazuhiko<kiri@FreeBSD.org>
-#
+# Created by: KIRIYAMA Kazuhiko<kiri@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= xemacs-devel-mule
PORTVERSION= ${XEMACS_VER:S/-/./}
@@ -172,7 +168,7 @@ WITH_DIALOGS?= --enable-dialogs=athena
WITH_WIDGETS?= --enable-widgets=athena
.if defined(WITH_XAW3D)
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-athena=3d
.else
CONFIGURE_ARGS+=--with-athena=xaw
diff --git a/editors/xemacs/Makefile b/editors/xemacs/Makefile
index a104760a74ae..7d8dbfcaa7df 100644
--- a/editors/xemacs/Makefile
+++ b/editors/xemacs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: X-Emacs
-# Date created: 25 Oct 2001
-# Whom: Gary Jennejohn (gj@FreeBSD.org)
-#
+# Created by: Gary Jennejohn (gj@FreeBSD.org)
# $FreeBSD$
-#
PORTNAME= xemacs
PORTVERSION= ${XEMACS_VER}
@@ -108,7 +104,7 @@ WITH_SCROLLBARS= --with-scrollbars=athena
WITH_DIALOGS= --with-dialogs=athena
WITH_WIDGETS= --with-widgets=athena
.if defined(WITH_XAW3D)
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+= --with-athena=3d
.endif
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index c4bb2277b0c2..5dcc16919c7d 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XEmacs with Mule
-# Date created: 8 Dec 1999
-# Whom: KIRIYAMA Kazuhiko<kiri@pis.toba-cmt.ac.jp>
-#
+# Created by: KIRIYAMA Kazuhiko<kiri@pis.toba-cmt.ac.jp>
# $FreeBSD$
-#
PORTNAME= xemacs-mule
PORTVERSION= ${XEMACS_VER}
@@ -139,7 +135,7 @@ WITH_DIALOGS?= --with-dialogs=athena
WITH_WIDGETS?= --with-widgets=athena
.if defined(WITH_XAW3D)
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-athena=3d
.else
CONFIGURE_ARGS+=--with-athena=xaw
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index ca4f0d9d7ab1..ba42dd4a25e2 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
gif:${PORTSDIR}/graphics/giflib \
mp3lame:${PORTSDIR}/audio/lame
.if defined(VICE_WITH_XAW3D)
-LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS+= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
.endif
RESTRICTED= "ROMs are copyrighted by Commodore Business Machines"
diff --git a/games/3dc/Makefile b/games/3dc/Makefile
index b1214d49cdd9..f9d0790949ef 100644
--- a/games/3dc/Makefile
+++ b/games/3dc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: 3Dc
-# Date created: 2 May 1998
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= 3dc
PORTVERSION= 0.8.1
@@ -18,7 +14,7 @@ COMMENT= 3-Dimensional Chess for X Window System
LICENSE= GPLv2
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
USE_PERL5_BUILD=yes
USE_XORG= x11 xaw xext xmu xpm xt
diff --git a/games/xfrisk/Makefile b/games/xfrisk/Makefile
index afc90a0e5a12..eb91f70063b3 100644
--- a/games/xfrisk/Makefile
+++ b/games/xfrisk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xfrisk
-# Date created: 20 April 1997
-# Whom: Matthew Hunt <mph@pobox.com>
-#
+# Created by: Matthew Hunt <mph@pobox.com>
# $FreeBSD$
-#
PORTNAME= xfrisk
PORTVERSION= 1.2
@@ -16,7 +12,7 @@ DISTNAME= XFrisk-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A multi-player networked Risk game for X11
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
NO_CDROM= Possible trademark infringement
diff --git a/games/xmine/Makefile b/games/xmine/Makefile
index 193995adef95..ecb9f8f71e55 100644
--- a/games/xmine/Makefile
+++ b/games/xmine/Makefile
@@ -1,6 +1,4 @@
-# New ports collection makefile for: xmine
-# Date created: 25 December 1994
-# Whom: joerg
+# Created by: joerg
#
# $FreeBSD$
#
@@ -17,7 +15,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-Xaw
MAINTAINER= joerg@FreeBSD.org
COMMENT= The `Athena' port of the xminesweeper game
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
USE_IMAKE= yes
USE_XORG= x11 xaw xext xmu xt xpm sm ice
diff --git a/x11-toolkits/Xaw3d/Makefile b/x11-toolkits/Xaw3d/Makefile
index 76994652ab81..f1b88f2fb1df 100644
--- a/x11-toolkits/Xaw3d/Makefile
+++ b/x11-toolkits/Xaw3d/Makefile
@@ -20,6 +20,7 @@ USE_XORG= x11 xext xmu xt sm ice xpm
USE_LDCONFIG= yes
SUB_FILES= pkg-message
+XAWVER= 8
SUB_LIST= XAWVER="${XAWVER}"
.include <bsd.port.pre.mk>
diff --git a/x11-toolkits/Xaw3d/pkg-plist b/x11-toolkits/Xaw3d/pkg-plist
index 2e78b66f8468..4edef4960ca4 100644
--- a/x11-toolkits/Xaw3d/pkg-plist
+++ b/x11-toolkits/Xaw3d/pkg-plist
@@ -1,6 +1,6 @@
lib/libXaw3d.a
lib/libXaw3d.so
-lib/libXaw3d.so.%%XAWVER%%
+lib/libXaw3d.so.8
include/X11/Xaw3d/AllWidgets.h
include/X11/Xaw3d/AsciiSink.h
include/X11/Xaw3d/AsciiSinkP.h
diff --git a/x11-toolkits/neXtaw/Makefile b/x11-toolkits/neXtaw/Makefile
index b00fae488cf3..a0e383cef95d 100644
--- a/x11-toolkits/neXtaw/Makefile
+++ b/x11-toolkits/neXtaw/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: neXtaw
-# Date created: 16 January 1997
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
-#
+# Created by: Thomas Gellekum <tg@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= neXtaw
PORTVERSION= 0.15.1
@@ -22,7 +18,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
post-patch:
- @${REINPLACE_CMD} -e 's|version-info.*$$|version-info ${XAWVER}:0:0|g' \
+ @${REINPLACE_CMD} -e 's|version-info.*$$|version-info 8:0:0|g' \
${WRKSRC}/X11/neXtaw/Makefile.in
post-install:
diff --git a/x11-toolkits/neXtaw/pkg-plist b/x11-toolkits/neXtaw/pkg-plist
index 519ffcdc9e1e..8065e4e33303 100644
--- a/x11-toolkits/neXtaw/pkg-plist
+++ b/x11-toolkits/neXtaw/pkg-plist
@@ -82,7 +82,7 @@ include/X11/neXtaw/laygram.h
lib/libneXtaw.a
lib/libneXtaw.la
lib/libneXtaw.so
-lib/libneXtaw.so.%%XAWVER%%
+lib/libneXtaw.so.8
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/FAQ
%%PORTDOCS%%%%DOCSDIR%%/README