aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-09-26 16:59:45 +0800
committerclsung <clsung@FreeBSD.org>2006-09-26 16:59:45 +0800
commit11f46442ce94c671744436724863fbe4b099adcd (patch)
treeceb3c8ca5b139db002c2d1cf0a468c3d8c2994bd
parent026d2e40505b0e0a70c9f035a1e837850f6a85a6 (diff)
downloadfreebsd-ports-gnome-11f46442ce94c671744436724863fbe4b099adcd.tar.gz
freebsd-ports-gnome-11f46442ce94c671744436724863fbe4b099adcd.tar.zst
freebsd-ports-gnome-11f46442ce94c671744436724863fbe4b099adcd.zip
Add p5-XML-Compile 0.05, compilation based XML processing.
PR: ports/102626 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Compile/Makefile33
-rw-r--r--textproc/p5-XML-Compile/distinfo3
-rw-r--r--textproc/p5-XML-Compile/pkg-descr24
-rw-r--r--textproc/p5-XML-Compile/pkg-plist25
5 files changed, 86 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b33a4549a92f..c6f36341c49a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -566,6 +566,7 @@
SUBDIR += p5-XML-AutoWriter
SUBDIR += p5-XML-Catalog
SUBDIR += p5-XML-Clean
+ SUBDIR += p5-XML-Compile
SUBDIR += p5-XML-DBMS
SUBDIR += p5-XML-DOM
SUBDIR += p5-XML-DOM-Lite
diff --git a/textproc/p5-XML-Compile/Makefile b/textproc/p5-XML-Compile/Makefile
new file mode 100644
index 000000000000..575531a6f65d
--- /dev/null
+++ b/textproc/p5-XML-Compile/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-XML-Compile
+# Date created: 2006-08-29
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Compile
+PORTVERSION= 0.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Compilation based XML processing
+
+RUN_DEPENDS= p5-XML-LibXML>=1.58:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-Regexp-Common>=2.00:${PORTSDIR}/textproc/p5-Regexp-Common
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Compile.3 XML::Compile::Schema.3 \
+ XML::Compile::Schema::BuiltInFacets.3 \
+ XML::Compile::Schema::BuiltInStructs.3 \
+ XML::Compile::Schema::BuiltInTypes.3 \
+ XML::Compile::Schema::Instance.3 \
+ XML::Compile::Schema::NameSpaces.3 \
+ XML::Compile::Schema::Specs.3 \
+ XML::Compile::Schema::Translate.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Compile/distinfo b/textproc/p5-XML-Compile/distinfo
new file mode 100644
index 000000000000..d049016c7e0f
--- /dev/null
+++ b/textproc/p5-XML-Compile/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Compile-0.05.tar.gz) = 52fd320f9967ce3236bf5e2fe439a24f
+SHA256 (XML-Compile-0.05.tar.gz) = c9153fdfd398048d9d71180ae0bce9e7b0a0ee9f35677e2bc2c75efca11fa3d4
+SIZE (XML-Compile-0.05.tar.gz) = 49932
diff --git a/textproc/p5-XML-Compile/pkg-descr b/textproc/p5-XML-Compile/pkg-descr
new file mode 100644
index 000000000000..7e91f3aa29cf
--- /dev/null
+++ b/textproc/p5-XML-Compile/pkg-descr
@@ -0,0 +1,24 @@
+Many applications which process data-centric XML do that based
+on a nice specification, expressed in an XML Schema.
+XML::Compile reads and writes XML data with the help of such
+schema's. On the Perl side, it uses a tree of nested hashes
+with the same structure.
+
+Where other Perl modules, like SOAP::WSDL help you using these
+schema's (often with a lot of run-time (XPath) searches), this
+module takes a different approach: in stead of run-time
+processing of the specification, it will first compile the
+expected structure into real Perl, and then use that to process
+the data.
+
+There are many perl modules with the same as this one: translate
+between XML and nested hashes. However, there are a few serious
+differences: because the schema is used here, we make sure we
+only handle correct data. Data-types are formatted and processed
+correctly; for instance, integer does accept huge values
+(at least 18 digits) as the specification prescribes. Also more
+complex data-types like list, union, and substitutionGroup
+(unions on complex type level) are supported, which is rarely the
+case in other modules.
+
+WWW: http://search.cpan.org/dist/XML-Compile/
diff --git a/textproc/p5-XML-Compile/pkg-plist b/textproc/p5-XML-Compile/pkg-plist
new file mode 100644
index 000000000000..ad2c3f84db62
--- /dev/null
+++ b/textproc/p5-XML-Compile/pkg-plist
@@ -0,0 +1,25 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/.packlist
+%%SITE_PERL%%/XML/Compile/Schema/Translate.pod
+%%SITE_PERL%%/XML/Compile/Schema/Translate.pm
+%%SITE_PERL%%/XML/Compile/Schema/Specs.pod
+%%SITE_PERL%%/XML/Compile/Schema/Specs.pm
+%%SITE_PERL%%/XML/Compile/Schema/NameSpaces.pod
+%%SITE_PERL%%/XML/Compile/Schema/NameSpaces.pm
+%%SITE_PERL%%/XML/Compile/Schema/Instance.pod
+%%SITE_PERL%%/XML/Compile/Schema/Instance.pm
+%%SITE_PERL%%/XML/Compile/Schema/BuiltInTypes.pod
+%%SITE_PERL%%/XML/Compile/Schema/BuiltInTypes.pm
+%%SITE_PERL%%/XML/Compile/Schema/BuiltInStructs.pod
+%%SITE_PERL%%/XML/Compile/Schema/BuiltInStructs.pm
+%%SITE_PERL%%/XML/Compile/Schema/BuiltInFacets.pod
+%%SITE_PERL%%/XML/Compile/Schema/BuiltInFacets.pm
+%%SITE_PERL%%/XML/Compile/Schema.pod
+%%SITE_PERL%%/XML/Compile/Schema.pm
+%%SITE_PERL%%/XML/Compile.pod
+%%SITE_PERL%%/XML/Compile.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/Compile/Schema
+@dirrmtry %%SITE_PERL%%/XML/Compile
+@dirrmtry %%SITE_PERL%%/XML