aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2004-10-23 14:51:33 +0800
committermezz <mezz@FreeBSD.org>2004-10-23 14:51:33 +0800
commit13113516b98a8e8723f24371301ab3b18270d7e2 (patch)
tree3aacf309475953703ddf2dc0e84815890224cb41
parentcfbabfa6921f1fa8e022103973b83109e204a94c (diff)
downloadfreebsd-ports-gnome-13113516b98a8e8723f24371301ab3b18270d7e2.tar.gz
freebsd-ports-gnome-13113516b98a8e8723f24371301ab3b18270d7e2.tar.zst
freebsd-ports-gnome-13113516b98a8e8723f24371301ab3b18270d7e2.zip
GTorrentViewer is a GTK2-based viewer and editor for BitTorrent meta files. It
is able to retrieve information from trackers, check files, show detailed information, and modify .torrent files without having to start downloading. WWW: http://gtorrentviewer.sourceforge.net/ PR: ports/72766 Submitted by: Michael Johnson <ahze@ahze.net>
-rw-r--r--net-p2p/gtorrentviewer/Makefile45
-rw-r--r--net-p2p/gtorrentviewer/distinfo2
-rw-r--r--net-p2p/gtorrentviewer/pkg-descr5
-rw-r--r--net-p2p/gtorrentviewer/pkg-plist22
-rw-r--r--net/Makefile1
-rw-r--r--net/gtorrentviewer/Makefile45
-rw-r--r--net/gtorrentviewer/distinfo2
-rw-r--r--net/gtorrentviewer/pkg-descr5
-rw-r--r--net/gtorrentviewer/pkg-plist22
9 files changed, 149 insertions, 0 deletions
diff --git a/net-p2p/gtorrentviewer/Makefile b/net-p2p/gtorrentviewer/Makefile
new file mode 100644
index 000000000000..ec30780bbf76
--- /dev/null
+++ b/net-p2p/gtorrentviewer/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: gtorrentviewer
+# Date created: 2004-10-16
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtorrentviewer
+PORTVERSION= 0.2a
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= GTorrentViewer-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GTK+2 viewer and editor for BitTorrent meta files
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+
+USE_GNOME= gtk20 gnomehier
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
+
+MAN1= gtorrentviewer.1
+DOCS= AUTHORS COPYING ChangeLog README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]datadir[)]/applications|(prefix)/share/gnome/applications|g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|[(]datadir[)]/pixmaps|(prefix)/share/gnome/pixmaps|g' \
+ ${WRKSRC}/pixmaps/Makefile.in
+ @${REINPLACE_CMD} -e 's|SYSTEM_PIXMAPS_DIR|PIXMAPS_DIR|g' \
+ ${WRKSRC}/src/mainwindow.h
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-p2p/gtorrentviewer/distinfo b/net-p2p/gtorrentviewer/distinfo
new file mode 100644
index 000000000000..a6b1d1106a46
--- /dev/null
+++ b/net-p2p/gtorrentviewer/distinfo
@@ -0,0 +1,2 @@
+MD5 (GTorrentViewer-0.2a.tar.gz) = 7d0e33e184d3c3c14e1942d38c1cbb68
+SIZE (GTorrentViewer-0.2a.tar.gz) = 213301
diff --git a/net-p2p/gtorrentviewer/pkg-descr b/net-p2p/gtorrentviewer/pkg-descr
new file mode 100644
index 000000000000..bde2695b2101
--- /dev/null
+++ b/net-p2p/gtorrentviewer/pkg-descr
@@ -0,0 +1,5 @@
+GTorrentViewer is a GTK2-based viewer and editor for BitTorrent meta files. It
+is able to retrieve information from trackers, check files, show detailed
+information, and modify .torrent files without having to start downloading.
+
+WWW: http://gtorrentviewer.sourceforge.net/
diff --git a/net-p2p/gtorrentviewer/pkg-plist b/net-p2p/gtorrentviewer/pkg-plist
new file mode 100644
index 000000000000..10a13f4299b1
--- /dev/null
+++ b/net-p2p/gtorrentviewer/pkg-plist
@@ -0,0 +1,22 @@
+bin/gtorrentviewer
+share/GTorrentViewer/README
+share/GTorrentViewer/pixmaps/about.png
+share/GTorrentViewer/pixmaps/dictionary.png
+share/GTorrentViewer/pixmaps/error.png
+share/GTorrentViewer/pixmaps/gtorrentviewer.png
+share/GTorrentViewer/pixmaps/gtorrentviewer.xpm
+share/GTorrentViewer/pixmaps/integer.png
+share/GTorrentViewer/pixmaps/list.png
+share/GTorrentViewer/pixmaps/ok.png
+share/GTorrentViewer/pixmaps/string.png
+share/GTorrentViewer/pixmaps/warning.png
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/gnome/applications/gtorrentviewer.desktop
+share/gnome/pixmaps/gtorrentviewer.png
+share/gnome/pixmaps/gtorrentviewer.xpm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/GTorrentViewer/pixmaps
+@dirrm share/GTorrentViewer
diff --git a/net/Makefile b/net/Makefile
index 25a0aafbf9dd..00ba93bd582b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -194,6 +194,7 @@
SUBDIR += gtk-gnutella
SUBDIR += gtkhx
SUBDIR += gtkyahoo
+ SUBDIR += gtorrentviewer
SUBDIR += gutenfetch
SUBDIR += gyach
SUBDIR += hagelslag
diff --git a/net/gtorrentviewer/Makefile b/net/gtorrentviewer/Makefile
new file mode 100644
index 000000000000..ec30780bbf76
--- /dev/null
+++ b/net/gtorrentviewer/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: gtorrentviewer
+# Date created: 2004-10-16
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtorrentviewer
+PORTVERSION= 0.2a
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= GTorrentViewer-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GTK+2 viewer and editor for BitTorrent meta files
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+
+USE_GNOME= gtk20 gnomehier
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
+
+MAN1= gtorrentviewer.1
+DOCS= AUTHORS COPYING ChangeLog README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]datadir[)]/applications|(prefix)/share/gnome/applications|g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|[(]datadir[)]/pixmaps|(prefix)/share/gnome/pixmaps|g' \
+ ${WRKSRC}/pixmaps/Makefile.in
+ @${REINPLACE_CMD} -e 's|SYSTEM_PIXMAPS_DIR|PIXMAPS_DIR|g' \
+ ${WRKSRC}/src/mainwindow.h
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/gtorrentviewer/distinfo b/net/gtorrentviewer/distinfo
new file mode 100644
index 000000000000..a6b1d1106a46
--- /dev/null
+++ b/net/gtorrentviewer/distinfo
@@ -0,0 +1,2 @@
+MD5 (GTorrentViewer-0.2a.tar.gz) = 7d0e33e184d3c3c14e1942d38c1cbb68
+SIZE (GTorrentViewer-0.2a.tar.gz) = 213301
diff --git a/net/gtorrentviewer/pkg-descr b/net/gtorrentviewer/pkg-descr
new file mode 100644
index 000000000000..bde2695b2101
--- /dev/null
+++ b/net/gtorrentviewer/pkg-descr
@@ -0,0 +1,5 @@
+GTorrentViewer is a GTK2-based viewer and editor for BitTorrent meta files. It
+is able to retrieve information from trackers, check files, show detailed
+information, and modify .torrent files without having to start downloading.
+
+WWW: http://gtorrentviewer.sourceforge.net/
diff --git a/net/gtorrentviewer/pkg-plist b/net/gtorrentviewer/pkg-plist
new file mode 100644
index 000000000000..10a13f4299b1
--- /dev/null
+++ b/net/gtorrentviewer/pkg-plist
@@ -0,0 +1,22 @@
+bin/gtorrentviewer
+share/GTorrentViewer/README
+share/GTorrentViewer/pixmaps/about.png
+share/GTorrentViewer/pixmaps/dictionary.png
+share/GTorrentViewer/pixmaps/error.png
+share/GTorrentViewer/pixmaps/gtorrentviewer.png
+share/GTorrentViewer/pixmaps/gtorrentviewer.xpm
+share/GTorrentViewer/pixmaps/integer.png
+share/GTorrentViewer/pixmaps/list.png
+share/GTorrentViewer/pixmaps/ok.png
+share/GTorrentViewer/pixmaps/string.png
+share/GTorrentViewer/pixmaps/warning.png
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/gnome/applications/gtorrentviewer.desktop
+share/gnome/pixmaps/gtorrentviewer.png
+share/gnome/pixmaps/gtorrentviewer.xpm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/GTorrentViewer/pixmaps
+@dirrm share/GTorrentViewer