aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2010-07-01 11:29:14 +0800
committervanilla <vanilla@FreeBSD.org>2010-07-01 11:29:14 +0800
commit133812ea34fb2620f4179fd71068fbc1363fb4dc (patch)
tree068d59580b3c25804802f2e4fdd2ab4ccb1fb60c
parent024bd0a232453e47979e8cbfa5e1e29ac02b9ec5 (diff)
downloadfreebsd-ports-gnome-133812ea34fb2620f4179fd71068fbc1363fb4dc.tar.gz
freebsd-ports-gnome-133812ea34fb2620f4179fd71068fbc1363fb4dc.tar.zst
freebsd-ports-gnome-133812ea34fb2620f4179fd71068fbc1363fb4dc.zip
make clang happy.
Feature safe: yes
-rw-r--r--devel/protobuf/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/protobuf/Makefile b/devel/protobuf/Makefile
index 62e2116b936d..f0a355cede97 100644
--- a/devel/protobuf/Makefile
+++ b/devel/protobuf/Makefile
@@ -8,6 +8,7 @@
PORTNAME= protobuf
PORTVERSION= 2.3.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -20,6 +21,9 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= gnomehack pkgconfig
+post-patch:
+ @${REINPLACE_CMD} -e 's|GREP "\\-L"|GREP "bin/ld"|g' ${WRKSRC}/configure
+
tests: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)