aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-11-02 02:56:19 +0800
committermakc <makc@FreeBSD.org>2014-11-02 02:56:19 +0800
commit13d49ff2008797814d9ddaa625ad44bcb2ba9b28 (patch)
treed4fbfb04f4ac1ae58adc275627969fea6f42bfef
parent3ad783a5ae3279d8bc9a1d0881f31036b73c4ec9 (diff)
downloadfreebsd-ports-gnome-13d49ff2008797814d9ddaa625ad44bcb2ba9b28.tar.gz
freebsd-ports-gnome-13d49ff2008797814d9ddaa625ad44bcb2ba9b28.tar.zst
freebsd-ports-gnome-13d49ff2008797814d9ddaa625ad44bcb2ba9b28.zip
www/qupzilla:
- update to 1.8.3 and add DEBUG option - pass maintainership to submitter while I'm here: - amend COMMENT - convert to USES=execinfo - convert to options helpers PR: 194310 Submitted by: matthew@reztek.cz
-rw-r--r--www/qupzilla/Makefile37
-rw-r--r--www/qupzilla/distinfo4
-rw-r--r--www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h15
-rw-r--r--www/qupzilla/pkg-plist3
4 files changed, 30 insertions, 29 deletions
diff --git a/www/qupzilla/Makefile b/www/qupzilla/Makefile
index b708eb9ede76..1e94cf08bcc4 100644
--- a/www/qupzilla/Makefile
+++ b/www/qupzilla/Makefile
@@ -1,47 +1,38 @@
# $FreeBSD$
PORTNAME= qupzilla
-PORTVERSION= 1.8.0
+PORTVERSION= 1.8.3
CATEGORIES= www
MASTER_SITES= https://github.com/QupZilla/${PORTNAME}/releases/download/v${PORTVERSION}/
DISTNAME= QupZilla-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Modern web browser based on WebKit core and Qt Framework
+MAINTAINER= matthew@reztek.cz
+COMMENT= Web browser based on WebKit engine and Qt Framework
LICENSE= GPLv3
-LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell \
- libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libhunspell-1.3.so:${PORTSDIR}/textproc/hunspell
-USES= desktop-file-utils pkgconfig qmake tar:xz
+USES= desktop-file-utils execinfo pkgconfig qmake tar:xz
USE_QT4= corelib gui moc_build rcc_build uic_build webkit \
xml script sql network imageformats_run linguist_build
-QMAKE_ENV= QUPZILLA_PREFIX=${PREFIX}/
+CONFIGURE_ENV= QUPZILLA_PREFIX=${PREFIX}/
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
+PLIST_SUB= VERSION=${PORTVERSION}
-OPTIONS_DEFINE= DBUS GNOMEKEYRING KWALLET
+OPTIONS_DEFINE= DBUS DEBUG GNOMEKEYRING KWALLET
OPTIONS_DEFAULT=DBUS
OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+DBUS_USE= QT4=dbus
+DBUS_CONFIGURE_ENV_OFF= DISABLE_DBUS="true"
-.if ${PORT_OPTIONS:MGNOMEKEYRING}
-LIB_DEPENDS+= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
-QMAKE_ENV+= GNOME_INTEGRATION="true"
-.endif
+GNOMEKEYRING_LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
+GNOMEKEYRING_CONFIGURE_ENV= GNOME_INTEGRATION="true"
-.if ${PORT_OPTIONS:MKWALLET}
-LIB_DEPENDS+= libkdeui.so:${PORTSDIR}/x11/kdelibs4
-QMAKE_ENV+= KDE_INTEGRATION="true"
-.endif
-
-.if ${PORT_OPTIONS:MDBUS}
-USE_QT4+= dbus
-.else
-QMAKE_ENV+= DISABLE_DBUS="true"
-.endif
+KWALLET_USE= KDE4=kdelibs
+KWALLET_CONFIGURE_ENV= KDE_INTEGRATION="true"
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${LOCALBASE}|g' \
diff --git a/www/qupzilla/distinfo b/www/qupzilla/distinfo
index d3e0e558d11f..9cca0b674331 100644
--- a/www/qupzilla/distinfo
+++ b/www/qupzilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (QupZilla-1.8.0.tar.xz) = c4089d14254e87b58a5f2bfb0e393cd6bae0b2bd508da19a92c12989b7e90908
-SIZE (QupZilla-1.8.0.tar.xz) = 3092300
+SHA256 (QupZilla-1.8.3.tar.xz) = d3551288b27af952bb6d9d0c8f3bf8d3e849722b23da0193433b1d0bb88469be
+SIZE (QupZilla-1.8.3.tar.xz) = 3093840
diff --git a/www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h b/www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h
index 1960ad34c8f2..5b4ece17f483 100644
--- a/www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h
+++ b/www/qupzilla/files/patch-src__lib__3rdparty__processinfo.h
@@ -1,11 +1,20 @@
--- src/lib/3rdparty/processinfo.h.orig 2014-09-26 12:35:35.000000000 +0400
+++ src/lib/3rdparty/processinfo.h 2014-09-26 23:04:10.000000000 +0400
-@@ -18,6 +18,8 @@
+@@ -18,16 +18,12 @@
#ifndef PROCESSINFO_H
#define PROCESSINFO_H
-+#include <QtGlobal>
-+
+-#include <QtGlobal>
++#include "qzcommon.h"
+
#if defined(Q_OS_UNIX) && !defined(Q_OS_MAC)
#include <sys/types.h>
#endif
+
+-#include <QString>
+-
+-#include "qzcommon.h"
+-
+ /*
+ * Code used from http://ubuntuforums.org/showpost.php?p=6593782&postcount=5
+ * written by user WitchCraft
diff --git a/www/qupzilla/pkg-plist b/www/qupzilla/pkg-plist
index 2dcb3e76a2a4..cf74947a3d01 100644
--- a/www/qupzilla/pkg-plist
+++ b/www/qupzilla/pkg-plist
@@ -2,7 +2,7 @@ bin/qupzilla
lib/libQupZilla.so
lib/libQupZilla.so.1
lib/libQupZilla.so.1.8
-lib/libQupZilla.so.1.8.0
+lib/libQupZilla.so.%%VERSION%%
lib/qupzilla/libAccessKeysNavigation.so
lib/qupzilla/libAutoScroll.so
%%GNOMEKEYRING%%lib/qupzilla/libGnomeKeyringPasswords.so
@@ -11,6 +11,7 @@ lib/qupzilla/libGreaseMonkey.so
lib/qupzilla/libMouseGestures.so
lib/qupzilla/libPIM.so
lib/qupzilla/libStatusBarIcons.so
+%%DEBUG%%lib/qupzilla/libTestPlugin.so
share/appdata/qupzilla.appdata.xml
share/applications/qupzilla.desktop
share/bash-completion/completions/qupzilla