aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-01-11 19:54:29 +0800
committeredwin <edwin@FreeBSD.org>2004-01-11 19:54:29 +0800
commit1449212efbd5db5ddc2b2fb386380da4cb9d4c0f (patch)
tree48c38d1b2c3f85beaa9a26b65943ba68d055a46e
parent9b36ee0aa94ca70f0dd60fcbe806fce55c485f11 (diff)
downloadfreebsd-ports-gnome-1449212efbd5db5ddc2b2fb386380da4cb9d4c0f.tar.gz
freebsd-ports-gnome-1449212efbd5db5ddc2b2fb386380da4cb9d4c0f.tar.zst
freebsd-ports-gnome-1449212efbd5db5ddc2b2fb386380da4cb9d4c0f.zip
ProFTPd port does not install docs for optional modules
The ftp/proftpd port creates /usr/local/share/doc/proftpd and installs the two HTML files from ProFTPd's docs directory into it. But it doesn't copy the html files from the contrib directory which describe the optional modules (mod_tls, mod_radius, etc.) and their configuration options. Also moved the portdocs to the PORTDOCS environment variable. PR: ports/56511 Submitted by: Pat Lashley <patl+freebsd@volant.org> Reviewed by: maintainer timeout
-rw-r--r--ftp/proftpd-devel/Makefile15
-rw-r--r--ftp/proftpd-devel/pkg-plist3
-rw-r--r--ftp/proftpd/Makefile15
-rw-r--r--ftp/proftpd/pkg-plist3
4 files changed, 26 insertions, 10 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index 16a4bc2f5457..4569b54c7ad4 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proftpd
PORTVERSION= 1.2.9
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.net/distrib/source/ \
ftp://ftp.stikman.com/pub/proftpd/ \
@@ -31,6 +32,11 @@ MAN1= ftpcount.1 ftpwho.1 ftptop.1
MAN5= xferlog.5
MAN8= proftpd.8 ftpshut.8
+PORTDOCSdoc= Configuration.html faq.html
+PORTDOCScontrib=mod_ifsession.html mod_radius.html mod_rewrite.html \
+ mod_tls.html mod_wrap.html ftpasswd.html
+PORTDOCS= ${PORTDOCSdoc} ${PORTDOCScontrib}
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -154,10 +160,15 @@ do-install:
${WRKSRC}/sample-configurations/basic.conf ${PREFIX}/etc/proftpd.conf; \
fi
@${INSTALL_SCRIPT} ${WRKSRC}/proftpd.sh ${PREFIX}/etc/rc.d/proftpd${RC_SUFX}
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/proftpd
- @${INSTALL_DATA} ${WRKSRC}/doc/Configuration.html ${PREFIX}/share/doc/proftpd
- @${INSTALL_DATA} ${WRKSRC}/doc/faq.html ${PREFIX}/share/doc/proftpd
+.for f in ${PORTDOCSdoc}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${PREFIX}/share/doc/proftpd
+.endfor
+.for f in ${PORTDOCScontrib}
+ @${INSTALL_DATA} ${WRKSRC}/contrib/${f} ${PREFIX}/share/doc/proftpd
+.endfor
.endif
.if !defined(WITHOUT_PAM)
diff --git a/ftp/proftpd-devel/pkg-plist b/ftp/proftpd-devel/pkg-plist
index 242c00f554f9..2418335488d6 100644
--- a/ftp/proftpd-devel/pkg-plist
+++ b/ftp/proftpd-devel/pkg-plist
@@ -7,6 +7,3 @@ etc/rc.d/proftpd%%RC_SUFX%%
@exec if [ ! -f %D/etc/proftpd.conf ] ; then cp -p %D/%F %B/proftpd.conf; fi
libexec/proftpd
sbin/ftpshut
-share/doc/proftpd/Configuration.html
-share/doc/proftpd/faq.html
-@dirrm share/doc/proftpd
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index 16a4bc2f5457..4569b54c7ad4 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= proftpd
PORTVERSION= 1.2.9
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.net/distrib/source/ \
ftp://ftp.stikman.com/pub/proftpd/ \
@@ -31,6 +32,11 @@ MAN1= ftpcount.1 ftpwho.1 ftptop.1
MAN5= xferlog.5
MAN8= proftpd.8 ftpshut.8
+PORTDOCSdoc= Configuration.html faq.html
+PORTDOCScontrib=mod_ifsession.html mod_radius.html mod_rewrite.html \
+ mod_tls.html mod_wrap.html ftpasswd.html
+PORTDOCS= ${PORTDOCSdoc} ${PORTDOCScontrib}
+
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -154,10 +160,15 @@ do-install:
${WRKSRC}/sample-configurations/basic.conf ${PREFIX}/etc/proftpd.conf; \
fi
@${INSTALL_SCRIPT} ${WRKSRC}/proftpd.sh ${PREFIX}/etc/rc.d/proftpd${RC_SUFX}
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/proftpd
- @${INSTALL_DATA} ${WRKSRC}/doc/Configuration.html ${PREFIX}/share/doc/proftpd
- @${INSTALL_DATA} ${WRKSRC}/doc/faq.html ${PREFIX}/share/doc/proftpd
+.for f in ${PORTDOCSdoc}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${PREFIX}/share/doc/proftpd
+.endfor
+.for f in ${PORTDOCScontrib}
+ @${INSTALL_DATA} ${WRKSRC}/contrib/${f} ${PREFIX}/share/doc/proftpd
+.endfor
.endif
.if !defined(WITHOUT_PAM)
diff --git a/ftp/proftpd/pkg-plist b/ftp/proftpd/pkg-plist
index 242c00f554f9..2418335488d6 100644
--- a/ftp/proftpd/pkg-plist
+++ b/ftp/proftpd/pkg-plist
@@ -7,6 +7,3 @@ etc/rc.d/proftpd%%RC_SUFX%%
@exec if [ ! -f %D/etc/proftpd.conf ] ; then cp -p %D/%F %B/proftpd.conf; fi
libexec/proftpd
sbin/ftpshut
-share/doc/proftpd/Configuration.html
-share/doc/proftpd/faq.html
-@dirrm share/doc/proftpd